The MU forums have moved to WordPress.org

Database Error on WP-MU install on Godaddy (20 posts)

  1. jesscon
    Member
    Posted 14 years ago #

    I am trying to install wp-mu but I get this error. How do I fix it thanks.

    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'WHERE domain = 'hot-cool-gadgets.com'' at line 1]
    SELECT * FROM WHERE domain = 'hot-cool-gadgets.com'

    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'WHERE site_id = 1 AND meta_key = 'site_name'' at line 1]
    SELECT meta_value FROM WHERE site_id = 1 AND meta_key = 'site_name'

    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'LIMIT 0,1' at line 1]
    SELECT blog_id FROM LIMIT 0,1

  2. jesscon
    Member
    Posted 14 years ago #

    anyone

  3. SteveAtty
    Member
    Posted 14 years ago #

    Hmm - its lost the table names.....

  4. jesscon
    Member
    Posted 14 years ago #

    I am new to all this mysql stuff, could you please explain a little more. Thanks

  5. SteveAtty
    Member
    Posted 14 years ago #

    When did you get this error?

  6. jesscon
    Member
    Posted 14 years ago #

    I got the error after I used the word press automatic install submit page where you enter your site and data base information.

  7. jesscon
    Member
    Posted 14 years ago #

  8. andrea_r
    Moderator
    Posted 14 years ago #

    It's spewing that error when the db connection info is wrong. reinstall.

    - db user should have ALL permissions on the db
    - db password should be more than 6 characters
    - make sure you put in the right db server location

  9. jesscon
    Member
    Posted 14 years ago #

    I have been reading this but how do change permissions on godaddy db.

  10. jesscon
    Member
    Posted 14 years ago #

    I see that the config file is generating all the information for the data base. Is there something beyond this that I need to do.

  11. andrea_r
    Moderator
    Posted 14 years ago #

    When you created a database, you had to create or assign a db user to it. That's the part I'm talking about.

  12. jesscon
    Member
    Posted 14 years ago #

    Yes I remember that,

    So what db user do I assign. I would really appreciate the help, thanks

  13. jesscon
    Member
    Posted 14 years ago #

    Andrea, so I recreated the database and this time I checked Allow Direct Database Access but I still get the error below. Please help.

    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'WHERE domain = 'hot-cool-gadgets.com'' at line 1]
    SELECT * FROM WHERE domain = 'hot-cool-gadgets.com'

    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'WHERE site_id = 1 AND meta_key = 'site_name'' at line 1]
    SELECT meta_value FROM WHERE site_id = 1 AND meta_key = 'site_name'

    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'LIMIT 0,1' at line 1]
    SELECT blog_id FROM LIMIT 0,1

  14. andrea_r
    Moderator
    Posted 14 years ago #

    http://www.tutorialtastic.co.uk/tutorial/creating_a_mysql_database (bottom)

    http://www.thewebhostinghero.com/tutorials/godaddy-mysql.html

    Make sure when you run the install you do NOT use localhost. GoDaddy will tell you what your db server is.

    The db username there is the same name as the db.

  15. jesscon
    Member
    Posted 14 years ago #

    Erica here is the information that I got for mysql on go daddy

    MySQL Database Information
    Status:Setup
    Host Name:hotcoolgadgets.db.5390853.hostedresource.com
    Database Name:hotcoolgadgets
    Database Version:5.0
    Description:WP-MU
    User Name:hotcoolgadgets

    HERE ARE MY INPUTS

    Database Name hotcoolgadgets

    User Name hotcoolgadgets

    Password

    Database Host hotcoolgadgets.db.5390853.hostedresource.com

    Server Address hot-cool-gadgets.com

    Site Title Hot-cool-gadgets.com Blogs

    Email

    THIS IS THE ERROR THAT I GET

    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'WHERE domain = 'hot-cool-gadgets.com'' at line 1]
    SELECT * FROM WHERE domain = 'hot-cool-gadgets.com'

    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'WHERE site_id = 1 AND meta_key = 'site_name'' at line 1]
    SELECT meta_value FROM WHERE site_id = 1 AND meta_key = 'site_name'

    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'LIMIT 0,1' at line 1]
    SELECT blog_id FROM LIMIT 0,1

    Warning: require_once(/home/content/53/5390853/html/wp-includes/wpmu-functions.php) [function.require-once]: failed to open stream: No such file or directory in /home/content/53/5390853/html/wp-settings.php on line 439

    Please help what I should do.

  16. andrea_r
    Moderator
    Posted 14 years ago #

    Are you filling in an actual password?

  17. jesscon
    Member
    Posted 14 years ago #

    Yes, and with the proper case.

  18. andrea_r
    Moderator
    Posted 14 years ago #

    Are you sure you successfully uploaded all the files?

  19. jesscon
    Member
    Posted 14 years ago #

    I reuploaded the files and tried again when I read your message.

    These are the files that I downloaded from wp-mu since I am linux
    wordpress-mu-2.9.1.1.tar

    I got the same error.

  20. jesscon
    Member
    Posted 14 years ago #

    Andrea,

    I got the install to go through finally. Thanks for your tips I really appreciate it.

    The install did say that there was some problem with my wild card and that I would not be able to create sub-blogs. However I logged on to mu and did create a sub-blog successfully. I will keep testing.

    Again thank you (YOURE GREAT!!!)

About this Topic