The MU forums have moved to WordPress.org

cant figure out how to create subdomains.. one.com hosted site.(dns wildcard) (18 posts)

  1. onakosano
    Member
    Posted 12 years ago #

    well... now i have dumped WP in main directory, WPMU in /blogs directory, since i read in another thread that one.com does not support subdomains.. well, now iv`e received an answer from the support @ one.com, they do support it, but without www. (so it will be http://yourdomain.mydomain.no )

    but they did not tell me how... i am a baby with wordpress and all this so a guide would be great..

    F

  2. mercime
    Member
    Posted 12 years ago #

    http://codex.wordpress.org/Installing_WPMU
    http://wpmututorials.com/basics/installing-wordpressmu-the-e-book/
    And since your host supports WPMU, their tech support will help you set it up much faster.

  3. onakosano
    Member
    Posted 12 years ago #

    yup... and i have asked them about it, this is what the answer was

    in danish
    "Hei, Vi endrer sjældent i folks filer, men umiddelbart så burde det være sat op korrekt. Hvis du kigger i de avancerede DNS-indstilliner i kontrolpanelet på one.com, kan du se at *.pt-eliten.no er oprettet. Så jeg ved ærlig talt ikke hvad det er som WordpressMU ønsker at der skal tilføjes. Du kan også prøve at oprette hvert subdomene om du har blog på i DNS-indstillingerne, benytte en A record og peke på 195.47.247.19. Vent mindst 90 min før du tester siden, og se så om det virker.

    Med vennlig hilsen / Best Regards

    SUPPORTEN"

    in english
    ",we seldom change customers files, but now it should be functional, if you look in the controlpanel you can see that *pt-eliten.no is created. I honestly dont know what WordpressMU wants to be added. You can try to create each subdomain you have a blog in within the DNS settings, use an A record and point to 195.47.247.19., wait at least 90min before you test it again. "

    have i missed something? i have tried to read tutorials but i cant get my head around it.. probably since i have been thinking about nothing else the last few days...
    i`ll freaking give someone the user/pass to get into the dns settiongs and so on to fix it of possible...

  4. andrea_r
    Moderator
    Posted 12 years ago #

    If they've added the wildcard settings already... did you try adding a blog in the backend to see if it works?

    WPMU will make the blog even if the wildcards aren't set up right. And the way to check and see if they are set up is to create a blog.

    Site Admin -> Blogs. Scroll down to where it says "Add a blog"

  5. onakosano
    Member
    Posted 12 years ago #

    i added a testblog now, it was created in my admin dashboard but when i want to visit it ore backend it i get this error site:
    "
    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, support@one.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log."

    if i cant get this working... is the solution (instead of dumping WP and WPMU in different directories) just to have the posting permalinks as dates of post insted of title so the blog usernames will not "crash" with the posting and page titles?

    i am also ready to PAY for someone to fix this for me now... so frustrated i could throw my CPU out the window, since they claim that the wildcard settings are added but the advanced dns settings seems identical to what they looked like yesterday, i also tried the fix they support gave me but that has not worked yet eather(might take time though), but i should not have to make the subdomain manually, it should be automatically...

    baaaah!

  6. andrea_r
    Moderator
    Posted 12 years ago #

    The other poster's "solution" doesn't have anything to do with your situation.

    And yes, wildcard subdomains are done so you don't have to enter them all.

    If you give your url we can ping it and see if the wildcards are set up.

  7. onakosano
    Member
    Posted 12 years ago #

    the url is http://www.pt-eliten.no
    the testblog should be http://fredrik.pt-eliten.no

    ---------------------------------------
    recived a new answer now:in english its something like:
    hey F. How did you create the subdomain for you bog? here at ONE.COM you can create an unlimited number of subdomains. First you have to create a folder in your main directory(FTP) called ex. "testblog" that should contain an index file, afterwords it will be possible to enter the testblog by http://testblog.pt-eliten.no / http://www.pt-eliten.no/testblog

    Best Regards

    SUPPORTEN
    ----------------------------------
    One.com

    but this is the same as above.. not something i need for my situation.

  8. DeannaS
    Member
    Posted 12 years ago #

    Support is telling you how to manually create the subdomain. You need wildcard subdomains. You need to be able to do *.pt-eliten.no

  9. onakosano
    Member
    Posted 12 years ago #

    this is enabled in the dns as a default...
    here is what is shown in my advanced dns settings..

    http://pt-eliten.no/DNS.JPG

    im seriously stuck..

    what if i give one of u the user/pass to the controlpanel , would you take a min or two to check it out?

  10. andrea_r
    Moderator
    Posted 12 years ago #

    The host has to make sure there is a wildcard entry for your web account in Apache,. If that's not there, it won't work.

    If you're not on a dedicated or VPS , then you don't have access to that.

    BOTH the dns record and the record in Apache have to be there. My guess is the Apache one is not there.

  11. onakosano
    Member
    Posted 12 years ago #

    ive copied what you wrote and sendt it to the support.. hope they will fix it :)

  12. onakosano
    Member
    Posted 12 years ago #

    well, support says that they do not help out with apache and they do not offer dedicated servers..

    now... I am thinking about two possibility`s,
    1: only 1WPMU install in main directory ,blogs in sub directorys and having posts permalinks named after the date they are uploaded instead of names, that way it will no affect the blogs, right?

    2: take my domain, show one.com the finger and go somewhere else?

  13. SteveAtty
    Member
    Posted 12 years ago #

    They don't help out with Apache? Does that mean you have access to your apache config file or that you don't and they refuse to make any changes to it.

  14. onakosano
    Member
    Posted 12 years ago #

    i dont have access to my apache config file...

    im on an online support chat with ONE.com now..

  15. onakosano
    Member
    Posted 12 years ago #

    they refuse to change the apache config...

    so, back to the questions:
    1: only 1WPMU install in main directory ,blogs in sub directorys and having posts permalinks named after the date they are uploaded instead of names, that way it will no affect the blogs, right?

    ex: mydomain.no/yourblog and postings mydomain.no/11/02/2010 or something similar?

    2: take my domain, show one.com the finger and go somewhere else?

  16. andrea_r
    Moderator
    Posted 12 years ago #

    You have two choices.

    1. Install MU using the subfolder options. you'll get blogs in the form of yourdomain.com/username/. Permalinks after than can be whatever.

    or

    2. go to a different host that does support wildcard subdomains.

  17. onakosano
    Member
    Posted 12 years ago #

    thanks for all the help andrea_r, you have actually replied to every thread i have made in here :)

  18. linusf
    Member
    Posted 12 years ago #

    Just wanted to hop in here and say thanks to all of you. It saved me a lot o trouble while setting up my own WPMU installation. Im also using one.com, now I´ll go with subfolder option instead.

About this Topic

  • Started 12 years ago by onakosano
  • Latest reply from linusf