The MU forums have moved to WordPress.org

Upload File Size (22 posts)

  1. mshao
    Member
    Posted 17 years ago #

    I tried to use "Site Admin --> Options --> Max Upload File Size" to control the size limit. After I changed it to 4MB and tried to upload a 3.5 MB picture file, I still got error "The uploaded file exceeds the upload_max_filesize directive in php.ini".

    Any advise?

    Thanks

  2. drmike
    Member
    Posted 17 years ago #

    What does the error message tell you? You copied and pasted the answer.

  3. mshao
    Member
    Posted 17 years ago #

    Thanks. I couldn't locate php.ini file. Can you please point out? Also if it's done in the .ini file, then what's "Site Admin --> Options --> Max Upload File Size" for?

    Thanks

  4. drmike
    Member
    Posted 17 years ago #

    WPMU runs on PHP much like your computer runs on whatever OS you're running. Any setting in PHP trumps over what WPMU has set. (3.5 megs is *VERY* low though)

    Can't help you find php.ini since 1) I don't know what OS you're running and 2) I don't have access to your computer.

    Maybe if we had some more information about your setup but you really need to talk to your host about this one. This is more of a question for your host instead of one covering WPMU.

  5. mshao
    Member
    Posted 17 years ago #

    Thanks for the reply. I will check with my host.

  6. mshao
    Member
    Posted 17 years ago #

    I just got this from my host. Posted here for sharing.

    The default limit is 2 mb. You can adjust this by adding the following line to your .htaccess file, change X to whatever amount you will need.

    php_value max_upload_size XMB

  7. drmike
    Member
    Posted 17 years ago #

    Then do so. :)

    A lot of hosts won't allow for .htaccess to override php.ini settings but that is an option if allowed.

    Only 2 megs, huh? That is small.

  8. mshao
    Member
    Posted 17 years ago #

    Any size limit to suggest based on your experience?

  9. drmike
    Member
    Posted 17 years ago #

    Depends on wht you're uploading. Since you tried with 4 megs to begin with, try that for now.

    I throw around zips of hundreds of pics and backups and new client sites on a regular basis. I think most of my boxes are set for 50 megs.

  10. mshao
    Member
    Posted 17 years ago #

    Thanks for the inputs. Case closed.

  11. kodama
    Member
    Posted 17 years ago #

    Slightly off topic...

    I am having trouble getting my host to increase the limit for uploading files.

    Can anyone suggest either a plugin or program I can somehow integrate into WPMU that will allow users to upload larger files - probably something along the lines of a limited access FTP plugin/program?

  12. zeug
    Member
    Posted 17 years ago #

    Mega Upload uses a php front end to talk to a perl file uploader. Be interested to see if anyone can hack the php into the WP uploader, then port that to Mu, then make it a plugin :)

  13. drmike
    Member
    Posted 17 years ago #

    You're probably going to bump up against the host's limit though.

  14. zeug
    Member
    Posted 17 years ago #

    On perl? Gotta be way better than the php 2mb default, even on anal shared hosting.

  15. kodama
    Member
    Posted 17 years ago #

    Thanks for the tip. I'll let you know how I go...

  16. drmike
    Member
    Posted 17 years ago #

    I know of some 'anal shared hosting' places that have a 128kb upload limit. :)

    Mostly free sites and those run by admins who think everyone on their box is a spammer or hacker or someone out to get them.

  17. jmanders-jones
    Member
    Posted 17 years ago #

    "The uploaded file exceeds the upload_max_filesize directive in php.ini"

    I get the same message when uploading a 5.5MB .flv file even though my host has increased the php max upload directive to 10M.

    I have also set Site Options / Upload File Types to include flv.

    Any suggestions?

  18. jmanders-jones
    Member
    Posted 17 years ago #

    My host has increased the directive to 50M but I still get the same upload exceeded message from mu.
    I've checked the php.ini file and it is definitely set to 50M.

  19. drmike
    Member
    Posted 17 years ago #

    They may need to stop and restart the webserver for the change in php.ini to take affect.

    Although I though it was a live change.

    heck, give it a try. Half the fun of this is mucking around with stuff.

  20. jmanders-jones
    Member
    Posted 16 years ago #

    Problem solved. The web host created a php.ini file within my public_html but forgot to add the second directive post_max_size = 10M.

    The complete file reads:
    upload_max_filesize = 10M
    post_max_size = 10M

    It works a treat, although they are not willing to increase it above those values.

    Thanks for your help.

  21. heaversm
    Member
    Posted 16 years ago #

    I've tried all of these things and none of them work. I have a php.ini file in just about every directory, they all provide a max filesize and a post max size quota of 50MB (which works in other application). I can't even upload a 8kb jpg.

    Once I modified PHP.ini - I stopped getting the error from wordpress, but the file still does not upload to my uploads directory. Also - where is this Site Admin --> Options --> Max Upload File Size option - all I see in my wp-admin/ folder is an Options tab, under which I don't see any options to configure file size.

  22. theapparatus
    Member
    Posted 16 years ago #

    Please take a second and read the readme file included with the download. There's a debugging section in there that should have been included with your post.

    I have a php.ini file in just about every directory

    That may be the issue. php.ini should only be in one place depending on what software you;re running. If you need to override it, it needs to be placed within the root of the webspace of the domain in question.

    You need to get with your host as they may not allow overriding like that.

    all I see in my wp-admin/ folder is an Options tab

    Are you the site admin for this Wordpress multiuser install? What specific tabs do you see when you login?

About this Topic

  • Started 17 years ago by mshao
  • Latest reply from theapparatus