The MU forums have moved to WordPress.org

Memory Troubleshooting Help (5 posts)

  1. admaster
    Member
    Posted 13 years ago #

    Hi,

    We have a blog magazine running WPMU 2.9.1 on an Apache VPS with 4gb RAM and 2 x Intel Xeon CPU E5540 2.53Ghz.
    We have about 15 000 - 20 000 visits/day

    The CPU is no problem, has about 1-5% load but we are having a lot of problem with the RAM memory usage that is between 2gb and hits the roof at 4gb several times every hour making the site stop or go extremely slow.

    The prefork MPM of the Apache is set up like this:
    StartServers 10
    MinSpareServers 5
    MaxSpareServers 10
    MaxClients 200
    MaxRequestsPerChild 0

    When I do a "ps -e" I can see that we have up to 190 Apache processes running at high loads.

    If I do a "top" I can only see 20-30 of the Apache processes running(am I thinking/doing anything wrong?).
    But then I anyway see that every Apache processes is each taking about 0.9% memory, occupying 4.3MB of Shared memory, about 15-35MB of reserved memory and about 255MB of virtual memory.

    So I got a lot of information but do not really sure how to put it all together....

    Should not 4gb be enough for our site? Or is Wordpress MU taking so much power from our system with the visitor levels we have that we need to look in to getting some more memory, if so, how much?
    Any other ideas?

    Would cache busting help? We have added the super cache plugin to wpmu, but perhaps using cache on the apache server would also help, or?

    What I am looking for is basically some ideas and help to get our site working better...

    Thanks in advance,
    Rickard

  2. andrea_r
    Moderator
    Posted 13 years ago #

    You definitely need to start caching.

    Some plugin optimization would help too, depending on what you have running.

  3. admaster
    Member
    Posted 13 years ago #

    Yes, start caching is a must,.

    But anyone that has any idea┬┤s regarding the Apache settings etc?
    Site is now up in 30 000 visits a day :-)

  4. tmoorewp
    Member
    Posted 13 years ago #

    Here are my Apache settings for a fairly high traffic site (not nearly what yours is, but still up there):

    ` StartServers 4
    MaxClients 150
    MinSpareThreads 25
    MaxSpareThreads 75
    ThreadsPerChild 25
    MaxRequestsPerChild 4000
    `

    I'm also using the worker MPM instead of prefork.

    Beyond that, you can optimize PHP and MySQL to respond more quickly. Using eAccelerator and APC for PHP often help. Optimizing MySQL so that you aren't hitting a bottleneck with database requests is key as well.

    Additionally, refactor any custom PHP code you have written in plugins and themes. Reduce the number of MySQL queries and reduce the amount of work PHP has to do.

    Hope this helps,

    Tim

  5. tdjcbe
    Member
    Posted 13 years ago #

    If it's spiking like that after a bit, you may have a user incorrectly using their RSS widgets. Since the rss feeds are cached for an hour, if this is happening to your install after an hour, that sounds likely.

    Discussed here a bit:

    http://mu.wordpress.org/forums/topic/17216

About this Topic