The MU forums have moved to WordPress.org

Subdomain not being created (9 posts)

  1. kcgleaton
    Member
    Posted 12 years ago #

    I know I am overlooking something simple, but after days of reading doc's & forums I have not found the solution...

    I have an installation of wordpress MU (ver 2.9.2) on the domain ushousesavers.com. It works fine for the host domain, which is on the root folder, httpdocs, but not for the additional blog sites.

    When I try to create an additional blog sites (which are named blog1.ushousesavers.com, blog2.ushousesavers.com, etc.) while logged in as an administrator, I get the following error: "The site you are trying to view does not currently have a default page. It may be in the process of being upgraded and configured"

    When I check in the plesk control panel, the blog1, blog2, etc. accounts, which SHOULD be in the subdomains folder are no where to be found.

    Could it be that I should have done something differently during setup?

    Is there a special setting to allow (or TELL) wordpress MU to create subdomains in a particular place that I have missed?

    Is there a global path setting somewhere in wordpress mu that will create these new blogs in my subdomain folder?

    Any assistance would be greatly appreciated.

  2. SteveAtty
    Member
    Posted 12 years ago #

    You need to enable wildcards in your DNS record and in your apache config - which is in the documented steps of what you have to do.

    All WPMU blogs are totally virtual (apart from their upload directory which is created under the blogs.dir directory) so you wont ever see anything being created on the server.

  3. tdjcbe
    Member
    Posted 12 years ago #

    You need to enable wildcards in your DNS record and in your apache config - which is in the documented steps of what you have to do.

    Just to clarify, that's the readme file included with the download.

  4. andrea_r
    Moderator
    Posted 12 years ago #

    When I check in the plesk control panel, the blog1, blog2, etc. accounts, which SHOULD be in the subdomains folder are no where to be found.

    Just noting after you do the wildcard steps, they still won't show up on your server,. They're virtual, they only exist in the database.

  5. kcgleaton
    Member
    Posted 12 years ago #

    Thanks for your help guys!

    Apparently these settings are not standard in my hosting, so I have sent a ticket to their tech support and they will make the necessary changes to the account.

    I will let you know how things turn out.

  6. pacnorwest
    Member
    Posted 12 years ago #

    I'm having the same problem.
    Only I'm on a windows server. I have a wildcard * A (Host Record) set in my DNS zone editor.
    WordPressMu is up and running: cloudybright.biz
    I've used the admin account to set up a new blog as a sub-domain.
    The new blog sub-domain seems to be setup within WordPressMu and it shows on the home page.

    But the link to the new domain produces an error message here:
    http://creaky.cloudybright.biz/
    Any pointers as to what I should look for?

  7. SteveAtty
    Member
    Posted 12 years ago #

    Have you enabled domain wildcards in IIS?

  8. pacnorwest
    Member
    Posted 12 years ago #

    "Have you enable domain wildcards in IIS?"

    That is not a feature of the HELM control panel to my knowledge.
    I've asked my host for the answer to your question.

  9. pacnorwest
    Member
    Posted 12 years ago #

    Wildcard is created by default on IIS in the HELM control panel.
    Just now, I had to add a domain alias in the control panel.
    Now the sub-domain blog appears to be working.

About this Topic

  • Started 12 years ago by kcgleaton
  • Latest reply from pacnorwest