The MU forums have moved to

[FIX] - "$base is set to BASE" error (3 posts)

  1. b_stewart
    Posted 14 years ago #

    I was having a problem when doing a fresh install on 2.9.2. Every time I would fill in the installation form where you put in your database/server details, I would get the following error:

    "Problem in wp-config.php - $base is set to BASE when it should be the path like "/" or "/blogs/"! Please fix it!"

    From reading the forums, the general feedback was either to delete the wp-config.php file and check there isn't a copy of the file 1 level up the file hierarchy and then try the installation again. I tried both of these multiple times to no avail. In the end, it turns out it was a problem with my php.ini file. The offending line was that magic_quotes_runtime was turned on. This causes the comparisons in the switch statement on line 471 of index-install.php to fail. As soon as I turned magic_quotes_runtime off, it worked first time. Hopefully this saves someone some time.

    It seems there was a support ticket (#3127) already opened for this in the Wordpress tracker which was then subsequently closed.

  2. SteveAtty
    Posted 14 years ago #

    magic_quotes is a nasty directive

  3. b_stewart
    Posted 14 years ago #

    Yep it was left on from running a legacy project (very old Joomla site). I had forgotten to change the php.ini file back over on my dev machine and this error was driving me nuts.

About this Topic

  • Started 14 years ago by b_stewart
  • Latest reply from b_stewart