The MU forums have moved to

FireFox logout quirk (5 posts)

  1. akorelc
    Posted 17 years ago #

    It took 3 attempts at installing/re-installing WP MU (latest build 08/14/06) into a dummy domain (for testing) on a shared server at Rackspace (Plesk control panel) before it finally 'mostly' worked. My steps:

    1) FireFox: clear cookies and cache
    manual (not remembered) login as admin OK
    verified correct blog
    logout OK
    2) clear cache (no cookies to clear)
    manual login as non-admin user OK
    verified correct blog
    logout NO GO
    clear cookies and cache, redirected to login page
    3) toggled to IE (IE Tab for FFF)
    manual login OK
    verified correct blog
    logout OK

    I've tried every 'hack' and suggestion I could find here; to no avail. Has anyone figured out a fix for this quirky behavior in FF?

  2. gamerhk
    Posted 17 years ago #

    i am a new user of wpmu and i have the same problem...
    looking at the code..
    i realize that..
    the login script do something like
    wp_setcookie($user_login, $user_pass, false, '', '', $rememberme);
    which create session cookies with Path=/
    yet, when u logout, the set-cookie header has Path=/%user%/
    that's why the cookie isn't clear

    i believe this is a bug.

    P.S. are u using sub-directory mode right?

  3. akorelc
    Posted 17 years ago #

    Yes, I am; and it can be a daunting task to dig down into the code, especially when nothing seems to make a difference. :o)

  4. abatkin
    Posted 17 years ago #

  5. thatposhgirl
    Posted 17 years ago #

    I applied this patch and it seems to have fixed the problem of the user not being able to log out. I am still having a problem that if I log a user in through the main site page and then log them out and log the admin in the admin page comes up but it is connected to the previous users blog.

    I am logged into the admin panel as the admin but at the top it says "test blog" and if I write an entry it goes into the "test" users blog instead of the admin blog.

    eta. This issue occurs in both netscape and ie

    eta2. Also, this only happens if I log in as admin from the login page that shows up when I log out of a user's blog. If I log in from the main page everything seems to be fine.

About this Topic

  • Started 17 years ago by akorelc
  • Latest reply from thatposhgirl