The MU forums have moved to WordPress.org

Problem installing on 1and1 managed server - really odd directory ? (4 posts)

  1. cc_humbry
    Member
    Posted 10 years ago #

    Hi,
    I am trying to install WP MU on 1and1 managed business server. I have successfully installed this on my local machine (running Ubuntu 9.04) with no problems following the install directions so I don't appear to be a complete fool!
    The problem is that although the install process runs fine and gives me links to the admin page etc. accessing that page doesn't work. I get the old

    Fatal Error

    If your blog does not display, please contact the owner of this site.

    If you are the owner of this site please check that MySQL is running properly and all tables are error free.

    Could Not Find Blog!
    Searched for madabout-kitcars.com/wpmu/ in db323237356::wp_blogs table. Is that right?

    What do I do now?

    Read the bug report page. Some of the guidelines there may help you figure out what went wrong.
    If you're still stuck with this message, then check that your database contains the following tables:
    wp_blogs
    wp_users
    wp_usermeta
    wp_site
    wp_sitemeta
    wp_sitecategories
    If you suspect a problem please report it to the support forums but you must include the information asked for in the WPMU bug reporting guidelines!

    problem.
    I have changed permissions, checked the permissions for the database (all the usual things). I have even added

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    to the top of the .htaccess file to force 1and1 to use php5 in case that is an issue.
    I am really stumped here. What I have noticed is that I am trying to use a subdirectory for the blogs (in this case wpmu) but in the wp_blogs table the entry for the first blog is created with a directory of system-bin viz.

    blog_id site_id domain path registered last_updated public archived mature spam deleted lang_id
    1 1 madabout-kitcars.com /system-bin/ 2010-04-14 20:11:47 2010-04-14 18:11:47 1 0 0 0 0 0

    No where do I specify to use this directory and is a complete mystery as to where this comes from.
    In a test for this, I manually went through the wp directory and greped for system-bin and changed to my actual directory, then changed it in the wp-options table in the database. This worked for the first blog, but creating new blogs is the same problem - they just don't find the blog with the same error as above i.e. can't find the blog.

    Anyone give any pointers on this as I appear to have exhausted suggestions I have come across in these forums???

  2. dgilmour
    Member
    Posted 10 years ago #

    This might be a settings.php thing:
    http://drupal.org/node/165559

  3. cc_humbry
    Member
    Posted 10 years ago #

    Hi, sounds like it might be, but where do I change the $base_url setting in WP and when? Do I change it in wp-config-sample.php before I install, do I change it in another file after install (and in the database tables possibly)?
    This isn't something you suggest is a setting in 1and1 set up do you? I can't see anything relating to this within the control panel of 1and1, nor does it appear to be a setting I can change (globally) from a ssh shell.

    Thanks
    Conrad

  4. cc_humbry
    Member
    Posted 10 years ago #

    It appears that you need to disable the advanced configuration in the 1and1 control panel (as hinted at by post referred to by dgilmour).
    Done this and managed to install ok.

    Just for completeness and to force 1and1 to use php5 I also added the

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php
    as mentioned above.

    other keywords: 1and1, oneandone, hosting

About this Topic

  • Started 10 years ago by cc_humbry
  • Latest reply from cc_humbry