The MU forums have moved to WordPress.org

XMLRPC on sub-blog not working (7 posts)

  1. taewoo
    Member
    Posted 7 years ago #

    Hi everyone.
    XMLRPC publishing on my main WP MU blog is working, but the subdomain isn't... I think i set it up correctly as I can contact xmlrpc.php via browser (which returns "XML-RPC server accepts POST requests only"), but when i try to post, i get this error

    <methodResponse>
    <fault>
    <value>
    <struct><member><name>faultCode</name>
    <value><int>5</int></value>
    </member>
    <member>
    <name>faultString</name>
    <value><string>Didn&apos;t receive 200 OK from remote server. (HTTP/1.1 302 Moved Temporarily)</string></value>
    </member>
    </struct>
    </value>
    </fault>
    </methodResponse>

    To clarify, i am using
    - sub-blog on subdirectory (shared host)
    - mapped domain plugin
    - XMLRPC client is something I wrote and has been proven (been using it past 7 months on my other WP blogs)
    - XMLRPC on MAIN blog is working correctly

  2. tdjcbe
    Member
    Posted 7 years ago #

    The 302 error is probably coming from the mapped domains plugin. Don;t have an answer on that but I did want to point out that we just covered this elsewhere in case you want to fix that to a 301 like it should be.

    http://premium.wpmudev.org/forums/topic/domain-mapped-subdomains-using-302-redirect

    Not sure which plugin (There's a bunch.) you;re using but the cause is probably the same.

  3. taewoo
    Member
    Posted 7 years ago #

    Hey tdjcbe...
    Not sure if the updates from that forum thread were included, but I downloaded the domain mapping plugin a couple of days ago.

    I tried changing line 453 from

    header( "Location: {$url}{$_SERVER[ 'REQUEST_URI' ]}", true, $redirect );

    to

    header( "Location: {$url}{$_SERVER[ 'REQUEST_URI' ]}", true, 301);

    still i get the same 302 error

  4. taewoo
    Member
    Posted 7 years ago #

    FYI: Under Site Admin => Domain Mapping => Permanent redirect, i have the box checked... so the logic above should be 301 redirect.

    I tested on a FRESH copy of MU (on subdir, not subdomain)
    1) w/o domain mapping plugin => XML RPC works fine
    2) w/domain mapping plugin => XML RPC breaks (302)

    (and domain mapping plugin is the ONLY active plugin)

    Anyone have any thoughts?

  5. andrea_r
    Moderator
    Posted 7 years ago #

  6. taewoo
    Member
    Posted 7 years ago #

    hey andrea
    i tried the new one... no luck. same error. ;/

  7. taewoo
    Member
    Posted 7 years ago #

    On side note: weird thing is.. i tried publishing via:

    http://topblog.com/subblog/xmlrpc.php

    The XMLRPC client is returning "successful" return code but i don't see any changes to the sub-blog.. but instead on the main blog. I'm assuming this has something to do with the domain mapping plugin.

About this Topic