The MU forums have moved to WordPress.org

error: "Page isn't redirecting properly" when installing MU (10 posts)

  1. zoldos
    Member
    Posted 11 years ago #

    All the database stuff is fine, and everything seems to work, but when I press submit after entering all the required info, I get this error on MU 2.9.2:

    ---
    The page isn't redirecting properly

    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

    * This problem can sometimes be caused by disabling or refusing to accept cookies.
    ---

    I can't make heads or tails of it. Does anyone know how to fix it?

  2. andrea_r
    Moderator
    Posted 11 years ago #

    Since you didn't give me a link to your site, I'm gonna guess. :)

    You ut the address in with a www. MU strips it out.

  3. zoldos
    Member
    Posted 11 years ago #

    Here is the site: Shadow Blogs. I didn't use a www during the install and even double checked the config settings. You are welcome to take a look, no matter how I try to access the site, I get the error. Here is an excerpt from my config file (I removed the database username and password as it connected to the database just fine):

    -------
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'xxxx');

    /** MySQL database username */
    define('DB_USER', 'xxxx');

    /** MySQL database password */
    define('DB_PASSWORD', 'xxxx');

    /** MySQL hostname */
    define('DB_HOST', 'localhost');

    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');

    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    define('VHOST', 'yes');
    $base = '/shadow/';
    define('DOMAIN_CURRENT_SITE', 'zoldixsava.net' );
    define('PATH_CURRENT_SITE', '/shadow/' );
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOGID_CURRENT_SITE', '1' );
    -------

    Thanks!

  4. andrea_r
    Moderator
    Posted 11 years ago #

    What host are you using?

    And you let it create the config for you, right?

  5. zoldos
    Member
    Posted 11 years ago #

    I am using Lunarpages and I let it create the config file automatically. I am running plenty of other PHP based scripts without a problem. Plus I was able to install the regular version of Wordpress. This is exactly what happens when I try to install Wordpress MU:

    I setup a database and then run index.php in my Wordpress installation. I enter all my details, database name, password, localhost, and zoldixsava.net as my website server. I click "submit" and it takes a bit, then I get the error from my original post. This is the exact URL it is trying to access when I get the error: http://zoldixsava.net/shadow/wp-signup.php?new=zoldixsava.net

    I tried deleting the database as well as the wp-config.php file and tried a fresh install, and got the same redirection error...

  6. andrea_r
    Moderator
    Posted 11 years ago #

    You're installing it in a folder (/shadow/) and you just put in the main domain without the folder name. So it's redirecting to just zoldixsava.net and can't find it in the database.

    If you want to keep it in a subfolder like that, it *must* be ion the URL. You can't have it installed in a folder and serve it from the root.

  7. zoldos
    Member
    Posted 11 years ago #

    I tried putting zoldixsava.net/shadow, zoldixsava.net/shadow/ and even localhost.localdomain and also tried keeping the field blank, and all result in the same redirection error...

  8. andrea_r
    Moderator
    Posted 11 years ago #

    Have you asked your host if they will even support WPMU on your web account?

    Some hosts don't, and disable it from working.

  9. andrea_r
    Moderator
    Posted 11 years ago #

    ... and you have www issues. like I said in the second post.

    You;re gettign a redirect because the server is set to use the www in your domain.
    MU strips it out.
    The server is trying to add it back.
    MU strips it out.

    Repeat. This is why you;re gettign a redirect.

    Go get the 3.0 version of WordPress from trac. install it, then do this:
    http://codex.wordpress.org/Create_A_Network

  10. zoldos
    Member
    Posted 11 years ago #

    Okay thanks for all your help, I will check that out! :)

About this Topic