The MU forums have moved to WordPress.org

Error 500 on access news blogs (11 posts)

  1. Frango
    Member
    Posted 12 years ago #

    Hi Guys,

    I install WPMU like sub-domains mode. The Installation work fine and the creating new blogs too. But i try access this new blogs i receive error 500.

    This error appear only on new blogs, the default blog work normally, all pages, permalinks of default blog work fine.

    Somebody any idea about this?

  2. andrea_r
    Moderator
    Posted 12 years ago #

    Please read the readme file included in the zip. There are instructions there about wildcard subdomains, which is how the blogs work. You need to enable them both in Apache and in your DNS records.

  3. Frango
    Member
    Posted 12 years ago #

    Hi andrea_r,

    I already read the readme file and follow all instructions. I add the * entry in my DNS. I'm not make alterations in http.conf but my server is shared.

    What i can do? I guess wich problem is in .htaccess file. What do yout think?

  4. tdjcbe
    Member
    Posted 12 years ago #

    The 500 error almost always put an error in your webserver's error logs and says that it is doing so. Can you check those please?

    I'm not make alterations in http.conf

    Get with your host and ask them to make the modifications listed. I politely point out that all of the instructions need to be followed. Kind of like baking a cake without the eggs.

  5. andrea_r
    Moderator
    Posted 12 years ago #

    "but my server is shared."

    This is the problem, not your htaccess file. Ask your host if they support wildcard subdomains.

  6. kingedward
    Member
    Posted 12 years ago #

    Hi andrea_r
    I hope you can help me too... I'm having the same problem ... 500 error at install... my server accepts wildcard subs, and my host guys just wrote back saying ...

    mod_rewrite is enabled on the server. I've created a phpinfo.php file in your web root if you'd like to verify that.

    I've modified your httpd conf include file to use *.sitename.com as requested. Let us know if theres anything else you need.

    still 500 error... no admin, no login, can't complete install...
    can you help?

  7. tdjcbe
    Member
    Posted 12 years ago #

    As noted up above, the 500 error almost always puts the specific error in the webserver's error logs. Please check to see what's in there.

  8. kingedward
    Member
    Posted 12 years ago #

    the error log says
    subdomains/muwptest/httpdocs/.htaccess: Invalid command '90', perhaps mis-spelled or defined by a module not included in the server configuration, referer: http://muwptest.kingedwardltd.com/index-install.php

    ((is it safe to list this address here or should I change it?))
    so ... Invalid command '90' ???

    I tried to use a new hack, and the orig htaccess.dist file ... I tried to reinstall the whole site, and the file, and new hack of the file ... no good.

    Funny, I asked my host guys, but they said they can't help with CMS issues, ... so I wiped the install ... and I STILL get a 500 error!! It was a blank site!! Then I uploaded a simple test index ... and still get a 500 error.. wahh!!??

    do you have any idea about /.htaccess: Invalid command '90', the error is listed about twenty times...

  9. kingedward
    Member
    Posted 12 years ago #

    Well I just wiped it all, and it was a blank site and STILL gave me 500 ... it was just an empty directory! Weird! Uploaded simple index page ... still 500 ... so I deleted the whole subdomain, and made new subdomain, new database, and on my 3rd test install .. it all works fine!! : ) still no idea why I was getting 500!

  10. Frango
    Member
    Posted 12 years ago #

    Hi Andrea_r,
    I contact the support of my host and verifiy that the http.conf is setup to AllowOverride All and yes, my host support the wildcard subdomains including this * entry already is created.

    The support of my host told me to delete all others subdomais created, but i can do that because i need their.

    This make sense to you? I think that entry is work fine because all subdomains return the 500 error, if not working thats subdomains return 404 error ok?

    Aaaa the apache log not appear nothing about this 500 errors.

  11. eyefox
    Member
    Posted 12 years ago #

    - This error, I fixed when I follow it:

    "Now navigate to your domain (master-example.com) and you should see the installation page. There are some errors for sure and the usual error is that you need to make some folder writable by Wordpress. That means to give those folders 777 permission and you’ll have to reset those to 755 after successful install."

    Good luck !

About this Topic