The MU forums have moved to WordPress.org

500 internal server error (14 posts)

  1. camster
    Member
    Posted 11 years ago #

    Hi, I've installed WPMU and the first time I can login successfully and I can perform functions like new posts, new pages ect.

    However soon as I create a new blog I receive a 500 - Internal server error.

    After I receive the error the first time I then get the same thing on the login page so I cant login or do anything.

    I deleted the database three times and created new as well as deleting all files and re-uploading.

    On install I tried both options as sub-directories or sub-domains

    I also have permissions to read, write, delete for the wordpress MU folder and am on a IIS server.

    The functionality seems to be working because I get the notification emails for the new blog I added but for some reason I'm getting this 500 error which seems to be caused by adding a new blog.

    Any help would be really cool.

    Thanks
    Camster

  2. tdjcbe
    Member
    Posted 11 years ago #

    Two quick suggestions:

    - Always check the webserver's error logs when ever you have a problem. I believe the debugging page linked to from the readme file included with the download mentions that. Good habit to get into no matter what software you;re using.

    - Always copy and paste the specific error you;re receiving. Never put it into your own words.

    Double check please that you have mod_rewrite installed though. That's probably the issue.

  3. eyefox
    Member
    Posted 11 years ago #

    - That is a error when you set permission CHMOD 777
    - After you set up wp mu, you must reset permission to 755
    - I have been like you but I fixed it !

  4. camster
    Member
    Posted 11 years ago #

    Thanks for the suggestions

    I couldnt find error logs and asked the web host support. They said they can not view error logs for some reason.

    I'm hosted on IIS 7 and the web host enabled or installed the mod-rewrite for me (I'm not sure how they did this). I called back and confirmed it was running.

    I also went through the steps suggested for installing on IIS 7
    http://www.matthewcasey.co.uk/2010/04/01/setting-up-wordpress-mu-on-iis/

    Changed the permissions to 755 as suggested

    Unfortunately still getting the same 500 error. I'm stumped and apparently so is my web host. Thanks for the suggestions though and if you have any other suggestions to pursue I'll certainly try them out.

    Camster

  5. andrea_r
    Moderator
    Posted 11 years ago #

    What kind of blogs did you pick, subfolder or subdomains?

  6. camster
    Member
    Posted 11 years ago #

    I've tried both, first I tried subdomains and got the error. So I deleted the database and the entire WPMU directory and started over again.

    I read in a few places that subdomains was not working when trying to install on IIS 7 so I tried installing again but as subfolder (subdirectories) but got the same result with everything working until I click to add a new blog then the internal error comes up.

    Thanks
    Camster

  7. andrea_r
    Moderator
    Posted 11 years ago #

    So you get the 500 error as you are creating a new blog (which is how that sentence reads now) or after the blog is created & you go to visit it?

    Do they have the mod rewrite add-on for IIs?

  8. camster
    Member
    Posted 11 years ago #

    Sorry I dont have any screen shots because I cant re-create it without re-installing. But basicly I can surf around the admin and add posts, pages, ect. everything seems to be working until I click the new blog link, I enter the Blog name and I believe title, and whatever else is in the dialogue box. The when I hit the submit (sorry I cant remember the exact name) button I get the 500 error for index, login and other pages.

    My hosting have told me they enabled the mod rewrite on their end. I cant view error logs and they say they cant view them either for some reason. They arent being very cooperative to be honest and want 75.00 an hour to complete/correct the install. I'll continue to trouble shoot this if anyone has any other ideas. Otherwise I may try install on go Daddy instead at least they have instructions on how to install specificly on their servers.

    Thanks
    Camster

  9. andrea_r
    Moderator
    Posted 11 years ago #

    Ugh, GoDaddy may be worse. you also need a dedicated IP on their end.

    IIS stuff is part of the issue. Honestly, I don't recommend it. Get an Apache server.

  10. camster
    Member
    Posted 11 years ago #

    I know but goDaddy seems to be a little more user friendly for novices like myself. I believe I was on Apache with my current host but they said I had to upgrade to get mod rewrite which put me on IIS.

    I installed B2evo with no problems but I like the interface and plugins available for wordpress a lot better.

    Not really sure what to do at this point.

  11. andrea_r
    Moderator
    Posted 11 years ago #

    I believe I was on Apache with my current host but they said I had to upgrade to get mod rewrite which put me on IIS.

    But mod_rewrite is an Apache module, not an IIS one.

  12. camster
    Member
    Posted 11 years ago #

    ok, talked to someone else at my host tech support and he says they have mod-rewite installed on windows intermediate servers. However he noticed I am on IIS 7 and says that WPMU wont work on IIS 7 (something to do with htaccess not working properly) and suggested they move my site to an IIS 6 plan and then I shouldnt have any problems with the install. I just wanted to check with you guys to see if this is sounds right before I move everything.

    Thanks

  13. andrea_r
    Moderator
    Posted 11 years ago #

    I don't work with IIS at all. That's a preface. :)

    having said that, I have heard others say that WPMU works even better on IIS 7 than 6.

    But if they say on their servers it works on 6, go with that.

    If you still have issues, find another host. non-windows.

  14. camster
    Member
    Posted 11 years ago #

    Ok you'll be happy to know there is an end to the install saga. They moved me to a IIS 6 server and that finally did the trick. I really have no idea why it wouldnt work with IIS 7 because I know nothing about servers as you can tell. Anyway I'm glad we found the anwser. Thanks for sticking with it andrea_r. I appreciate your persistence!

    Camster

About this Topic