The MU forums have moved to WordPress.org

Domain Mapping - parked domain cPanel step (12 posts)

  1. jsteffen0852
    Member
    Posted 11 years ago #

    I clearly need to do some research on this domain mapping because I just can't get the plugin (http://wpmututorials.com/simple-multi-site-plugin-e-book/) to work to work. My curveball is that my webhost (Media Temple Gridserver) has a few apparently non-standard things, one of which is that they don't use cPanel.

    So the "parked domain" option doesn't exist, which appears to be one of the steps to get this mapping right.

    Question: is "parked domain" just a series of A records and CNAME records set a certain way? I have full access to my zone file, so I can do whatever I want with it. Or do I really have to go into Apache and make some Virtual Host entry?

    I'm guessing this may be too technical for me. My hobbyist-level abilities fall way short of doing some command line stuff on the Apache webserver.

    I've searched the Media Temple help, next step is to call them unless someone has an idea.

  2. jsteffen0852
    Member
    Posted 11 years ago #

    Actually, Media Temple may not let me edit my A records. I saw this quote on some Media Temple help site:

    That's correct, but not necessary. When the nameservers are pointed to Media Temple, you have no way to change the A record as (mt) does not allow it in their zone files.

    As a result, you should go into your GoDaddy Domain Control Center, enable the checkbox of the domain you are referring to, click "Nameservers" at the top, and click "Parked Nameservers".

    After doing that and allowing a few minutes for it to take effect, you can enter the actual control panel specifically for that domain and change the records to suit your needs. Let me know if you need more thorough directions and I'd be glad to provide them to you...

    I will try this route.

  3. andrea_r
    Moderator
    Posted 11 years ago #

    On Media Temple, you have to add the new domain, then create a symlink via command line to your mu install.

    Not my favorite host to do domain mapping on. :)

  4. jsteffen0852
    Member
    Posted 11 years ago #

    Okay Andrea, thanks. I'm probably going to engage in battle with it again this weekend.

  5. andrea_r
    Moderator
    Posted 11 years ago #

    I know there's a thread in here somewhere with direction for mt specifically. I just don't have it in my special mu forums link file. ;)

  6. jsteffen0852
    Member
    Posted 11 years ago #

    Cool, I'll definitely do some rooting around on that. Thanks for your help.

  7. jsteffen0852
    Member
    Posted 11 years ago #

    Ah, here it is. I should have thought to search for "media temple" instead of "domain mapping". I'll get on it, but first I have to figure out how to use SSH and the terminal. Oh well, should be fun.

  8. jsteffen0852
    Member
    Posted 11 years ago #

    Okay, I'm getting darn close, but not there yet. I'm installing multi-site with 3.0 RC2 15161. My main domain is jstef.com and I created another blog called jstef.com/j90stef/. I purchased the multi-site plugin and did this:

    1. Installed MU at jstef.com
    2. Created multi-site blog using subfolders at jstef.com/j90stef/
    3. Checked and backed up everything, no problems, both blogs work
    3. Went to Godaddy and pointed j90stef.com to Media Temple
    4. Add domain j90stef.com to Media Temple
    5. Created mu-plugins folder, loaded plugin, added sunrise.php...etc
    6. Mapped j90stef.com to jstef.com/j90stef/
    7. Checked table in my database called wp_domain_mapping and it has a record that reads (id, blog_id, domain, active) 1, 2, j90stef.com, 1, which seems to make sense. Note that this is the only additional table that the plugin seemed to add.
    8. Deleted everything in j90stef.com through terminal command
    9. Added symlink via terminal to forward everything from j90stef.com to jstef.com

    So there are two problems.

    1. I can get to j90stef.com (so the symlink is probably correct), but it has this at the top:

    Warning: Conflicting values for the constants VHOST and SUBDOMAIN_INSTALL. The value of SUBDOMAIN_INSTALL will be assumed to be your subdomain configuration setting. The constant VHOST is deprecated. Use the boolean constant SUBDOMAIN_INSTALL in wp-config.php to enable a subdomain configuration. Use is_subdomain_install() to check whether a subdomain configuration is enabled. in /xxx/xxx/xxx/xxx/12345/domains/jstef.com/html/wp-includes/ms-default-constants.php on line 115

    2. I cannot get into the backend of the j90stef.com at all. I get the same message above plus this:

    Warning: Cannot modify header information - headers already sent by (output started at /xxx/xxx/xxx/xxx/12345/domains/jstef.com/html/wp-includes/ms-default-constants.php:115) in /xxx/xxx/xxx/xxx/12345/domains/jstef.com/html/wp-includes/pluggable.php on line 890

    It may be important to note that:

    a. I tried to do this first using subdomains, it didn't work then, but that's because I didn't know about the symlinks terminal command I had to enter.
    b. My "Sites" page at Super Admin looks just like the example in the PDF (more in this in a few).
    c. I've deleted and reloaded the blog several times from backup, which I backed up right after I got the successful subfolder blog added but before I did anything with the plugin.

    So you need to know one more thing that could signify the root of the problem. In researching this, I noticed that Andrea's slideshare from Wordcamp Chicago and ottopress.com's tutorial have an item in the Super Admin menu below Domain Mapping called Domains. But in the PDF from the plugin I purchased, no reference is made to this menu item nor do I see it in my Super Admin menu at jstef.com. I think it is has something to do with the fact that I'm missing that Domain Mapping Configuration screen, for some reason, that allows me to enter the IP and see the check boxes for remote login, permanent redirect, user domain mapping page, and redirect administration. I can't figure out why I'm missing that screen. I've done it a few times. In the tutorial at ottopress.com he mentions some "trunk version of the plugin", do I need to get that?

    I don't know where to go from here, besides back to individual installs. Hey, at least I learned how to use the terminal.

    Any help is much appreciated.

    John

  9. jsteffen0852
    Member
    Posted 11 years ago #

    Update: I replaced sunrise.php and domain_mapping.php with the ones referenced in this article:

    http://ottopress.com/2010/wordpress-3-0-multisite-domain-mapping-tutorial/

    It seems to have cleaned things up. I can now get into both blogs and and the error messages have gone away. I still feel a little uncomfortable for a couple of reasons:

    1. When I go to Sites in the Super Admin menu, my subfolder blog (the second one) is listed with ID #2 and has the proper mapping (j90stef.com). The the Path is blank though, just /. That doesn't seem right, I don't get it.

    2. When I go to the backend of Site 2, and choose Tools - Domain Mapping, it lists my subdomain (Site 2) twice as active domains. I'm afraid to delete one.

    Should I not worry about it? Should I wait until the plugin is updated reload? Not sure what to do.

    Thanks for listening thought.

  10. andrea_r
    Moderator
    Posted 11 years ago #

    In researching this, I noticed that Andrea's slideshare from Wordcamp Chicago and ottopress.com's tutorial have an item in the Super Admin menu below Domain Mapping called Domains. But in the PDF from the plugin I purchased, no reference is made to this menu item nor do I see it in my Super Admin menu at jstef.com

    Becasue they are two different plugins. :)

  11. jsteffen0852
    Member
    Posted 11 years ago #

    Okay, I think we are there. I just started over. I'm sorry to bother everyone with my ramblings, but it did help me to solidify my thoughts. Media Temple is just kind of different so here is what I did.

    1. Got my multi-site install working without any domain mapping.
    2. Confirmed the symlink was working fine and mapping the domain for blog 2 to the primary domain.
    3. Grabbed the trunk version of the plugin from Ottopress' link.
    4. Then followed the directions from Andrea R's mu tutorial on the PDF included with the plugin, updating admin screen after each step.

    Not sure where I went wrong in all of this. I'm a rookie so it's not surprising I guess.

  12. andrea_r
    Moderator
    Posted 11 years ago #

    Glad you sorted it out.

About this Topic

  • Started 11 years ago by jsteffen0852
  • Latest reply from andrea_r