The MU forums have moved to WordPress.org

Wordpress 3.0 - No .htaccess being generated (5 posts)

  1. trivum
    Member
    Posted 11 years ago #

    Hi - I'm trying to get multiblogs working with 3.0 by following the instructions here: http://codex.wordpress.org/User:Andrea/Create_A_Network

    #3 says:

    Replace the content of your .htaccess file with the following

    (If there isn't one, then create it.)

    These lines are dynamicly generated for you based on your configuration.

    Nothing was generated for my .htaccess file (though a file was there). I found the following code on a blog and put it in the .htaccess file:

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    
    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    I have followed all the instructions on the page from the link above; however, no "Super Admin" appears in my dashboard.

    Is my .htaccess file wrong? Is there something else I need to be doing?

    Thanks

  2. andrea_r
    Moderator
    Posted 11 years ago #

    .htaccess is a hidden file. No, wp does not create it for you, as the instructions stated. It did give you the code to paste in the file though.

    Go look in the db to make sure the extra tables were added.

  3. trivum
    Member
    Posted 11 years ago #

    Thanks for the reply.

    I looked in the database, and it doesn't seem the extra tables were added. (It would be wp_blogs, right?)

    I'm not sure what you mean when you say it gave me the code to paste in the file. The code that I posted above is code I found somewhere on the internet. The only thing that was in the .htaccess was # BEGIN WordPress and # END WordPress ... Is that the right code? (I just checked the code again and it was different -- I guess because I've been updating as newer versions come out.)

    I just went back and reread the instructions again, and it seems there is another issue.

    #2 says:

    2. Add the extra lines provided to your wp-config.php file

    These lines are dynamicly generated for you based on your configuration.

    Put these lines right under the WP_ALLOW_MULTISITE line, mostly for readability.

    Actually, I did not have the line WP_ALLOW_MULTISITE in my config file. I had to put it in there.

    ~ Thanks

    (By the way, does anyone know if the final version is going to be like this - where you need to go through similar steps for multiblogs?)

  4. andrea_r
    Moderator
    Posted 11 years ago #

    this is the process:
    http://codex.wordpress.org/Create_A_Network

    I'm not sure what you mean when you say it gave me the code to paste in the file. The code that I posted above is code I found somewhere on the internet.

    In step 2 above, where you do the "create a network" thing in the backend, the second install screen gives you code to paste:
    - in the config file
    - in your htaccess

    That's what I meant.

    And yes, this is the final process. If you can't handle setting it up, then running it is going to be a challenge.

  5. trivum
    Member
    Posted 11 years ago #

    OK, I got it now. I was missing the setting up a network step in the Tools section.

    Thanks for your help.

About this Topic