The MU forums have moved to WordPress.org

Error install WPMU on Win2008R2+SQL2008R2 Express (10 posts)

  1. chrisavis
    Member
    Posted 10 years ago #

    System: Windows 2008 R2 Clean Install - No Extras - Fully Patched (running in a VM)
    Attempting to run through the guide at -- http://wordpress.visitmix.com/development/installing-wordpress-on-sql-server -- to install the Multi-User version of WP.

    The steps and screen shots are a lttle different from what I have to do to get things installed though. If I follow the steps exactly, the first error I get is at the Platform Installer. I get “SQL Server 2008 Express with Tools is incompatable with SQL Server Express 2008 R2″.

    From there I have attempted two paths – 1) Just continue through the error and attempt the remainder of the steps after the Platform Installer completers and 2) Grab SQL2008 R2 Express and install it manually then run the Platform Installer again to add in the proper features.

    In both cases, I have to manually download and install the SQL Server 2008 R2 Management Studio so I can then add the account and database. Once SQL is configured, I moved on to installing WP. I create the WP-sqlsrv directory, copy all the WP files over, create the web.config file and paste in the data from the posting. I then open IE and browse to the directory. The WP install fires up and I see slightly different screens (presumably because the WP Code has been update since the posting was made) but all goes well until clicking the "Submit" button at the bottom of the page. There is a brief pause then I get the Internal Error 500 Message.

    Module FastCgiModule
    Notification ExecuteRequestHandler
    Handler PHP_via_FastCGI
    Error Code 0x00000000
    Requested URL http://wordpresser.azeroth.local:80/wp-sqlsrv/index.php
    Physical Path C:\inetpub\wwwroot\wp-sqlsrv\index.php
    Logon Method Anonymous
    Logon User Anonymous

    Anyone?

  2. andrea_r
    Moderator
    Posted 10 years ago #

    Install WordPress 3.0 instead. It was released today, and the WPMU codebase is now merged in with it.

    Once you've installed it, this will turn on the multiple blogs.
    http://codex.wordpress.org/Create_A_Network

  3. tdjcbe
    Member
    Posted 10 years ago #

    Someone correct me if I;m wrong but I could have sworn that wp can't be run on SQL Server. It does need a MySQL server as they;re not compatible. I've never tried it myself.

  4. ZachPritchard
    Member
    Posted 10 years ago #

    I'm having this problem, too; however, I don't get the SQL Server Express error, just the 500 error while I'm trying to install.

  5. andrea_r
    Moderator
    Posted 10 years ago #

    Zach - install WordPress 3.0. then enable the network.
    http://codex.wordpress.org/Create_A_Network

    WPMU will no longer be updated as a separate program.

  6. chrisavis
    Member
    Posted 10 years ago #

    I have downloaded Wordpress 3.0, however the README file makes no mention of compatability with Microsoft SQL Server 2008 either the full or Express version. Are there any detailed instruction posted somewhere on configuring WP and Microsoft SQL?

    Chrs

  7. chrisavis
    Member
    Posted 10 years ago #

    Update - Decided to just push forward with this using the guide from my original posting - http://wordpress.visitmix.com/development/installing-wordpress-on-sql-server -- this time, the initial screen shots match. Now the problem I have is being unable to connect to the SQLExpress instance.

    On the initial setup screen I enter my Database Name, User Name, Password, Database Host and Table Prefix. After clicking submit, i receive an error --

    Error Establishing a databas econnection

    I noticed that the wp-config.php file never gets created as well, so I used the template sample, plugged in my info, and tried browsing back to the site and get an error 500. I am at a bit of a loss now.

    Chris

  8. andrea_r
    Moderator
    Posted 10 years ago #

    That's the MU install screen details.

    Go get 3.0. Install it.

  9. chrisavis
    Member
    Posted 10 years ago #

    No. I completely deleted MU. I can assure you this is the Wordpress 3.0 install that I am using. When I open the readme.html file it says WordPress 3.0 and notes the "famous 5 minute install" which is now closing in on 5 days.

    I have tried running the install from "http://localhost/wp-sqlsrv" and from "http://localhost/wp-sqlsrv/wp-admin/install.php" with the exact same results.

    Chris

  10. chrisavis
    Member
    Posted 10 years ago #

    Apparently there is no support for Wordpress 3.0 on Microsoft SQL. Although the page I link to provides instructions, they are specific to the MU version of Wordpress.

    In the future, it would be a good idea to note this before sending people on wild goose chases.

    Please see the following thread on the Wordpress 3.0 Forums --

    http://wordpress.org/support/topic/414061?replies=3

    Chris

About this Topic

  • Started 10 years ago by chrisavis
  • Latest reply from chrisavis