The MU forums have moved to WordPress.org

Upgrade from 2.9.2 to 3.0 - Admin Area Unaccessable (17 posts)

  1. lovewordpress
    Member
    Posted 10 years ago #

    I used the internal upgrader to move from 2.9.2 to 3.0.

    I did the modifications on .htaccess and wp-config.

    The websites hosted on mu display normally when called and their HTML tag signals that they are running on Wordpress 3.0.

    When I call any mu hosted url with /wp-admin/ I receive a blank page with nothing else.

    Any thoughts on this?

  2. lovewordpress
    Member
    Posted 10 years ago #

    Also, my .htaccess file:

    AddHandler x-httpd-php5 .php
    AddHandler x-httpd-php .php4

    RewriteEngine On
    RewriteBase /

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

  3. lovewordpress
    Member
    Posted 10 years ago #

    I also ran a debug and found these errors. Unfortunately it appears to hang after the following error listed below:

    Warning: include([host]/wp-content/advanced-cache.php) [function.include]: failed to open stream: No such file or directory in [host]/wp-settings.php on line 60

    Warning: include() [function.include]: Failed opening '[host]/wp-content/advanced-cache.php' for inclusion (include_path='.:/usr/local/php5/lib/php') in [host]/wp-settings.php on line 60

    Notice: add_option was called with an argument that is deprecated since version 2.3 with no alternative available. in [host]/wp-includes/functions.php on line 3323

    Notice: Undefined index: aioseop_migrate in [host]/wp-content/plugins/all-in-one-seo-pack/all_in_one_seo_pack.php on line 537

    Notice: Undefined index: aioseop_migrate_options in [host]/wp-content/plugins/all-in-one-seo-pack/all_in_one_seo_pack.php on line 538

    Notice: Undefined index: aiosp_enabled in [host]/wp-content/plugins/all-in-one-seo-pack/all_in_one_seo_pack.php on line 688

    Notice: Undefined index: aiosp_enabled in [host]/wp-content/plugins/all-in-one-seo-pack/all_in_one_seo_pack.php on line 688

    Notice: Undefined index: trackregistration in [host]/wp-content/plugins/google-analytics-for-wordpress/googleanalytics.php on line 617

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at [host]/wp-settings.php:60) in [host]/wp-content/plugins/si-contact-form/si-contact-form.php on line 940

    Notice: define() was called with an argument that is deprecated since version 3.0! The constant VHOST is deprecated. Use the boolean constant SUBDOMAIN_INSTALL in wp-config.php to enable a subdomain configuration. Use is_subdomain_install() to check whether a subdomain configuration is enabled. in [host]/wp-includes/functions.php on line 3321

    Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in [host]/wp-includes/functions.php on line 3237

    Notice: register_widget_control is deprecated since version 2.8! Use wp_register_widget_control() instead. in [host]/wp-includes/functions.php on line 3237

  4. andrea_r
    Moderator
    Posted 10 years ago #

    Disable your plugins, including those in the mu-plugins folder. Most of what you've got there is plugin related.

  5. lovewordpress
    Member
    Posted 10 years ago #

    that's what i initially thought but when i run debug, the hosted websites still come up as normal (with the error logs)... it's only the admin areas which do not result in ANY html....

  6. andrea_r
    Moderator
    Posted 10 years ago #

    Right, but did you turn OFF the plugins? Sometimes error logs don't catch everything. White screens are DEFINTELY php errors though.

  7. lovewordpress
    Member
    Posted 10 years ago #

    since i cannot log into the admin area, how can i do this? should i delete all the plugins and the re-upload them? or is there an SQL way of doing it?

  8. tdjcbe
    Member
    Posted 10 years ago #

    Rename the plugins and mu-plugins subdirectories.

    Andrea, I know it's going to be all moot shortly but maybe a Blank Page sticky would be helpful. Considering there are currently 803 threads on the topic. :)

    http://www.google.com/search?q=site%3Amu.wordpress.org%2Fforums+blank

  9. lovewordpress
    Member
    Posted 10 years ago #

    thanks tdjcbe... after i rename them and log back in, do i think rename them back? what's the full procedure?

  10. andrea_r
    Moderator
    Posted 10 years ago #

    Andrea, I know it's going to be all moot shortly but maybe a Blank Page sticky would be helpful.

    As long as people will actually read it. ;)

  11. lovewordpress
    Member
    Posted 10 years ago #

    OK, I renamed the mu-plugins and plugins directory under wp-content and it still does not come up at all.

    next possible solution?

  12. andrea_r
    Moderator
    Posted 10 years ago #

    And you checked the error logs, right?

  13. lovewordpress
    Member
    Posted 10 years ago #

    please point me to the error logs in which you refer so i can verify....

    you help is much appreciated! :)

  14. andrea_r
    Moderator
    Posted 10 years ago #

    The error logs on your server provided by your webhost. If you have cPanel, there's an "Error logs" menu item.

    They are not built by mu.

  15. lovewordpress
    Member
    Posted 10 years ago #

    yes. i looked through those before i turned on debug and didn't see anything...

  16. lovewordpress
    Member
    Posted 10 years ago #

    SOLVED!

    There must have been a parameter that was not completed. I called the following URLs directly.

    update-core.php
    upgrade.php?step=upgrade_db
    upgrade.php

    When I called site/wp-admin/upgrade.php I received an message that the DB had been completed.

    After I was redirected to the home page, I called wp-admin and it came up...

    Not sure what the issue is/was but it worked for me.

    Thanks for your help everyone!!!

    [Note: this was after I ran the update from the menu, reconfigured .htaccess, etc.]

  17. thespecialistsa
    Member
    Posted 10 years ago #

    DUDE YOUR A ROCK STAR lovewordpress

    It worked for me as well :)

About this Topic

  • Started 10 years ago by lovewordpress
  • Latest reply from thespecialistsa