The MU forums have moved to WordPress.org

GoDaddy Install Questions (39 posts)

  1. philip_i
    Member
    Posted 15 years ago #

    Hi all, I'm having a few small issues getting Wordpress MU working on GoDaddy. I think I'm close but haven't quite got it and thought maybe someone could give me some advice.

    The issue I am having is the main blog works fine but I'm trying to create additional blogs for my family to use and those are not working correctly. There are two scenarios, one is if I had setup a subdomain and the other is if there is not a subdomain created.

    If there is a subdomain it gives the following error:

    Forbidden
    You don't have permission to access / on this server.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    --------------------------------------------------------------------------------

    Apache/1.3.33 Server at phil.ingramfamilies.com Port 80

    If there is not a subdomain created it does the following:

    Forbidden
    You don't have permission to access / on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

    --------------------------------------------------------------------------------

    Apache/1.3.33 Server at AppStuff Port 80

    To give some background I've read the readme file and tons of posts on here. To answer some of the common issues, I did an install using sub-domains, installed to root directory, I have the wildcard DNS working (tested with pinging it) and it appears like I have all the php configured correctly. I think my issue might be with Apache, I've emailed GoDaddy to check that the three things in the readme are correct with GoDaddy and I received the following response.

    1. Yes, mod_rewrite is enabled.
    2. The line should be set to "AllowOverride FileInfo Options" by default. This may be specified or you may override this with an .htaccess file.
    3. This is not set by default, but you are able to specify this with an .htaccess file.

    I'm not an expert with .htaccess files so I was hoping someone could help me with what I should put in the .htaccess file to ensure AllowOverride is correct even though they said that should be the default and also to set up the ServerAlias.

    Any help would be greatly appreciated! If you need additional information please let me know.

    Thanks,
    Phil

  2. drmike
    Member
    Posted 15 years ago #

    What errors are listed in the apache and WPMU error logs?

    What specific three things in the readme me file are you talking about?

    Have you checked your file permissions?

    What is in your .htaccess file?

    Have you installed WPMU to the domain root?

    What specifically are you doing to generate that error?

    Did it install?

    Are the database tables present?

    Please talk more about your install. I'm sorry to say you've given us really nothing to go on here.

    I wouldn't trust GoDaddy tech support with a piece of paper myself. Their company has a number of issues with obeying RFCs, internet policies and promoting good customer service. Any company that promotes webspace and bandwidth the equal of an entire server for ten bucks a month should not be trusted.

  3. philip_i
    Member
    Posted 15 years ago #

    1) I don't see any WPMU error files, I've looked in all directories and in the database. Where would I find this? I don't think I have access to the Apache error files.

    2) The three things listed under Apache in the readme:
    1. Make sure a line like the following appears in your httpd.conf
    LoadModule rewrite_module /usr/lib/apache2/modules/mod_rewrite.so

    2. In the <Directory> directive of your virtual host, look for this
    line
    "AllowOverride None"
    and change it to
    "AllowOverride FileInfo Options"

    3. In the <VirtualHost> section of the config file for your host there
    will be a line defining the hostname. You need to add the following
    if you want virtual hosts to work properly:
    "ServerAlias *.domain.tld"
    Replace domain.tld with whatever your one is, and remove the quotes.

    3) If I put a file in a directory with the name of the blog and try it comes up. So it appears that I have file access.

    4) Here is my .htaccess file:
    Options +FollowSymlinks
    RewriteEngine On
    RewriteBase /

    # Rewrite http://www.domain.com to domain.com
    RewriteCond %{HTTP_HOST} ^www\.(.*)
    RewriteRule ^(.*) http://%1/$1 [R,L]

    #uploaded files
    RewriteRule ^(.*)?/?files/(.*) wp-content/blogs.php?file=$2 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    5) Installed to the root directory

    6) If I go to my main blog it works fine(ingramfamilies.com). If I go to a blog which I've also created a subdomain for (phil.ingramfamilies.com) it gives the first error. If I go to a blog which I've not created a subdomain for (philip.ingramfamilies.com) it gives the second error.

    7) Everything appears like it installed correctly and the main blog works just fine.

    8) The database tables were created and have data in them

    9) I installed WPMU 1.0 RC4. Everything seemed to go very smoothly with the install and I didn't run into any issues. The main blog (ingramfamilies.com) was up and worked fine. I created two blogs to test and play with (phil.ingramfamilies.com and philip.ingramfamilies.com) both with me as the main user. There were no error messages when I created them and it created the WP_2 and WP_3 database tables. Can't think of anything else to mention, if there is something else you need please let me know.

    I think my issue is with the virtualhost (Apache issue 3) because they said this was not the default and said I would need to enable it on the .htaccess file, I just don't know how.

  4. philip_i
    Member
    Posted 15 years ago #

    Any additional tips on what I can do to get this to work? To provide an update I have verified that mod_rewrite is working through testing it myself. Also I've updated most files to 777 file permission and it is still not working.

    I still kinda think it has to do with the VirtualHost setup in .htaccess file. I've tried pretty much every way of configuring VirtualHost that I can think of and it is still not working.

    What would cause the main blog ingramfamilies.com to work but not any with a subdomain? The wildcard DNS is working it appears with other things besides the blog.

  5. drmike
    Member
    Posted 15 years ago #

    What's the file permission for the .htaccess file?

    error_log should be in the root of the wpmu install. If it isn't there, create it with a file permission of 0666 or 666.

    I would go back and install the nightly. I don't think it will fix this issue but RC4 is over a month old and had a few minor issues.

  6. philip_i
    Member
    Posted 15 years ago #

    The file permissions for .htaccess is 777.

    I created an error_log file with permissions of 777 in the root directory but nothing has been written in them. Do I need to turn on logging someplace in WPMU?

    I completely deleted my old version of WPMU and all database tables and installed last nights build. Still having the same issue of the main blog working fine but the new blogs don't load.

    I was looking at my phpinfo() and did notice one thing, the "Virtual Directory Support" is disabled. Does this need to be enabled and if so how?

  7. febwa1976
    Member
    Posted 15 years ago #

    I don't know much about this but did you have Godaddy set up wildcard DNS for you?

  8. philip_i
    Member
    Posted 15 years ago #

    Yes, wildcard DNS is setup and tested by pinging false subdomains.

  9. Chandu
    Member
    Posted 15 years ago #

    Any solution to this problem....
    I am also facing the same issue here.

  10. drmike
    Member
    Posted 15 years ago #

    Solution - Don't use GoDaddy. Simple. Why folks to support a company that doesn't follow RFCs, oversell their boxes, and our known for poor client services and for going after joejob victims, I don't know.

    Also maybe looking through the thread and answering the questions posed might help us help you. :)

  11. Chandu
    Member
    Posted 15 years ago #

    Thanks for the suggessions mike.

    I will try to find out the alternatives. Which host do you think would be most suitable for this?

  12. coolrasta
    Member
    Posted 15 years ago #

    I am facing the same issue but don't really thing it is a godaddy problem ...:D Unless you want to save some money ;)

  13. thierryyyyyyy
    Member
    Posted 15 years ago #

    I think the wildcard subdomain is not handled by Apache on GoDaddy.
    did you try to get a file like "http://anysubdomain.yourDomain.tld/test.file" (the .htaccess should be rename something.htaccess)
    if you can read your test.file, Apache is OK.
    If you can't, I think it's because they wildcard the DNS, but not the "virtualhost" in the apache configuration.

  14. rfleigh
    Member
    Posted 15 years ago #

    i am also having this problem. installed wpmu to run with subdomains.

    my wildcard is set up
    i am using a godaddy shared server
    my mod_rewrite is active

    i get the following error when trying to view my blogs

    Forbidden
    You don't have permission to access /wpmu/ on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/1.3.33 Server at AppStuff Port 80

  15. lunabyte
    Member
    Posted 15 years ago #

    Are you "positive" that the Apache configuration file was modified correctly, as well as the DNS wildcard?

    If they say it "was", this could be a way of discouraging MU without coming right out and saying so. If that makes sense. They say everything is set-up correctly, but yet it "doesn't work". Therefore, they can point a user back here, and keep them going in circles.

    Granted, that's speculation, but there's more than one way to skin a cat.

  16. drmiketemp
    Member
    Posted 15 years ago #

    Either that or the file permissions aren't correctly set for the /wpmu/ subdirectory. Please make sure it's set to at least 755.

  17. ziera
    Member
    Posted 14 years ago #

    I think for a successful installation, wpmu would require httpdconf to be configured. GoDaddy Share webhosting wont allow any changes to the httpdconf, so alternative? go for virtual dedicated hosting or find share hosting that allow you to edit their httpdconf or let say they'll do it for you, that should be good enough. Check this out... Its a blog step by step installing wpmu. The part 7? I asked godaddy support, ah ah nope cant do..they told me to go for virtual dedicated instead, so dont waste your time working with the htaccess. Alternative? Go for virtual dedicated hosting, or find some other hosting services or hack godaddy servers and edit their httpdconf..The last part was a joke..

    http://www.blogopreneur.com/2006/11/06/installing-wordpress-mu-on-a-cpanelwhm-server/

  18. don3
    Member
    Posted 14 years ago #

    i use this hosting service to and i have this problem to. After i purchase this hosting service i contact the support and i asked is i'm alowed to use willcard dns and they confirm to confirm to yes. Fixed any one this problem i spend like 100$ and i cant recover back.

  19. heyguy
    Member
    Posted 14 years ago #

    Define ServerAlias in your .htaccess? That's new to me, and honestly, completely ridiculous. If people could define ServerName and ServerAlias in their own .htaccess files they could have unlimited parked and add-on domains, not to mention the ability to really really mess with other peoples' websites on the same server. Think about it for five minutes, then get back to me. I'll wait....

    Okay, welcome back.

    Look people, the hosting issue has been gone over, beaten down, raked through the coals, and dragged for many miles by so many horses. The bottom line is that Mu is not really made for today's shared server environments. Or at least not the ones offering stupid amounts of space for little to no money. They are banking on people uploading their cute little FrontPage sites or somesuch, not people that are actually using server resources and trying to draw serious traffic on top of it.

    If you are on shared hosting you need to have an open dialog with your host to determine if what you are trying to do is within their terms of service and technical ability. There are many boutique hosts that will host your site. Budget hosting is not the way.

    If in the course of setting up your Mu site you receive any kind of resistance from your host - whether they refuse to do something or they don't know how to do something - you need to go elsewhere. This is server software - this is not something you install and maintain through Fantastico. It requires server administrations skills, and it requires a server on which you are allowed to run it. If your friendly neighborhood sysadmin can't or won't help you get it set up, then any workaround you come up with is going to be a band aid. Eventually your site will be suspended and you will have to find a new host. There is experience with that in this forum.

    So seriously, enough of the GoDaddy and Dreamhost and Site5 and Lunarpages and so on and so forth. If you're serious about building a blogging community, be serious about your web hosting. Most of us regulars shell out for our servers, and you never hear any of us bitch about setup issues or performance issues or problems with our hosts. We have better things to do than try to save a couple bucks a month by buying crappy hosting.

    The install as outlined in the README honest-to-god takes five minutes to do, including custom DNS and wildcard subdomains. Invest in your hosting, install by the book, and get on with life.

  20. lunabyte
    Member
    Posted 14 years ago #

    * standing ovation for heyguy *

    Yet folks still think we're kidding, hence all the damn threads on it.

    It's like some are saying... "Gee, I wanna make a fortune and be like wp.com, but I don't want to foot the bill."

    If you're only setting up a few blogs, and want something simpler in terms of administration, MU is probably not the best choice.

    If you're setting up a community, and using MU as it's intended, then shared hosting shouldn't even be an option.

    A bare minimum is a decent VPS, but dedicated is truly the path that should be followed.

  21. andrea_r
    Moderator
    Posted 14 years ago #

    Hey, feel free to start pointing people to the thread where I got booted off shared hosting and all the trouble that was.

    Got a VPS for now. Yep, it's way more than $5-10 a month and worth every penny.

  22. Nokao
    Member
    Posted 14 years ago #

    I came here by google and I resolved the problem myself...

    I made it using a "hosting deluxe plan" (so SHARED hosting, not virtual dedicated server).

    I just:

    1) added, in the dns menu, a "*" as host, and my domain's web address as "points to". TLL=1 hour.
    If you have doubts, look at this guide:
    http://www.blogopreneur.com/2006/11/06/installing-wordpress-mu-on-a-cpanelwhm-server/

    2) I edited a little the .htaccess file created by wordpress removing the "if mod_rewrite" clause, I thought, GoDaddy renamed some configuration stuff to avoid people play with it. (for example a lot of "dangerous" linux command have another name and can't be used with the cron panel).
    So, this is my .htaccess file:
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    Remember to chmod it 666.

    The result is great:
    http://www.nokao.com/photography/personal-galleries/

    I'm also publishing this wordpress theme I did in a month or two.

    Bye

  23. PBO
    Member
    Posted 14 years ago #

    Wildcard DNS for godaddy must be set up with a dedicated IP 3$ a month

  24. Arlo Gilbert
    Member
    Posted 14 years ago #

    Dedicated IP is really expensive

  25. rajeshatbuzz
    Member
    Posted 13 years ago #

    Hi Friends,

    I have Deluxe hosting plan in Godaddy server.

    I have following scenario for installation of WordPress Mu.

    1. I have domain http://www.mysite.com installed, which is alias to ROOT_FOLDER/
    2. Also, I have installed Wordpress Mu to ROOT_FOLDER/blog so my blog link is http://www.mysite.com/blog
    3. Installation and all went fine and it’s working with admin access.
    4. But it’s NOT working when I try to create new blog and new user. It’s showing FILE NOT FOUND …Could you please help me to fix.

    I found lots of blog is talking about this issue but without solution…

    Raj

  26. andrea_r
    Moderator
    Posted 13 years ago #

    "4. But it’s NOT working when I try to create new blog and new user. It’s showing FILE NOT FOUND …Could you please help me to fix."

    Is it a subdomain install, as in the user blogs will be username.yourdomain.com/blog/ ? If so, you forgot a step. Enable the wildcard subdomains according to the readme file.

  27. Limeboy11
    Member
    Posted 13 years ago #

    Any solution to this problem....
    I am also facing the same issue here.

  28. andrea_r
    Moderator
    Posted 13 years ago #

    by clicking on the goddady tag on this thread at the top of the page I foudn this:

    http://mu.wordpress.org/forums/topic.php?id=735#post-19241
    http://mu.wordpress.org/forums/topic.php?id=1853&replies=12#post-36316

  29. rajeshatbuzz
    Member
    Posted 13 years ago #

    Hi Andra,

    thanks for ur reply..could u plz let me know how to Enable the wildcard subdomains according to the readme file.

  30. andrea_r
    Moderator
    Posted 13 years ago #

    Did you read the readme.txt file? It;s in the zip.

About this Topic

  • Started 15 years ago by philip_i
  • Latest reply from zvineyard