The MU forums have moved to WordPress.org

Index page problems - Blog Only Shows when logged into wp-admin (5 posts)

  1. blaze2u
    Member
    Posted 16 years ago #

    This is very strange indeed. I got everything up-n-running and thought everything was working fine with WPMU RC-4. The subdomains work, my plugins work, etc. But when I logged out of the wp-admin... it was a different story!

    For some reason, my site only works when logged into the wp-admin panel -- this is for both the main domain and the subdomains. I tried firefox, opera and internet explorer, but the problem still exists. I don't know what the problem is.

    System Specs:
    Unix Apache 1.3.34
    PHP 4.3.11
    MySQL 4.1.21-standard

    Here is my .htaccess file:

    +++++++++++++++++++++++++++++++++++++++++
    RewriteEngine On
    RewriteBase /

    # Rewrite http://www.domain.com to domain.com
    RewriteCond %{HTTP_HOST} ^www\.(.*)
    RewriteRule ^(.*) http://%1/$1 [R,L]

    #uploaded files
    RewriteRule ^(.*)?/?files/(.*) wp-content/blogs.php?file=$2 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    # Feed Tag Rules
    RewriteRule ^tag/(.+)/feed/(feed|rdf|rss|rss2|atom)/?$ /index.php?tag=$1&feed=$2 [QSA,L]
    RewriteRule ^tag/(.+)/(feed|rdf|rss|rss2|atom)/?$ /index.php?tag=$1&feed=$2 [QSA,L]
    RewriteRule ^tag/(.+)/page/?([0-9]{1,})/?$ /index.php?tag=$1&paged=$2 [QSA,L]
    RewriteRule ^tag/(.+)/?$ /index.php?tag=$1 [QSA,L]

    +++++++++++++++++++++++++++++++++++++++++

    Here is my dns:

    *.domain.com. 14400 IN A 12.12.123.12

    And here is my httpd config file:

    <VirtualHost 12.12.123.12>
    ServerAlias domain.com *.domain.com
    ServerAdmin webmaster@domain.com
    DocumentRoot /home/username/public_html
    ServerName http://www.domain.com

    User username
    Group username
    CustomLog /usr/local/apache/domlogs/domain.com combined
    ScriptAlias /cgi-bin/ /home/username/public_html/cgi-bin/

    <Directory /home/username/public_html >
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    allow from all
    </Directory>

    </VirtualHost>

    +++++++++++++++++++++++++++++++++++++++++

    I believe I did everything right... so what could be the problem? Any help would be greatly appreciated. Please help me, as it's been nearly 5 days of trying to fix this. Thanks in advance!

  2. kipit
    Member
    Posted 16 years ago #

    Hi,

    Do you use widget plugin ? If yes, upgrade to last version.
    Did you sync your template files with latest version ?

    R.

  3. drmike
    Member
    Posted 16 years ago #

    What's in your error logs, both for your webserver and for WPMU? Which theme is this occuring on? Have you cleared your browser cache?

    What is actually happening when you try to visit your site. Telling us "It doesn't work" tells us nothing I'm afraid. Are you getting errors? Is your broswer empty? Have you looked at the Page source? Have you tried removing the plugins like kpit (sort of) suggests? (The common cause of this overe at wp.org is a mucked up plugin causing an issue)

  4. blaze2u
    Member
    Posted 16 years ago #

    Hmmm... well, I did a new install on another domain of mine using the "nightly" install instead, and it appears to be working the way it should. Everything does validate too -- so that's good. But on my 1st install -- you can't even view the source code when trying to access the site, as the server is trying to request the page but it keeps timing out. It could perhaps be something as simple as a corrupted file when uploading -- who knows? I'll redo a fresh install, keep testing and see what happens as I add more subdomains. Thanks for your help guys.

  5. blaze2u
    Member
    Posted 16 years ago #

    Well, I updated all the files from the nightly install to replace the files of the RC4 and it's now working as it should. They should remove the RC4 files and replace them now -- as that install hasn't been updated since July.

    Oh well, thanks again for trying to help me guys! :-)

About this Topic