The MU forums have moved to WordPress.org

Needs to have script put / at end of each url? (9 posts)

  1. justmsw
    Member
    Posted 17 years ago #

    I am not sure how to explain this, so I'll just give it a go.

    My webhost seems to think that my URLs for WORDPRESS all need to have a / on the end of them. otherwise it directs users back to the main website (not wordpress).

    Now, I've got it coded in my theme for that... however, if a user makes a "page" the default loading page,the / gets removed from that page in the menu.

    Confused yet?
    So, lets say my blog would be:
    test.com/wordpressmu/blogging/
    (with that ending slash)
    and I create a page called go
    so it's test.com/wordpressmu/blogging/go/
    now it shows that just fine, UNLESS I make it the default page, at which time, it's link changes to
    test.com/wordpressmu/blogging/go
    which now causes people to direct to test.com

    Make any sense? I just need to know how to change the script so that the url's by default will have that / on the end. How do I do this?

    Thanks and apologies if I confused anyone!

  2. andrea_r
    Moderator
    Posted 17 years ago #

    Check your htaccess file. :)

  3. justmsw
    Member
    Posted 17 years ago #

    Thanks Andrea...
    I have a really dumb follow-up question now... LOL

    I just opened my .htaccess file
    and um... it's got only information pertaining to 403.shtml and some deny IP information in it..

    Um.. what all do I need to put in for wordpress as is there anything in particular I need to start it with so that it's for wordpress? I tried search this site, but didn't come up with a complete answer.

    If you can just point me to where I need to go, I would appreciate it (:

  4. justmsw
    Member
    Posted 17 years ago #

    Ok, I dug a little deeper, and found this:
    http://www.itdamager.com/2005/12/10/wpmu-and-htaccess/

    Well, I tried it... but it still didn't put the trailing slash at the end of my URL that doesn't have one. and I had to take out the domain rewrite because the page never loaded..

    ideas? Sorry for the back to back posts!

  5. justmsw
    Member
    Posted 17 years ago #

    Ok, I have it partly fixed. I crashed the entire thing LOL, got it back up after redoing the .htaccess.. now I have a slight problem.

    The / is working, EXCEPT on the main account.
    IE:

    test.com/blogger
    will direct to test.com
    whereas:
    test.com/blogger/
    goes to that page.

    test.com/blogger/two & test.com/blogger/two/ both go to correct page..

    why is the main account not working? This causes a problem if I have the reading option set to read a subpage first (like About) because then the "link" for about on my theme then points to test.com/blogger
    so we go to test.com

    ): I know I'm just missing something simple.. I'm sure of it! I'm going to keep at it though.

  6. andrea_r
    Moderator
    Posted 17 years ago #

    Well, the install should have created the proper htaccess file for you. Look in the root folder for htacces.dist.

  7. justmsw
    Member
    Posted 17 years ago #

    Thanks Andrea!

    Got that worked out, just having a problem with the main blog not directing correctly (see my post right above yours)

    Other than that I seem to be ok, but it's definetely a monday!

  8. drmike
    Member
    Posted 17 years ago #

    You're not running WPMU on an 'Addon domain' by any chance are you? Sounds like the issue I had with my last host. The trailing '/' mark had to be there or it went to main site for the server.

  9. justmsw
    Member
    Posted 17 years ago #

    Hi drmike,

    Not that I am aware of no.

    I think I have an idea of what's causing it (because I'm just that stubborn!)

    the url being pulled from the information for the main blog is
    url/blogger/

    However, blogger is the folder where ALL of the wp files have been uploaded, so the technical "correct" url for the main blog is: blogger/blog

    (came across that by accident! ha!)

    which is accessible by the / or without. I'm wondering if I change that in the Site Admin part of WPMU under blogs and that blog, if all problems will go away? I'm not even going to wonder why it didn't have that there to start with however, and of course it still doesn't make a whole lot of sense, but oh well!

    What do you think?

About this Topic