The MU forums have moved to WordPress.org

After blog creation, page does not come up (35 posts)

  1. yongra
    Member
    Posted 15 years ago #

    I have Mu verison installed and admin user works fine. But, when I create a blog site and tried to go in, there is no blog site with the new user.

    Can someone help me? I am using apache on the W2K OS.

    Thanks

  2. andreika
    Member
    Posted 15 years ago #

    Hi.
    I have a similar problem. i installed WPMU to server, exmp. url = distance.domain.com/wordpress.
    Admin forks fine. Then i create a user, and get an activation link, an it works. Also i get and url to user's blog url = distance.domain.com/wordpress/username.
    and after going to that url I get message "Page not found". Same message when i go to the post "Hello world" from initial page.

    i guest this is really common problem. please, guru's, responde and explain where is a problem ?? :)

  3. andrea_r
    Moderator
    Posted 15 years ago #

    Got links? Any error messages? What kind of install - subdomain or directory? What build?

    And, just in case, when you added a new user, did you just add a user, or user-with-blog?

    Can't tell exactly what the problem is without more info.

  4. andreika
    Member
    Posted 15 years ago #

    wow, andrea_r, thnx for such a quick response :)
    ok, some detales:
    install type - directory

    my WPMU is on:
    http://distance.ktu.lt/wordpress/
    go to that url.
    click bottom link "Hello world!". you'll see an error message "HTTP 404 - File not found"

    problem nb2: creating user.
    i created user 'xeon'. got a confirmation letter with an activation link. i clicked lick and activated profile xeon, and got a psw in that page. then i have 2 ways: login and view my site.
    user site is http://distance.ktu.lt/wordpress/xeon . when i click it, i get same error - page not found.

    Many Many Thanks in advance!

    p.s. as far as i can see in a database everything that is related with Admin site works fine! i coud see all record in database. nothing is missing. the problem is somewhere with namespace...

  5. andrea_r
    Moderator
    Posted 15 years ago #

    Yep, soemthing is wrong in your setup somewhere.

    First, the main blog is sticking /blog/ in the archive URL for some reason. (You've probably plunked "blog" in an option somewhere.)

  6. andreika
    Member
    Posted 15 years ago #

    some more details pls :) where whoud i look for an answer? i have reinstaled it ten times ;)
    the whole "instalation" is defininf database connection (and database forks fine), that's it, there is no points, where i could plunk anything wrong :)
    any tips or ideas???

  7. andrea_r
    Moderator
    Posted 15 years ago #

    did the htaccess set up correctly?

  8. yongra
    Member
    Posted 15 years ago #

    I am not sure what to setup for htaccess. Is there an example of this file? I know I have not done anything with htaccess.

    Thanks

  9. andrea_r
    Moderator
    Posted 15 years ago #

    Usually, it is set up on installation. Check it, and make sure it is similar to htaccess.dist in the default directory.

  10. andreika
    Member
    Posted 15 years ago #

    .htaccess looks fine. the only difference from htaccess.dist is in second line: RewriteBase Base is changed to RewriteBase /wordpress/

    an example of mine .htaccess. pls take a look does it look good

    RewriteEngine On
    RewriteBase BASE/

    # Rewrite http://www.domain.com to domain.com
    RewriteCond %{HTTP_HOST} ^www\.(.*)
    RewriteRule ^(.*) http://%1/$1 [R,L]

    #uploaded files
    RewriteRule ^(.*)?/?files/(.*) wp-content/blogs.php?file=$2 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

  11. yongra
    Member
    Posted 15 years ago #

    I have the same information in the .htaccess file. It must be a default setting.

  12. andrea_r
    Moderator
    Posted 15 years ago #

    What build are both of you using?

  13. monika_a
    Member
    Posted 15 years ago #

    I'm having a similar problem. When a new user tries to register for a blog (or even a user name), the site just "hangs"/loads forever and doesn't send them an email confirmation or anything. A new user is created, but not a blog. I can go in and add a user in admin, but it also just stays on the page and says "loading" even though it actually does create a new user. Going through admin to create a blog doesn't seem to do anything. I've had some luck with creating a few blogs, but it takes about 3 hours and I try so many different things that I can't repeat it.

    I didn't have this problem until we upgraded to the latest version of WP-MU at the end of July.

    **update** It seems that it takes about a half hour of sitting in the "loading" position before the blog is created by the admin.

  14. yongra
    Member
    Posted 15 years ago #

    Where do I find that? Far as I can see it is 1.0.

  15. yongra
    Member
    Posted 15 years ago #

    I have not seen anymore postings here. Does anyone has any solutions?

    Thanks

  16. andrea_r
    Moderator
    Posted 15 years ago #

    "RewriteBase BASE/"

    This shoudl just be:
    RewriteBase /

    And yongra, I can't tell exaclty what's wrong with the little bit of info you've given me. Got a URL? Is it still doing the same? Did you install it in the root? Is it a v-host or directory set-up?

  17. yongra
    Member
    Posted 15 years ago #

    I am sorry, I should have been more specific.

    Yes. It is still not working.
    The URL us http://mxm.nyit.edu/worlpressmu
    It is installed off of the root (sub-dir).
    It is the directory setup.

    Thanks

  18. carel53
    Member
    Posted 15 years ago #

    I am experiencing simmilar problems.

    firstly i found that during installation the subir name off my installation dir "wpmu" was altered to "php"

    This affected :
    .httaccess, setting RewriteBase
    wp-config.php, setting $base

    Database files :
    wp_blogs, field path
    wp_site, field path
    wp_users, field user_url
    WP_1_posts, field post_content
    wp_1_posts, field option value (several records)
    wp_1_comments, field comment_author_url

    In addition the subdir wpmu/new_user is not created as i guess it should be. This after correcting the problems mentiond above.

    When I create the users subdir manualy and copy all files from the wpmu directory to it, the blog site of the new user works fine.

    Also i am missing the subdir "blogs" that is reffered to on several occasions, as it is not created during setup. Not knowing what it should contain, i can't recreate it.

    wpmu version, latest, downloaded october 4
    Apache version 1.3.19, seems to work fine after altering a load of stuff manualy.

    All this on w2k
    local URL http://localhost.localdomain/wpmu/ *
    Not tested on a webserver.

    Any suggestions how to proceed with my struggles to get wpmu running?

    All of this written with the aid of my cat who has tryed to sleep on my keyboard, sit in front of my keyboard and screen and finaly found the ultimate instrument to get attention. It pushed my calculator witch in turn dropped my drink, resulting in me heaving wet feet :-)

    Carel53

  19. andrea_r
    Moderator
    Posted 15 years ago #

    carel, I suspect something's wrong with your local setup, as it shouldn't rename the dir to "php".

    Blow it away, check everything (Apache etc...) and reinstall.

    yongra, I'm poking around now.

  20. andrea_r
    Moderator
    Posted 15 years ago #

    Yongra, check the files on your server, specifically to make sure wp-activate.php is there.

    Because I'm getting an error that it's not.

  21. yongra
    Member
    Posted 15 years ago #

    andrea_r:

    I have check the directory and the file is in there. It is in the same directory as all of other files.

    Thanks

  22. kodama
    Member
    Posted 15 years ago #

    I seem to be having a similar problem to everyone here...

    Installation and admin appear to be working without any problems. Clicking on a post header, or comment link gives

    "Not Found
    The requested URL /blog/2006/10/08/welcome/ was not found on this server."

    Attempting to set up a test blog (http://test.southernsteppa.com/) doesn't seem to have worked. The confirmation email was sent, but clicking on the link gives

    "can't find the server at test.southernsteppa.com"

    After searching the forums, it seems that .htaccess could be the problem, however my file is similar to those I have found on the forums. The functioning site is at http://www.southernsteppa.com

    Any help would be hugely appreciated.

    Best.

  23. kodama
    Member
    Posted 15 years ago #

    Checking with my host, my .htaccess wasn't enabled. After rectifying that, I no longer get the 404 error messages, but instead, the offending links don't seem to take me anywhere.

    Any ideas what i'm missing?

  24. yongra
    Member
    Posted 15 years ago #

    How do you enable the .htaccess?

  25. theworkisdone
    Member
    Posted 15 years ago #

    Your hoster normally reloads the webserver on a regular basis, e.g. every 15 minutes. Some of the htaccess rules become active after successfull reload.

  26. gillesbeauchamp
    Member
    Posted 15 years ago #

    I have something similar : the blogs are created (at least partially) cause the activation is sent, the administration login is possible, the cration of posts... but noting is visible, there is no public face of the blogs : 404

    Gilles

  27. andrea_r
    Moderator
    Posted 15 years ago #

    Gilles; are they created fully in the database?

  28. markpea
    Member
    Posted 15 years ago #

    Guess what? I'm having the same problems as the fellows here. I downloaded wordpress-mu-1.0-tart.gz on Oc 24th and installed it a coiuple of days later. The install went fine and created all the MySQL tables as expected. I sussed out how to create a user & a blog (I created the blog first and then the user) and, behold, the user was apparently created and an email duely dispatched. But, alas, the link didnae work giving a 404 not found error. Try ec281.lly.earlham.edu/WPMU/spiggy

    .htaccess is there and as far as I can tell functional. No, I think that Carel53 has put his finger on the issue : the individual blog directories are just not being created. That is, I assume (although I cannot find it written anywhere) that each individual blog gets a copy of the main 'admin' blog to go with their database tables. Anyhow, these are not being created. So, I would expect to find /WPMU/spiggy and a bunch of php files in there. Nope. No 'spiggy' directory.

    One thing is that I am not using the virtualhosts option and I am not using the root of the webserver. Thus my URL is ec281.lly.earlham.edu/WPMU .Could this make difference? Seems unlikely to affect the generation of the user's blog files though

  29. markpea
    Member
    Posted 15 years ago #

    I have checked the tickets on http://trac.mu.wordpress.org but there does not seem to be a ticket for this problem ....

  30. andrea_r
    Moderator
    Posted 15 years ago #

    "I created the blog first and then the user"

    If you create a blog manually and the user doesn't exist, it will create it. If you're creating a blog and then also creating a user, there's probably all kinds of things messed up somewhere.

    "So, I would expect to find /WPMU/spiggy and a bunch of php files in there. Nope."
    No, the directories are not created. Even the subdirectory blgo for a user is *virtual*. They exist only in the database. The only hard directories that get created on the server are the ones for file uploads and they go by user number.

    The amdin blog does not have a bunch of "stuff" in a directory. Just the whole MU program, which is shared for all users. Again, *virtually*.

    Also, I have noted people who have the most issues are running an install in a subdirectory off a subdomain. It wasn't really meant to be used like that. I would imagine internally it creates a mess.

About this Topic