The MU forums have moved to WordPress.org

After blog creation, page does not come up (35 posts)

  1. markpea
    Member
    Posted 17 years ago #

    Thanks for the explanation of how WPMU works. I couldn't find that in the README or FAQ.

    Also, I have noted people who have the most issues are running an install in a subdirectory off a subdomain. It wasn't really meant to be used like that. I would imagine internally it creates a mess.

    So, basically what you're saying is that if I have the install in /WPMU I still need a VHOSTS directive in apache.conf that maps something like 'blogs.earlham.edu' to this directory? The README file refers to installing in the root of the domain or a subdirectory but it's not clear that it won't run directly from that subdirectory off the subdomain. Doing the VHOST thing requires that the DNS gets set to map 'blogs.earlham.edu' to 'myhost/WPMU/' right?

  2. spaccioman
    Member
    Posted 17 years ago #

    Hi,
    i'd installed wpmu on my vps on the subdomain http://blog.spaccioworld.com Now i have created the first user account "mix1986" but the address http://mix1986.blog.spaccioworld.com don't work I have inserted the mx record in dns *.spaccioworld.com but the trouble is the same: i can see only the error page of my plesk. What's i can do? .htaccess is configured automatically or not?

  3. johnsong
    Member
    Posted 17 years ago #

    If you are getting a 404 Not Found error like I was, then this thread http://mu.wordpress.org/forums/topic.php?id=2556&replies=4 explains how it was fixed [on linux].

    I installed MU with the directory option, not domain opt.

    Even with the correct .htaccess file, the problem was in the httpd.conf

  4. rchennau
    Member
    Posted 16 years ago #

    The changes to httpd.conf and .htaccess fix the issue forme as well. It is a bit frustrating to note that after a year this install issue still exist. Someone should update the install docs.

  5. bnettles
    Member
    Posted 16 years ago #

    This install docs are accurate...just confusing for many people. This is what the README.txt file says.

    2. In the <Directory> directive of your virtual host, look for this
    line
    "AllowOverride None"
    and change it to
    "AllowOverride FileInfo Options"

    In my Red Hat Apache httpd.conf file, you will find this.

    <Directory "/var/www/html">

    #
    # Possible values for the Options directive are "None", "All",
    # or any combination of:
    # Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
    #
    # Note that "MultiViews" must be named *explicitly* --- "Options All"
    # doesn't give it to you.
    #
    # The Options directive is both complicated and important. Please see
    # http://httpd.apache.org/docs-2.0/mod/core.html#options
    # for more information.
    #
    Options Indexes FollowSymLinks

    #
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    # Options FileInfo AuthConfig Limit
    #
    AllowOverride FileInfo Options

    #
    # Controls who can get stuff from this server.
    #
    Order allow,deny
    Allow from all

    </Directory>

    If the AllowOverride in not changed at this particular spot, the subdirectory blogs will give you Page Not Found.

About this Topic