The MU forums have moved to WordPress.org

Install with MAMP (19 posts)

  1. ryanfitzer
    Member
    Posted 17 years ago #

    Trying to get today's nightly running on my Mac with MAMP but keep getting this error

    $base is set to BASE when it should be the path like "/" or "/blogs/"!

    I have it installed within MAMPs htdocs directory in wpmu060920. Any ideas?

  2. ryanfitzer
    Member
    Posted 17 years ago #

    I set $base to "/" and set the server address to localhost:8888/MAMP and now get this message (this seems like progress):

    "No WPMU site defined on this host. If you are the owner of this site, please check Debugging WPMU for further assistance."

    I went to the "Debugging WPMU" link but found nothing that could help me.

    Anyone else successfully set up WPMU with MAMP?

  3. donncha
    Key Master
    Posted 17 years ago #

    You should probably run MAMP on port 80. I got it working myself, but it was a month ago and I can't remember the hoops I jumped through. $base is set to '/' and the rewrite rule in .htaccess is '/' too.

  4. andrea_r
    Moderator
    Posted 17 years ago #

    "I have it installed within MAMPs htdocs directory in wpmu060920"

    Then try localhost:8888/MAMP/wpmu060920 or localhost:8888/wpmu060920

  5. ryanfitzer
    Member
    Posted 17 years ago #

    andrea_r, I've tried both of those addresses during the set up (I'm going to try again as well) with no luck. Maybe it was just some fluke or typo or something (2 hours worth). Have you had success before?

    donncha, I'll give that port a try. I currently have WordPress running on port:8889 (which was a breeze to set up link to tutorial). Not sure if this would pose a conflict as I don't have that much experience with MAMP.

  6. drmike
    Member
    Posted 17 years ago #

    Not a clue from me I'm afraid. I have two Mac XServes but neither one has a webserver on them.

  7. ryanfitzer
    Member
    Posted 17 years ago #

    Still nothing. Donncha I'm not sure how install MAMP on port:80. I'm not even sure where to look. Does this involve opening up the Terminal. I tried that once while installing MySQL. Got it working but never was able to do anything with it (not a real command line type).

    andrea_r, tried every version possible. No luck. I left a comment on the post that I linked to above asking if the author had any advice on installing WPMU. We'll see.

  8. andrea_r
    Moderator
    Posted 17 years ago #

    Just a guess really as I have Mu setup locally on a Winblows box, with XAAMP. :-/

  9. audihertz
    Member
    Posted 17 years ago #

    Did anyone find a solution for this? I'm having the exact same problem as described above:
    "No WPMU site defined on this host. If you are the owner of this site, please check Debugging WPMU for further assistance."

    Want to run this locally just so I can get an understanding of MU.

  10. lunabyte
    Member
    Posted 17 years ago #

    Using MAMP?

    Uh, Mac's already come with apache. ;)

    Might need MySQL, but other than that, it's good to go.

    Only thing you need to do is call your pages by 127.0.0.1, and presto.

  11. BondageRadio
    Member
    Posted 17 years ago #

    Mamp is actually wonderful for Macs because of the ease of setup for PHP and SQL

    Port designations are simply in the preference panel of the MAMP application (I'm also a member of the MAMP.INFO forums ... there's more info over there)

    As far as WPmu install on MAMP, simply make sure you have the latest update of MAMP, I'm not sure what the changes were that broke WP on this last set of updates, but they have been addressed and should be working as advertised now.

    I have not used subdomains in any of my installs, so I have no reference there, but given the difficulties of MAMP using Virtual Domains, there may be some issue there as well... keep your eyes open if you try it.

  12. lunabyte
    Member
    Posted 17 years ago #

    I dunno. The only thing I've needed was MySQL. Of course, now that I think about it, it might have been Php too. Oh well, nothing terminal couldn't fix. :D

    The last box I set up was probably 18 months ago. Here in the (hopefully) not too distant future I'll be doing a fresh one again.

  13. suleiman
    Member
    Posted 17 years ago #

    so there is still no easy way of setting up MAMP with MU?

  14. lunabyte
    Member
    Posted 17 years ago #

    Not if you're using port numbers, no.

    And, Donncha's specifically stated that it won't be fixed.

  15. donncha
    Key Master
    Posted 17 years ago #

    It will be fixed if someone else does it. I don't have the time I'm afraid to devote to that problem.

    It is possible to run MAMP on port 80, I have, and it works very well. Just search Google for "MAMP port 80" and you'll get lots of information about it.

  16. lunabyte
    Member
    Posted 17 years ago #

    OK, my bad. Kinda. ;)

    I still don't get it though, since Mac's already come with Apache, which works very well out of the box.

    Getting MySQL running isn't a problem, and neither is PHP.

    Tons of google info out there on it, as well as running mamp on :80.

    Edit /etc/hosts and you can do subdomains locally for testing too. :O

  17. suleiman
    Member
    Posted 17 years ago #

    hmm...i knew Jobs wouldn't let this one sit. ;)

  18. creatina
    Member
    Posted 17 years ago #

    I've got this problem:
    WPMU only works without the port number in the URL.

    http://localhost:8888/wordpress-mu/

    Who knows how to solve it?

    Thanx

  19. drmike
    Member
    Posted 17 years ago #

    Not sure why you're cross posting this. Most forums frown on stuff like that.

    You have a couple of issues there:

    - Mu needs to be run on port 80. I would suggest modifying MAMP to the new port as mentioned up above.

    - You're running it on localhost. Try using localhost.localdomain instead. That's been discussed before as well.

    Hope this helps,
    -drmike

About this Topic

  • Started 17 years ago by ryanfitzer
  • Latest reply from drmike