The MU forums have moved to WordPress.org

Blog admins cannot add categories (13 posts)

  1. ksenia
    Member
    Posted 17 years ago #

    Hi,

    When I am logged in as a blog admin, and try to add new category, I get the error:
    "You don't have permission to do that."

    I hope somebody can help me to solve this!

    Thanks.

  2. ksenia
    Member
    Posted 17 years ago #

    Ok, I've found it. The problem is that i've customized the code for reading username and password from the cookies, and forgot to adjust the function "check_ajax_referer" that reads the cookies from $_GET or $_POST.

    The reason for customizing WP code is because my Python application in the root of the site also takes care of setting the login cookie for WPMU in /blog/. And the Python framework I am using insists on quoting every cookie value, what causes problem when PHP reads cookie.

    I know very little about PHP so if anybody have an idea how to force PHP to assume that every cookie value is quoted without customizing WPMU code, I'll be glad to know.

    thanks!

  3. nolageek
    Member
    Posted 17 years ago #

    Im getting the same error message. I also get that message when in bbpress when I try to delete individual posts. I can delete the entire topic though.

    I tried removing all plugins too, still the same error.

    Even as Site Admin I can't create new topics.

  4. nolageek
    Member
    Posted 17 years ago #

    These are the problems I'm having:

    ///////// in wpmu ////////////////

    3 out of 4 Blog Admins are complaining that they get "You do not have permission to do that." errors when they try to delete posts or add categories.

    The Site Admin also gets this error when I try to add categories with the stock category.php file. After I installed a Category Manager plugin Admin was able to add categories - but Blog Admins keep getting the same error even if they used the plugin.

    ///////// in bbpress /////////////

    Admin can create new posts, I can edit posts.

    Admin can delete entire TOPICS, but not individual POSTS.

    I just noticed that after a post is saved I can add one (1) tag, but not delete it. I cannot create additional tags on a post after that first one.

    I can create multiple tags at once when the post is first created.

    This is really getting on my nerves now. I've reuploaded WPMU once. I've reinstalled bbPress twice - once using all new tables.

    I would think it HAS to be something to do with permissions, but I can't tell what the are in the database... what tables should I look at??

    Running WPMU 1.2.1
    bbpress “Desmond” version 0.8.1-1
    PHP 4.4.6

    /////////////////////////
    // bbpress config.php ///
    /////////////////////////

    in /forums/
    
    <?php
    require_once('/home/nolageek/public_html/wp-blog-header.php');
    // ** MySQL settings ** //
    define('BBDB_NAME', '----------');      // The name of the database
    define('BBDB_USER', '----------');     // Your MySQL username
    define('BBDB_PASSWORD', '------------'); // ...and password
    define('BBDB_HOST', 'localhost');    // 99% chance you won't need to change this value
    
    // Change the prefix if you want to have multiple forums in a single database.
    $bb_table_prefix  = 'bb_'; // Only letters, numbers and underscores please!
    
    	$bb->domain = 'http://blognola.org'; // Example:
    	$bb->path   = '/forums/';	
    
    //bb->mod_rewrite = true;
    
    // What are you going to call me?
    $bb->name   = 'BLOG NOLA forums';
    
    // This must be set before running the install script.
    $bb->admin_email = 'nolageek@gmail.com';
    
    // Set to true if you want pretty permalinks.
    $bb->mod_rewrite = true;
    
    // The number of topics that show on each page.
    $bb->page_topics = 30;
    
    // A user can edit a post for this many minutes after submitting.
    $bb->edit_lock = 60;
    
    // Your timezone offset.  Example: -7 for Pacific Daylight Time.
    $bb->gmt_offset = -6;
    
    $bb->cookiepath = '/';
    $bb->usercookie = 'wordpressuser';
    $bb->passcookie = 'wordpresspass';
    
    // Change this to localize bbPress.  A corresponding MO file for the
    // chosen language must be installed to bb-includes/languages.
    // For example, install de.mo to bb-includes/languages and set BBLANG to 'de'
    // to enable German language support.
    define('BBLANG', '');
    
    // Your Akismet Key.  You do not need a key to run bbPress, but if you want to take advantage
    // of Akismet's powerful spam blocking, you'll need one.  You can get an Akismet key at
    // http://wordpress.com/api-keys/
    $bb->akismet_key = ''; // Example: '0123456789ab'
    
    // The rest is only useful if you are integrating bbPress with WordPress.
    // If you're not, just leave the rest as it is.
    
    $bb->wp_table_prefix = 'wp_';  // WordPress table prefix.  Example: 'wp_';
    $bb->wp_home = 'http://blognola.org';
    $bb->wp_siteurl = 'http://blognola.org';
    
    /* Stop editing */
    
    if ( !defined('BBPATH') )
    	define('BBPATH', dirname(__FILE__) . '/' );
    require_once( BBPATH . 'bb-settings.php' );
    
    ?>

    /////////////////////////
    // wpmu wp_config.php ///
    /////////////////////////

    in /

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'nolageek_blognola');    // The name of the database
    define('DB_USER', '----------');     // Your MySQL username
    define('DB_PASSWORD', '-----------'); // ...and password
    define('DB_HOST', '------------');    // 99% chance you won't need to change this value
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');
    define('VHOST', 'yes');
    $base = '/';
    
    // double check $base
    if( $base == 'BASE' )
    	die( 'Problem in wp-config.php - $base is set to BASE when it should be the path like "/" or "/blogs/"! Please fix it!' );
    
    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix  = 'wp_';   // example: 'wp_' or 'b2' or 'mylogin_'
    
    define('ENABLE_CACHE', false);
    
    // Change this to localize WordPress.  A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');
    
    define( "WP_USE_MULTIPLE_DB", false );
    
    /* That's all, stop editing! Happy blogging. */
    
    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>
    

    /////////////////////////
    // .htaccess ///
    /////////////////////////

    in /

    
    RewriteEngine On
    RewriteBase /
    
    # www is soooo deprecated
    RewriteCond %{HTTP_HOST} ^www.blognola.org$ [NC]
    RewriteRule ^(.*)$ http://blognola.org/$1 [R=301,L]
    
    RewriteCond %{HTTP_HOST} ^www.disgruntledmumblings.com$ [NC]
    RewriteRule ^(.*)$ http://disgruntledmumblings.com/$1 [R=301,L]
    
    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*.php)$ $2 [L]
    RewriteRule . index.php [L]
    
  5. nolageek
    Member
    Posted 17 years ago #

    bumped out of desperation.

  6. nolageek
    Member
    Posted 17 years ago #

    anyone? please? I'm seriously about to give up. If you need admin rights to the blog and access to my phpadmin.. it's yours. I can't figure out what happened to my permissions. I just completely deleted wpmu and reuploaded it. I'm still getting this "you dont have permission to do that."

    in wp_1_capabilities I have this:

    a:1:{s:13:"administrator";b:1;}

    Could someone decipher this?

    Is it a cookie issue? I've gone over everything I can think of.

  7. nolageek
    Member
    Posted 17 years ago #

    in wp_*_options the blog_id's are all set to 0. It's like that in all wp_*_. Is that correct?

  8. nolageek
    Member
    Posted 17 years ago #

    brand new install. Brand new database. Still getting this error. wtf?

  9. nolageek
    Member
    Posted 17 years ago #

    If a blogger asks a question in a forum and no one is there to read it, did he really ask?

    Oh my god, this is just getting weirder and weirder. I'm now using the original installation and trying to troubleshoot the catagory issue.

    I have two categories "updates" and "Blogroll."

    In the Create New Category Form, where is asks for a possible Parent Category there are THREE options.... all of which are a combination of the two current categories: "updates Blogroll"

    screenshot:
    http://i32.photobucket.com/albums/d27/nolageek/updates.png

    Is my WUWP freakin' haunted or something??

  10. andrea_r
    Moderator
    Posted 17 years ago #

    Somethign similar is hapening to me. A user delelted the category "blogroll" and is now wondering why her links won't show up.
    It won't let me add that category back.

  11. ovationfinancial
    Member
    Posted 17 years ago #

    bump

  12. billdennis5
    Member
    Posted 16 years ago #

    I'm going to have to bump this too. It seems that I cannot delete categories. I thought it might be solved by opening a new browser window, or even restarting my laptop.

    Any advice would be appreciated.

  13. drmiketemp
    Member
    Posted 16 years ago #

    Bill, you need to tell us what you're looking at. What happens when you try to delete categories? Do you get an error or what? What level of access do you have? what browser and browser version are you using? etc.

About this Topic

  • Started 17 years ago by ksenia
  • Latest reply from drmiketemp