The MU forums have moved to WordPress.org

Visual Rich Editor no-go. Comments likewise (5 posts)

  1. thornelawler
    Member
    Posted 17 years ago #

    Hi Folks!

    My WPMU 1.0rc4 server is giving me a little grief:

    1. The "Rich Visual Editor" doesn't seem to work: when I use it my posts show up with no body, and I can confirm that the body text never makes it into the database. The plain old editor still works fine.

    2. If I post a comment, I hit the submit button and get a blank white page. Turning on "display errors" in php.ini does not change the white, blankness of these pages. No errors come out in the apache log. Is there some simple, obvious debugging mechanism for WPMU or WordPress that I'm unaware of?

    Thanks in advance.

    --
    Thorne

  2. thornelawler
    Member
    Posted 17 years ago #

    If there's any further information I need to give, I am more than willing. I just really need assistance with this... Help! Please!

  3. dsader
    Member
    Posted 17 years ago #

    Thorne,
    I've seen your first problem on my install a while ago. I got a bright idea one day to upload a new build of tinymce with all it's plugins enabled. Looked cool, lots of new shiny buttons to press. Poof, nothing saved in the posts. Just as you described.(Only in Firefox, if I recall)

    Deleted my new tinymce, uploaded the original packed with wpmu rc4 I think. Enabled new plugins half at a time, disabled the offending ones and away I went.

    All is well.

    dsader

  4. thornelawler
    Member
    Posted 17 years ago #

    I fixed it without reinstalling. In the end I took the advice of the Debugging WPMU page (http://trac.mu.wordpress.org/wiki/DebuggingWpmu) and stuffed my wp-comments-post.php with mindless little print_r statements until it became aparrent that my POST data was never getting there.
    The answer? I had just moved my site to legitimately certified SSL and in the process I had arranged rewrite rules to channel all unencrypted traffic to the SSL equivalent URL. What I had not done was crawl through every URL in every blog in WPMU and change the URLs there to reflect the https-ness of things. The redirect was aparrently throwing away my POST data. [C3PO] How rude! [/C3PO]

  5. thornelawler
    Member
    Posted 17 years ago #

    I should add: this also fixed the Rich editor. Same problem exactly.

About this Topic

  • Started 17 years ago by thornelawler
  • Latest reply from thornelawler