The MU forums have moved to WordPress.org

Upload Permissions Problem (4 posts)

  1. vCarey
    Member
    Posted 17 years ago #

    I've installed WPMU (Build 082605)and I'm having a permissions problem (I think).

    When a new user is created and wants upload an image, this is what comes up:

    Warning: dir(): SAFE MODE Restriction in effect. The script whose uid/gid is 4112/4112 is not allowed to access /mounted-storage/home6/sub002/sc13146-WEKN/www/wp-inst/wp-content/blogs.dir owned by uid/gid 99/99 in /mounted-storage/home6/sub002/sc13146-WEKN/www/wp-inst/wp-includes/wpmu-functions.php on line 45

    Warning: dir(/mounted-storage/home6/sub002/sc13146-WEKN/www/wp-inst/wp-content/blogs.dir/1/files/): failed to open dir: No such file or directory in /mounted-storage/home6/sub002/sc13146-WEKN/www/wp-inst/wp-includes/wpmu-functions.php on line 45

    Fatal error: Call to a member function on a non-object in /mounted-storage/home6/sub002/sc13146-WEKN/www/wp-inst/wp-includes/wpmu-functions.php on line 48

    I have to go into wp-content/blogs.dir and create a directory based on their id and another one within it named files and manually set the permissions to 777 for both in order for image upload to work.

    Is there a way I can get this to work automatically.

  2. Smoothie
    Member
    Posted 17 years ago #

    Tell your host to turn PHP safe mode off, or get a decent host.

  3. vCarey
    Member
    Posted 17 years ago #

    I thought they were "decent". Nobody tells you before you sign up with them that you will have problems with their server settings when you install Wordpress MU. And since I found them through someone who had Wordpress 1.5 installed and running...

  4. Smoothie
    Member
    Posted 17 years ago #

    Webservers shouldn't have to run in safe mode. Ask your host to turn it off, with your reason.

About this Topic