The MU forums have moved to WordPress.org

Links on blog aren't working (12 posts)

  1. Rubyducky
    Member
    Posted 16 years ago #

    Hello everyone!
    Recently installing WP with no problem, I ran into this issue. When I go to the blog, none of the links work. The comment links don't work, the archives and the category links don't work and give me a 404 error when clicking them. Any ideas? Thanks!

    Ryan

  2. andrea_r
    Moderator
    Posted 16 years ago #

    Without any further information, I'd say it wasn't installed correctly. You may have forgotten a step. Got a link? Is it a vhost install? Did you enable vhosts? How do the links "not work"? Where are they pointing to?

  3. Rubyducky
    Member
    Posted 16 years ago #

    Sorry about that, I was thinking it wasn't installed correctly, it's on my home machine, the link is http://karc.ath.cx

    If you click on "Uncategorized" and "comments" For example, it brings up a 404 error. I'm' not sure about the vhosts thing, but the links give a 404 error.

  4. andrea_r
    Moderator
    Posted 16 years ago #

    Yeah, it's sticking /blog/ there in the links. Dig around in your htaccess.

  5. Rubyducky
    Member
    Posted 16 years ago #

    Well here's my htaccess if anyone can tell me what I can do to fix it

    RewriteEngine On
    RewriteBase BASE/

    # Rewrite http://www.domain.com to domain.com
    RewriteCond %{HTTP_HOST} ^www\.(.*)
    RewriteRule ^(.*) http://%1/$1 [R,L]

    #uploaded files
    RewriteRule ^(.*)?/?files/(.*) wp-content/blogs.php?file=$2 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

  6. Rubyducky
    Member
    Posted 16 years ago #

    Also, I forgot to add, if I manually remove the /blog/ from the address, it still gives me a 404 error.

  7. mozey
    Member
    Posted 16 years ago #

    RubyDucky,
    It seems that apache gets confused whenever it has to interpet any of your URLs. You do have mod rewrite installed right? to find out, open your httpd.conf and make sure that the mod_rewrite.so module is there. (or whatever version of that windodws use).

  8. Rubyducky
    Member
    Posted 16 years ago #

    In my httpd.conf/htaccess, I don't see mod_rewrite anywhere, here's what's inside the file anyways. Do I need to add something?

    # Rewrite http://www.domain.com to domain.com
    RewriteCond %{HTTP_HOST} ^www\.(.*)
    RewriteRule ^(.*) http://%1/$1 [R,L]

    #uploaded files
    RewriteRule ^(.*)?/?files/(.*) wp-content/blogs.php?file=$2 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

  9. mozey
    Member
    Posted 16 years ago #

    Okay, so here is the deal. SOmetimes, your URL actually looks like this.

    http://www.bladihahaha.hippies/?i=look&very=ugly&seriously=UGLY

    mod_rewrite is an apache module which allows you to translate THIS

    http://www.bladihahaha.hippies/i-look-good

    into the ugly URL. You dont have mod rewrite, so your apache is getting confused. Because there is nothing there to translate the nice URL to the UGLY url.

    Now, in normal wordpress, you can tell wordpress not to use this apache feature however NOT in MU. So you NEED to figure out how to get mod rewrite working on your server in order to solve this.

  10. Rubyducky
    Member
    Posted 16 years ago #

    I strongly believe I enabled the mod_rewrite, I'll have to double check. The httpd.conf/htaccess file I posted above was my root directory, do I need to put it somewhere else? But when I installed muwp, it warned me that I needed to enable it. I think I enabled it and the warning went away. I'll double check though and thanks for telling me what the problem is.

  11. mozey
    Member
    Posted 16 years ago #

    actually, the httpd.conf file is not in your root direcotry. Well, i guess it could be, but 99% it is'nt. .htaccess file has nothing to do with this.

    Try to find a good document online that would walk you through installing mod rewrite on windows apache. I would just tell youy what you have to do, but i'm not a windows guy AT ALL.

  12. Rubyducky
    Member
    Posted 16 years ago #

    Thank for all your help everyone! Turns out that by changing my permalink structure to default, it fixed everything! Topic resolved =D!

About this Topic

  • Started 16 years ago by Rubyducky
  • Latest reply from Rubyducky