The MU forums have moved to WordPress.org

Install into folders, non vhost working again (20 posts)

  1. donncha
    Key Master
    Posted 17 years ago #

    I spent the best part of today debugging the living daylights out of this so I'll expect VERY GOOD bug reports back if this breaks. (anyone who responds with the equivalent of "it doesn't work" will be summarily taken outside and given a wedgy by Bob The Dinosaur (see Dilbert cartoons, circa 1989))
    This works on my installs:
    1. vhosts: installed into the root and into folders.
    2. folders: installed into the root and into folders.

    This code is so fresh and so much has changed that it's liable to break. I want everyone to test it on a spare server before putting it live! I'm not putting this baby on wordpress.com just yet as so much has changed.
    I leave you with this inspirational message: PLEASE TEST! PLEASE TEST! PLEASE SEND CODE PATCHES!

  2. andrewbillits
    Member
    Posted 17 years ago #

    I'm on apache with PHP4 amd it works just fine. Thanks for working hard on it donncha. Btw, is there any way to allow users to choose a category for their blog while signing up? city or state for example.

  3. Smoothie
    Member
    Posted 17 years ago #

    Excellent! Support for non-vhosts! What can I say... you don't stop working till this thing's perfect, I admire that. Keep it up donncha, if only more developers were like you ;)

  4. Smoothie
    Member
    Posted 17 years ago #

    Seems to be working well... first problem I've had is that uploading pictures doesn't work anymore - they upload fine, but the link provided is

    <img src='/files/image.jpg' alt='comment' />

    Which creates a broken image, for me. The blog URL is http://smoothie.biz.tm/smoothie/ and it links to http://smoothie.biz.tm/files/image.jpg - which, when visited, returns

    "Fatal Error
    Could Not Find Blog!
    Searched for smoothie.biz.tm/ in smoothie_blogs::wp_blogs table. Is that right?"

    Any ideas? Cheers.

  5. Korora
    Member
    Posted 17 years ago #

    Hey.
    I installed 2005-09-01 version and it workes very well now. But there are still several problems:

    1. On my host, I got "child pid **** exit signal Segmentation fault (11)" error and apache falls(?) on Step 3 under the installation. I commented out "wp-db.php" line 238:
    $this->col_info[$i] = @mysql_fetch_field($this->result);

    WPMU looks liks work fine now, but this solution can cause another problems in future. I don't know...

    2. The same problem as Smoothie; I don't knou how to access the uploaded files.

    3. I'm not using vhosts, but urls of blogs on Site Status in the administration page are still with vhosts(e.g. they should be http://example.com/BlogId/ but the outputted urls are actually http://BlogId.example.com).

    4. When I click "Sign Out", I get Fatal error:

    Could Not Find Blog!

    Searched for example.com/ in wordpress::wp_blogs table. Is that right?
    Please check that your database contains the following tables:
    wp_blogs
    wp_users
    wp_usermeta
    wp_site
    wp_sitemeta
    wp_sitecategories

    ...
    Othewise this blogsystem works very fine;)
    So, I hope that these problems will be repaired.

  6. donncha
    Key Master
    Posted 17 years ago #

    Thanks for those bug reports. I'll try to fix them today!
    I can't understand why you got a seg fault Korora - was there anything else in the error logs? Are you using PHP4 or PHP5?

  7. donncha
    Key Master
    Posted 17 years ago #

    Upload path is now fixed! I updated the downloads.
    Changed files:
    wp-inst/wp-content/blogs
    wp-inst/wp-includes/wpmu-functions.php

    If you have existing blogs then look in the options table for "fileupload_url". It should be of the form http://example.com/path/blogname/files/

  8. Korora
    Member
    Posted 17 years ago #

    Hi donncha.
    Upload path is now fully functional on my host!
    But the IMG tag which is shown after uploading doesn't seem to work (at least on non-Vhost installation). Maybe it would be fine if users can get the tag with global path which begins with "http://".

    About seg fault, my environment is PHP 4.3.11, Apache 2.0 and OS is Linux. I couldn't find anythng else than seg faults on the error logs. Do you have any ideas to solve this fault?

    Thanks.

  9. donncha
    Key Master
    Posted 17 years ago #

    How does the url differ from that of your host? email me at donncha @ linux.ie if you don't want to publish your site's URL here.

  10. partypageusa
    Member
    Posted 17 years ago #

    I'm having a wierd problem. I can't seem to access the subdomains that I had set up or even the folder on my site. I get this message when I try to load the page. Also another problem with the same error message is when I try to access the archive and categories page. Is this error due to the .htaccess file not rewriting the page? If so how do I fix?

    Fatal Error
    Could Not Find Blog!
    Searched for domain.com/ in host_wordpress::wp_blogs table. Is that right?
    Please check that your database contains the following tables:

    * wp_blogs
    * wp_users
    * wp_usermeta
    * wp_site
    * wp_sitemeta
    * wp_sitecategories

    If you suspect a problem please report it to support forums!

  11. andrewbillits
    Member
    Posted 17 years ago #

    party,

    whatever the solution to my problem is will fix your problem: http://mu.wordpress.org/forums/topic/226

    you have to manually pass through folders and i can't figure out how to do it.

  12. Shelley
    Inactive
    Posted 17 years ago #

    I had previously asked my host to set up "a dns wildcard alias and an apache wildcard virtual host" which they apparently did correctly because I was then successful with installing and setting up new blogs with the 19-8 nightly. (It is a cPanel site though and I had to change permissions on .htaccess - thanks for the great instructions via the forums!)

    I've now installed the most recent nightly on the same site and all went well. However, the front page of the admin site says I'm not using virtual hosts so I can't post to the primary blog. I added a new blog called test and the email gave me an address of domainname.org/test and I am also able to access the blog at test.domainname.org.

    I can live with things just as they are and be perfectly happy. But I was surprised to get the message after my success with the 19-8 nightly. Maybe there is just something I don't understand, being such a novice.

    Thanks for all your work, donncha!

  13. partypageusa
    Member
    Posted 17 years ago #

    Got the folder problems fix but still have the problem with the archive and categories link. Still get the following error.

    Fatal Error
    Could Not Find Blog!
    Searched for domain.com/ in host_wordpress::wp_blogs table. Is that right?
    Please check that your database contains the following tables:

    * wp_blogs
    * wp_users
    * wp_usermeta
    * wp_site
    * wp_sitemeta
    * wp_sitecategories

    If you suspect a problem please report it to support forums!

  14. Shelley
    Inactive
    Posted 17 years ago #

    I'm still getting broken image links using the code produced when I upload the file. Is this resolved and I've missed the solution?

  15. partypageusa
    Member
    Posted 17 years ago #

    Ok got my problem fix. Did a fresh install.

  16. Totto
    Inactive
    Posted 17 years ago #

    I got a fresh instalation of the 2005-09-07 version and all started well, had some posts in the base blog after that, but when I tried to logout get the well known error message:
    Fatal Error
    Could Not Find Blog!
    Searched for domain.com/ in wpmu::wpmu_blogs table. Is that right?
    Please check that your database contains the following tables:

    * wpmu_blogs
    * wpmu_users
    * wpmu_usermeta
    * wpmu_site
    * wpmu_sitemeta
    * wpmu_sitecategories

    If you suspect a problem please report it to support forums!

    That well known error. The instalation is on Linux, Apache 1.3.2.2 and PHP 4.3.4. All the tables are there and seem filled right, with the correct data in them. It happens trying to load /wp-login.php?action=logout script. And I'm not using the VHost option.

  17. Korora
    Member
    Posted 17 years ago #

    Hi
    I'm very sorry to I've not written response so long time on this thread, donncha:(
    About seg fault I haven't test again so I don't know how it is now, but I hope that my email helped you. Anyway, thank you very much. I tried to cleaninstall in another server and the installation successed with no error.

    I upgraded WPMU in the latest version yesterday. It works fine but still buggy in several things, so I report it.

    1. Cannot sign out as site admin. I get following error:
    Fatal Error
    Could Not Find Blog!
    Searched for my.domain.jp/ in wordpress::wp_blogs table. Is that right?
    Please check that your database contains the following tables:
    wp_blogs
    wp_users
    wp_usermeta
    wp_site
    wp_sitemeta
    wp_sitecategories
    If you suspect a problem please report it to support forums!

    I tried to reload page but it doesn't help.

    2. File upload url works fine after posting(image url is then "http://my.domain.jp/blogname/files"), but when I edit the entry which contains IMG tags with the file upload url and post it again, this file upload url doesn't work any more in top page and even in permalink (image url is now "http://my.domain.jp/files"). And smiles dies also in permalink(on top page: http://my.domain.jp/wp-includes/js/tinymce/plugins/emotions/images/smiley-money-mouth.gif permalink: http://my.domain.jp/blogname/2005/09/09/wp-includes/js/tinymce/plugins/emotions/images/smiley-money-mouth.gif). My server has already subdomain and I installed as non-vhost. I think it is WYSIWYG editor's fault which converts global-path to relative path...

    3. "next page" button in edit.php doesn't work: Jumps to blog-toppage.

    Any ideas?
    Sincerely.

  18. Korora
    Member
    Posted 17 years ago #

    Hi again.
    I fixed problem no.2.
    Changed /wp-inst/wp-admin/admin-header.php line 100,101 from:
    plugins : "emotions,wordpress"
    <?php do_action(mce_options); ?>

    to:
    plugins : "emotions,wordpress",
    relative_urls : false
    <?php do_action(mce_options); ?>
    Now this editor works fine:)

  19. TomK32
    Member
    Posted 17 years ago #

    @Korora: see the other posts about db issues, someone got his installtion working yesterday just like you

  20. Korora
    Member
    Posted 17 years ago #

    Thanks for your suggestion.
    I searched some topics on DB, and I found some topics which seemed to be near, but I couldn't find any solution:(
    About problem 3, Now I suspect that there is something wrong with get_pagenum_link in /wp-inst/wp-includes/template-functions-links.php line 352. On my edit page the link of "previous post" refers http://domain.jp/blogname/wp-inst/wp-admin/edit.php?paged=2 . But it should be http://domain.jp/blogname/wp-admin/edit.php?paged=2 I think. I'll try to edit template-functions-links.php to show URI collectly, but maybe I have to study rewriterules hard...

About this Topic