The MU forums have moved to WordPress.org

subdir and 404 after install on permalinks (8 posts)

  1. TNLNYC
    Member
    Posted 11 years ago #

    So I installed MU into a subdir called wpmu on our site. Because other content is running in root, we can have the WPMU site run under root.

    Blogs would be sitting under /wpmu/blogname

    The root blog would be /wpmu

    So I have the root blog working but permalinks are failing (click on them and they don't go anywhere)

    Pages are also failing and other blogs are too. This seems to point to an issue with .htaccess

    I've read through all the problems in the forum here but none of the solutions seem to work...

    Here are my .htaccess files:

    ---- .htaccess in my root dir ----
    RewriteEngine On
    RewriteBase /

    # Rewrite http://www.domain.com to domain.com
    #RewriteCond %{HTTP_HOST} ^www.(.*)
    #RewriteRule ^(.*) http://%1/$1 [R,L]

    # force a trailing slash for dirs
    #RewriteRule !..{2,4}$ - [C]
    #RewriteCond %{REQUEST_URI} !^.*/$
    #RewriteRule ^(.+)$ /$1/ [R=301,L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]*)/?files/(.*) /wpmu/wp-content/blogs.php?file=$2 [L]

    --- .htaccess in my wpmu dir ----
    RewriteEngine On
    RewriteBase /

    # Rewrite http://www.domain.com to domain.com
    # RewriteCond %{HTTP_HOST} ^www\.(.*)
    # RewriteRule ^(.*) http://%1/$1 [R,L]

    #uploaded files
    RewriteRule ^(.*)?/?files/(.*) wp-content/blogs.php?file=$2 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    Any ideas?

  2. drmike
    Member
    Posted 11 years ago #

    Looking in your error logs would be the first step. (Honestly should be doing that before posting by the way.)

    Open up the database (ie wp_blogs) and make sure that blog #1 is set to your domain name and the '/wpmu/' extention.

  3. TNLNYC
    Member
    Posted 11 years ago #

    Fixed. It was a dumb config issue relating to htaccess

  4. zimen
    Member
    Posted 11 years ago #

    hello can you tell me the fix pls?

  5. TNLNYC
    Member
    Posted 11 years ago #

    The fix was that I had not turned on .htaccess on in my httpd.conf

    Once I did that, it all worked...

  6. mikeh30276
    Member
    Posted 11 years ago #

    How would one "turn on" .htaccess in the httpd.conf file?

  7. edgarg
    Member
    Posted 11 years ago #

    when you fix something you should post how did you do it in that way
    many people can benefit of your work....
    it´s the open source spirit, take and give...

  8. andrea_r
    Moderator
    Posted 11 years ago #

    Or we could say it's the spirit of Google, since the "fix" isn't techinically an MU issue. It's basic Apache server stuff.

    Search and ye shall find.

    http://httpd.apache.org/docs/1.3/howto/htaccess.html

    (less than 2 minutes)

About this Topic