The MU forums have moved to WordPress.org

Serious Posting Problem in MU 1.0 (7 posts)

  1. suleiman
    Member
    Posted 16 years ago #

    Just when I thought I was done troubleshooting MU for the weekend, I ran into a serious issue:

    Whenever I go to edit a page, upon saving it MU sends me to the wordpress url where the page should be located and throws up a 404 error. At first I thought my work had simply dissappeared, but then I realized it had saved what should have been a page as a post instead!

    If I create a new page and then paste the contents back in then delete the old post then I'm good to go, but I tried this on a test blog and the problem was pronounced there too.

    Are there any ideas as to why this might be happenning? The only other major change to my install other than the 1.0 upgrade, was to integrate BBPress (finally!) into my site (sharing users and cookies), but I didn't think that would be a problem.

    EDIT: Culprit FOUND!

    The issue is the MU Admin Bar Plugin. While editing posts using the "Edit" button is fine, using the same "Edit" link to edit a page will result in the saved page turning into a saved post and the original page being deleted.

    I think we need to find a way to either disable the Edit button on Pages or provide the correct url when Blog Authors are on their pages.

  2. kahless
    Member
    Posted 16 years ago #

    How is MU Admin Bar the culprit? I think Dr. Mike found the fix for the edit link while on pages in the Admin Bar. Are you saying clicking the edit link in the Admin Bar while on a page deletes the page and makes it a post? If so that is what Dr. Mike fixed around version 1.2. The bar makes no change to the edit links on the page itself, it just adds a link to edit in the bar.

  3. theworkisdone
    Member
    Posted 16 years ago #

    Suleiman, I can reproduce this behavior.

    Being on a page the MU-AdminBar Edit-Link is /wp-admin/post.php?action=edit&post=2 though it should be /wp-admin/page.php?action=edit&post=2

    Im using latest release both of MU-Admin-Bar (1.4.1) and WPMU (r803)

  4. drmike
    Member
    Posted 16 years ago #

    Actually it points the Pages to the Posts when you try to edit it. One of our bloggers pointed it out to me in our support forums.

    Lets's see if this works:

    # Special case for edit
    if (is_single() || is_page()) {
    if( $post->post_type == 'page' ) {
    $file = 'page';
    } else {
    $file = 'post';
    }
    $edit_array = array('<strong>'.__('Edit').'</strong>', array('edit_post', $posts[0]->ID), $file . '.php?action=edit&amp;post='.$posts[0]->ID, 'edit-link');

  5. kahless
    Member
    Posted 16 years ago #

    I've added the change suggested by dr. mike on my test server but it doesn't seem to fix it. When I hover over the Edit link on the About page it still says post.php.

  6. mypatricks
    Member
    Posted 16 years ago #

    what's theme that you are using? Change to default theme and try it. :)

  7. suleiman
    Member
    Posted 16 years ago #

    mypatricks, I haven't tried using it on the default theme, but that's not a very useful fix nonetheless, since our users obviously have many different blog themes they are using.

    offtopic!
    As a side note, could you clue the community in on how you got Tags working on your site? That's really the last remaining feature I want to implement.

About this Topic

  • Started 16 years ago by suleiman
  • Latest reply from suleiman