The MU forums have moved to WordPress.org

http://example.com/wpmu/ turning to http://com/wpmu/examlple/ (36 posts)

  1. sasidhar
    Member
    Posted 15 years ago #

    Please help.

    http://www.example.com/wpmu/user/ turning to http://com/wpmu/examlple/ on the admin dashboard page. Also, there seems to be no css enabled.

    Is this a mod_rewrite bug? what should I do?

  2. apolkov
    Member
    Posted 15 years ago #

    I'm having the same problem installing right now. I'm hosting at http://www.lrc.macewan.ca which gets shortened to lrc.macewan.ca. I've looked at the database contents and some entries are stored as macewan.ca.

  3. drmike
    Member
    Posted 15 years ago #

    Don't use the 'www' bit when you install.
    You may also want to reread the instruction as if you're installing it to /wpmu/, you may have missed a step. (ie WPMU should be installed to root, not a subdirectory, unless you want to run it from that subdirectory)

  4. gregy
    Member
    Posted 15 years ago #

    but when installing i left field domain.com ... i didn't enter www ...

    tried 5 times to fresh install .. still no css no colors no design .. :(

  5. andrea_r
    Moderator
    Posted 15 years ago #

    There's a lot of threads about this exact same isues, and pretty much every single one involves installing MU in a subdirectory of the main domain.

    Can we flag this as a bug now?

  6. bbruggers
    Member
    Posted 15 years ago #

    same problem here

  7. drmike
    Member
    Posted 15 years ago #

    Someone who can give details please submit this as a bug over at trac.

  8. bbruggers
    Member
    Posted 15 years ago #

    where can i submit this bug?

    you say at trac but what is trac?

    more info
    these links work:
    http://baby-log.net/
    http://baby-log.net/wp-signup.php

    does not work
    http://baby-log.net/wp-login.php
    when you login you get at microsoft.com????

    hello world link does not work
    http://net/baby-log/blog/2006/11/11/hello-world/

    rss feeds does not work
    feed:http://net/baby-log/feed/
    feed:http://net/baby-log/comments/feed/

  9. andrea_r
    Moderator
    Posted 15 years ago #

    I will if I can narrow down in what instances it does this. Installing in a directory is one of them. I tried it myself.

    bbruggers; is the baby-log.net domain the only domain you have with your hosting account?

  10. wordpresshostorg
    Member
    Posted 15 years ago #

  11. CoreyCampbell
    Member
    Posted 15 years ago #

    I've had the same problem? Any fixes?

  12. drmike
    Member
    Posted 15 years ago #

    I'm feel like being a smart ass about this but I'll just point you to the post directly above yours for the solution.

    Bloody hell...

  13. lunabyte
    Member
    Posted 15 years ago #

    :-|
    (Luke declines comment. Must wipe up coffee that shot out of nose.)

  14. CoreyCampbell
    Member
    Posted 15 years ago #

    LOL! I meant like a plugin option or something? Is the bug ever going to be actually fixed within the installation file. I already did what that post said to do but there are still several broken links within my blog that point to that stupid http://com thing.

    I've finally got everything to where I can see it. Is there something that is messing it up within the database files?

  15. CoreyCampbell
    Member
    Posted 15 years ago #

    Okay. Like I go in a fix it but all the other blogs are not fixed. That means I have to change it everytime someone makes one... not fun...

  16. drmike
    Member
    Posted 15 years ago #

    It should be as it takes the info right out of the wp_site table.

  17. CoreyCampbell
    Member
    Posted 15 years ago #

    I don't know... I do that exact thing and I still have http://com all over my site. My admin blog works fine... I can't figure it out.

  18. redbox
    Member
    Posted 15 years ago #

    Same here! I followed the 'fix' but I still have the http://com everywhere as well.

  19. gonetitsup
    Member
    Posted 15 years ago #

    You need to add your wildcard to your DNS settings, read the 'read me' for details - you might have to ask your web host to do this. This needs to be done even if you are using subdirectories!

  20. drmike
    Member
    Posted 15 years ago #

    You may also want to double check the datatables aagin because you may have missed one or two somewhere. The URL is pulled from the datatables.

    I'd double check the .htaccess file as well and make sure the domain is in there as correct as well.

  21. CoreyCampbell
    Member
    Posted 15 years ago #

    Uhm k... I'll try to do this. I really wish there was some easier way. Could you perhaps list exactly what needs to happen directly from install to finish?

  22. CoreyCampbell
    Member
    Posted 15 years ago #

    I'm like 100% that this is my problem. I've tried installing this so many times. I still get links that are http://com/mkcproductions/ everywhere on my site instead of http://mkcproductiosn.com/

    I'm installing this as sub directories but am still having issues. I don't quite understand all the rewrite rules, and I have no idea how to go about editing a database through PHPMyAdmin.

    I have been trying to get this up for about a month. Could anyone be kind enough to work with me, perhaps step by step, with what needs to go on.

    My admin blog works, but when ppl register I can get them registered but it never gives them a blog.

  23. simplestation
    Member
    Posted 15 years ago #

    This didn't work for me, I had to edit the wp_1_options database table, and then corrected the siteurl field to match my url

  24. drmike
    Member
    Posted 15 years ago #

    Workaround is here:

    http://mu.wordpress.org/forums/topic.php?id=2508

    Donncha is aware of the issue and we're awaiting a fix currently.

  25. donncha
    Key Master
    Posted 15 years ago #

    I figured out one way of triggering it: install from http://www.mydomain.com instead of mydomain.com - somewhere the code gets confused and mangles the siteurl and home values.
    I added code yesterday to issue a warning but that's only a temporary fix while I debug it.

  26. lunabyte
    Member
    Posted 15 years ago #

    Interesting Donncha.

    So even when you put domain.tld in the proper box of the form, which it should be there already, it still gets confused?

    I tried putting www. in front of it, and it was stripped out and installed fine. So where is it reading the server var to check?

  27. donncha
    Key Master
    Posted 15 years ago #

    No, I went to http://www.mydomain.com in my browser and installed it through that URL, instead of mydomain.com

    The string "www." gets stripped from the domain basename in the text box so it doesn't matter if it's there or not :)

  28. lunabyte
    Member
    Posted 15 years ago #

    Exactly.
    So it's picking it up from the url somewhere. maybe as a precautionary measure when installing or something, and it isn't being stripped out.

    Looking at 372, that's where the inserts start. 365 is where the domain is checked.

    It's doing the post value, so there shouldn't be a www in there since it's stripped out. So maybe checking $domain right before it's ready to be inserted, and look for com/ or net/, or whichever would help.

    Either that, or just have it "silently" redirect to the non-www domain. Although that doesn't necessarily explain "why".

    It shouldn't be doing it at all, unless somewhere the POST var is getting mucked up.

  29. donncha
    Key Master
    Posted 15 years ago #

    Hopefully this should be fixed now!

  30. lunabyte
    Member
    Posted 15 years ago #

    What exactly was the issue, Donncha? I'm curious to know what would hose it up?

About this Topic

  • Started 15 years ago by sasidhar
  • Latest reply from lunabyte