The MU forums have moved to WordPress.org

SiteWide Feed Parsing Error (12 posts)

  1. suleiman
    Member
    Posted 15 years ago #

    When I go to add my feed to feedburner it says to me:

    The URL you entered does not appear to be a valid feed. We encountered the following problem: Error on line 96: The element type "description" must be terminated by the matching end-tag "</description>".

    Indeed, when I try and use Camino's built-in RSS to read my feed it gives me this error:

    XML Parsing Error: mismatched tag. Expected: </description>.
    Location: http://hadithuna.com/sitefeed/
    Line Number 96, Column 3:</script>
    --^

    I have no idea what I'm doing wrong. I've downloaded and re-downloaded the wpmufeed.php file numerous times. I've even tried default settings. No dice.

    Does anyone know where this information is stored? I want to try going into my wpmu database and dropping the RSS, or finding that pesky xml file if it's located there.

    Any help, and I shall be much obliged.

  2. suleiman
    Member
    Posted 15 years ago #

    I've narrowed this down to instances where SiteFeed is set to display 5 or more posts. If i set it to lower than that then FeedBurner and Camino both parse the XML file it generates correctly. At the 5th post however, I run into an error.

    I tried checking the blog that had the 5th most recently updated post, but deactivating it and making sure no plugins were activated had no effect. SiteFeed still crashes on the 5th post.

    Does anyone have any idea why this would be happenning?

  3. suleiman
    Member
    Posted 15 years ago #

    Well I found the culpri, Anarchy Media Plugin. I don't believe it, but de-activating this plugin lets my site render a valid RSS feed once more.

    I tried checking for any whitespaces after the ?> in the plugin but all to no avail.

    If anyone is using this plugin and it works without conflicting in their RSS feeds, I'd appreciate your posting your working php file of the plugin.

    Thanks!

  4. DrkWrz
    Member
    Posted 15 years ago #

    I also tried the Stiewide Feed. And I hade the same conflict with the anarchy media plugin.
    The point is that the XML pharser thinks that the description is over when it reaches the ending of the code generated by anarchy media.

  5. suleiman
    Member
    Posted 15 years ago #

    hmm...I see that on the homepage for the anarchy media plugin one of the users has reported this issue just recently. Let's hope it gets resolved soon!

  6. corourke
    Member
    Posted 15 years ago #

    I'm not using that plugin and also haven't updated any core files since I grabbed version 1 in midnovember. I started having the parsing issue as well.

  7. zeug
    Member
    Posted 15 years ago #

    The Anarchy problem got sorted back when it started in Oct, the problem then was the insertion of cdata tags within a cdata rss description. You can't have a cdata tag within a cdata tag ... what errors is your sitewide feed via feedburner throwing?

  8. suleiman
    Member
    Posted 15 years ago #

    you can check out the specific error by going over to feedvalidator.com.

  9. corourke
    Member
    Posted 15 years ago #

    Nevermind it resolved. Turns out a user had imported his blog and the import was badly malformed. I suppose that's something to watch for now then.

  10. suleiman
    Member
    Posted 15 years ago #

    do you know from which service? Blogger? Typepad?

    I've been hearing about issues with Movable Type and Live Journal lately

  11. andrea_r
    Moderator
    Posted 15 years ago #

    LJ has been horking big time lately.

  12. corourke
    Member
    Posted 15 years ago #

    Just heard back from the user, was wordpress 2.0.1. Was adding in nonstandard ascii whereever there was a double space.

About this Topic

  • Started 15 years ago by suleiman
  • Latest reply from corourke