The MU forums have moved to

Same old .. No WPMU site defined on this host (5 posts)

  1. dcs0pk
    Posted 17 years ago #

    Ok please help me. I have read some posts with the same problem as well as debugging info. Still haven't resolved it.

    "No WPMU site defined on this host. If you are the owner of this site, please check Debugging WPMU for further assistance "

    I am trying to install on Apache 2, linux, local server.

    1. I untar into htdocs/blog dir, set permissions for
    2. I run install.php and add database details, chose sub-dir insted of vhost, because I just want to install on
    3. I submit and went to Creating Database config done.. then that error..

    Do I need to set vhost in apache? What do I need to change for sub-dir insted of vhost?

    What do I need to change in .htaccess? RewriteBase is changed to /blog/ . Do I need to change anything else? My rewrite is enabled.

    Here is my wp-config

    // ** MySQL settings ** //
    define('DB_NAME', 'xxxx'); // The name of the database
    define('DB_USER', 'xxxx'); // Your MySQL username
    define('DB_PASSWORD', 'xxxx'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this v
    alueiteRule ^(.*)?/?files/(.*) wp-content/blogs.php?file=$2 [L]
    define('VHOST', 'no');
    $base = '/blog/';

    // double check $base
    if( $base == 'BASE' )
    die( 'Problem in wp-config.php - $base is set to BASE when it should be
    the path like "/" or "/blogs/"! Please fix it!' );

    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = 'wp_'; // example: 'wp_' or 'b2' or 'mylogin_'

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    define( "WP_USE_MULTIPLE_DB", false );

    /* Stop editing */

    define('ABSPATH', dirname(__FILE__).'/');

  2. drmike
    Posted 17 years ago #

    You're using both 'blogs' and 'blog' as the subdirectory in your description. Which is it just to be sure?

    Please install to (or blog) Please skip the 'www' bit.

    vhost doesn't need to be set but the other stuff within Apache does that the readme file mentions.

    Open up the database and make sure the tables exist. Also check to see what site is defined in the wp_site table.

    Hope this helps,

  3. dcs0pk
    Posted 17 years ago #

    Thank you for your reply.

    It was blog, it was a typo. My server is already on a subdomain so I dont have www bit.

    My localhost is called, so I just use that.

    for Apache config, according to readme,

    i have to setup directory directive for my vhost. It mensioned about vhost only. I dont have vhost so I added

    alias /blog/ "/srv/www/htdocs/blog/"
    <Directory "/srv/www/htdocs/blog/">
    Options FollowSymL....
    AllowOver.... Options FileInfo...

    Is that right?

    read me doesnt mension about database setup. I thought the install script creates the table from config. At the moment there is no table. Do I need to pipe SQL scripts from somewhere?

    read me doesnt mension about creating .htaccess.
    the dist comes with htaccess.dist, do i need to rename it ot .htaccess? or the install script does it for me? at the moment there was nothing. So I renamed it and changed the rewritebase bit. Is that right?

    Thanks again

  4. dcs0pk
    Posted 17 years ago #

    Sorry for the double post. Currently it stops at

    Creating Database Config File: DONE

    In the source


    <h1><img src="wp-includes/images/wordpress-mu.png" alt="WordPress MU" /></h1>
    Creating Database Config File: <b style='color: #00aa00; font-weight: bold'>DONE</b>

    Then stop. When refresh

    "No WPMU site defined on this host. If you are the owner of this site, please check Debugging WPMU for further assistance "

    Seems like it never go to step 3.

    Something wrong with the latest install script in the lastest dist?

  5. lsabug
    Posted 17 years ago #

    Just figured out why I was having this problem - the solution to get beyond the "No WPMU..." message is to make your directory that holds the WordPress files 777 (on windows give the apache/IIS user full control-temporarily). Once you do that you'll be able to go to the next step.


About this Topic