The MU forums have moved to WordPress.org

New User Activation fails (22 posts)

  1. mysticwolfpress
    Member
    Posted 17 years ago #

    OK, I've been experimenting and searching through this all week.

    My site is at http://mysticwolfpress.com/wpmu/ and I'm setting it up on subdomains

    My host confirms that the apache stuff is all good and working properly.

    Upon signup I get the new user activation email link;
    <http://test2.mysticwolfpress.com/wpmu/wp-activate.php\?key=ce22bd04c079e099>

    This results in this error message;

    "Server not found

    Firefox can't find the server at test2.mysticwolfpress.com.

    * Check the address for typing errors such as
    ww.example.com instead of
    http://www.example.com

    * If you are unable to load any pages, check your computer's network
    connection.

    * If your computer or network is protected by a firewall or proxy, make sure
    that Firefox is permitted to access the Web."

    I also can't ADD a new blog through the Site Admin Dashboard. I get this message then;

    "

    WordPress database error: [Table 'mysticwo_wpmu.wp_3_options' doesn't exist]
    SELECT option_value FROM wp_3_options WHERE option_name = 'blogname' LIMIT 1

    WordPress database error: [Table 'mysticwo_wpmu.wp_3_options' doesn't exist]
    SELECT option_value FROM wp_3_options WHERE option_name = 'siteurl' LIMIT 1

    WordPress database error: [Table 'mysticwo_wpmu.wp_3_options' doesn't exist]
    SELECT option_value FROM wp_3_options WHERE option_name = 'post_count' LIMIT 1

    Warning: Cannot modify header information - headers already sent by (output started at /home/mysticwo/public_html/wpmu/wp-includes/wp-db.php:111) in /home/mysticwo/public_html/wpmu/wp-includes/pluggable.php on line 281"

    I'd really appreciate some help with this. I've been going around and round with WPMU all week.

    Thanks,
    Robert:)

  2. andrea_r
    Moderator
    Posted 17 years ago #

    The db errors on adding a user manually is a current bug. It should still have added them.

    If it can't find those subdomains, then it's not set up right in Apache. To reiterate; in the http.conf file, it should allow for wildcard subdomains for your domain.

    Also, I have had issues with installing MU in a subdirectory and then using subdomains.

    Why not run it off the root, and import the blog you have there into the main MU blog?

  3. mysticwolfpress
    Member
    Posted 17 years ago #

    I have it set up in /home/public_html/wpmu/

    They told me that this IS the root and that anything put on the next level up, ie.
    home/wpmu/ won't work

    I tried that this morning and couldn't get it to work either. I couldn't even get it to install.

    We set up the DNS and wildcard stuff on wednesday. It's set to on.mysticwolfpress.com

    I can go to robert.on.mysticwolfpress.com and see my homepage, so the tech said that meant it was set up properly. I never heard of wildcards until tuesday, so I have to take everyones word for it. :)

    Thanks for your help,
    Robert:)

  4. mysticwolfpress
    Member
    Posted 17 years ago #

    "Why not run it off the root, and import the blog you have there into the main MU blog?"

    I'd be happy to, but I can't figure out a file path that will let it install. If I put it in the /home/wpmu/ configuration then it won't install and just gives me a 404 when I type in mysticwolfpress.com/index.php (as per the Readme).

    How should I set that up? I'm reloading it into the root right now.

    Thanks,
    Robert:)

  5. andrea_r
    Moderator
    Posted 17 years ago #

    /home/public_html/

    *This* is the root, not /home/wpmu/. :) HTH.

  6. mysticwolfpress
    Member
    Posted 17 years ago #

    I'm having the same problem with both iPower and HostGator. They swear by all that's holy that they have the DNS and wildcards set up properly, and I have it installed in the public_html directory, yet my new user activation emails have a link that ALWAYS takes me to a "Server not found" error.

    I just spent another hour and a half on the phone with HostGator and they think they know how to fix it and that they should have it working in an hour or so. I guess we'll see.

    Robert

  7. mysticwolfpress
    Member
    Posted 17 years ago #

    HostGator tells me the problem lies with their security programs and the Permissions, and that they should be able to sort it out. They also wanted me to give them another $25 to install it. I might have done that this morning (or maybe on Tuesday morning when I started all of this) but now they either get it to work or I'll cancel that account and quit wasting my time with this.

    Robert

  8. webfusion
    Member
    Posted 17 years ago #

    add this code to your .htaccess file and you should be fine.

    --------------
    RewriteEngine On
    RewriteBase /blogs/

    # Rewrite http://www.domain.com to domain.com
    RewriteCond %{HTTP_HOST} ^www\.(.*)
    RewriteRule ^(.*) http://%1/$1 [R,L]

    #uploaded files
    RewriteRule ^(.*)?/?files/(.*) wp-content/blogs.php?file=$2 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    Cheers

    Chad

  9. mysticwolfpress
    Member
    Posted 17 years ago #

    It took quite a bit more than that.

    I've emailed the adminstrator that was finally able to get it working. He had to make changes to the DNS and Wildcard, other than what is posted in the Readme directions, as well as quite a list of other stuff.

    The files were uploaded to the public_html directory, but there had to be some changes made to get it to install since public_html permissions can't be set to 777.

    Once he got all of that worked out then it installed and, with the exception of being able to create a new user from the Admin Panel, it's working great.

    I can tell you for a fact that NONE of the solutions that are currently offered on the forums made it work. I spent the better part of 60-70 HOURS last week, including about 20-30 of that on the phone with tech support for a couple of different hosts, and NONE of what was finally done was covered.

    I've emailed the guy who was able to get it to work and asked him to please send me directions that can be posted here.

    I'm very happy to have this working as it's cost me several hundred dollars in time and new web hosting to get to this point. Now that it's working I think it will be very good.

    Robert :)

  10. andrea_r
    Moderator
    Posted 17 years ago #

    Um, that's really weird. I would hazard a guess that you ran into people who just did not quite know what they were doing as well, when they should. Hey, it happens.

    As for the public_html permissions, mine are not set 770 and it installed, so I dunno what was up with that.

  11. mysticwolfpress
    Member
    Posted 17 years ago #

    Well, I have to take it all back about HostGator. There is 1 (one) and apparently only 1, guy there that can get it done. I tried to upgrade my account and move my primary website over and they ended up crashing everything. I cancelled that account and I'm checking out https://www.psek.com right now.

    They told me that they can get it all rolling in 10-15 minutes, so we'll see.

    We REALLY need an open 'Hosting' thread where people can post about this. It would have saved me many, many hours of experimenting and phone support.

    "As for the public_html permissions, mine are not set 770 and it installed, so I dunno what was up with that."

    They weren't set at 777 at HostGator either, and it installed. However, iPower couldn't get it to work and some really nice people tried very hard.

    Robert:)

  12. drmike
    Member
    Posted 17 years ago #

    Hosting thread :)

    I've got to admit. After 10 hours, I would have ran for the border. :)

    You can actually set it to 700 and get it to run. You're going to have to set the files and directories to the Apache owner though and you won't be able to do anything with the files except while signed in as root. (Not user but the box root) I can think of some security issues though of running anything owner as 'nobody' or whatever Apache runs under now a days.

  13. andrea_r
    Moderator
    Posted 17 years ago #

    Come north, Mike. :)

    Also, a good network guy is worth his weight in 401k's. uh, yeha if they are a *hosting company* and only have one guy in the whole place who can set this up, then run for the hills.

  14. Ionut
    Member
    Posted 17 years ago #

    I have the same problem, can you give details...

  15. mysticwolfpress
    Member
    Posted 17 years ago #

    OK I'm back with the original problem.

    I did a new install in the root, which was successful.

    I'm setting up subdirectories, ie. example.mysticwolfpress.com.

    When I try to set up a new blog it gives me the "Server not found" error;
    "Firefox can't find the server at anya.mysticwolfpress.com."

    It gives me the same error when I try to set up a blog manually.

    The web hosting techs repeatedly assure me that the Wildcard is setup correctly. It's set to 'on.mysticwolfpress.com'

    I also tried webfusion's .htaccess fix listed above and it doesn't work either.

    Any ideas?

    Robert:)

  16. mysticwolfpress
    Member
    Posted 17 years ago #

    I also tested it using foobar.on.mysticwolfpress.com and that also worked, ala http://mu.wordpress.org/forums/topic.php?id=1530&replies=6

    Robert:)

  17. mentaltank
    Member
    Posted 17 years ago #

    Sorry to beat a dead horse, but i'm trying to setup wpmu at http://www.mentaltank.com/wpmu and i can not successfully activate any key generated through the Registration link, though i have a similar wpmu install at http://www.blognett.com and we know that apache is set properly already - confirmed.

    it works fine for blognett.com but not mentaltank.com/wpmu, which is not in the root, where it can not be, as i need to publish a site around the wpmu system.(ahh- and both are set to 'create subdomain/instead of directory)
    i modified the header.php to add the registration link, it sends the email fine, gives out a key, but gives a page error upon key activation. any help ?

    thank you ahead of time.
    mentaltank

  18. drmike
    Member
    Posted 17 years ago #

    Please provide details of your setup for mt.com/wpmu. Like are we doing VHosts, what is the resulting domain, what does a registration link look like, etc.

  19. INOXFIRE
    Member
    Posted 17 years ago #

  20. drmike
    Member
    Posted 17 years ago #

    INOXFIRE, it appears that you're trying to run subdomains while having the software installed into a subdirectory. File directories don't work like that. It's either/or.

    Best bet would be to install the software into a subdomain for your blogs like blogs.sportska-prognoza.com and install it so to create subdirectory installs for your user.

    Just for reference, please note the post right above yours and how I suggest providing details. May want to think about it.

  21. imgoel
    Member
    Posted 17 years ago #

    Hi, I have a problem.
    I did a new install in the root, which was successful.
    I tried setting up a 'new blog', ie. example.goelji.com

    It works fine when I try to set up a new blog.
    An email activation code is received at email.
    On clicking the activation code in my email, it gives me the "Server not found" error:
    *Firefox can't find the server at example.goelji.com.
    *If you are unable to load any pages, check your computer's network connection.

    When I try to set up a blog manually, it gives

    WordPress database error: [Table 'imgoel_blogs.wp_3_options' doesn't exist]
    SELECT option_value FROM wp_3_options WHERE option_name = 'wp_3_user_roles' LIMIT 1

    WordPress database error: [Table 'imgoel_blogs.wp_3_options' doesn't exist]
    SELECT option_value FROM wp_3_options WHERE option_name = 'blogname' LIMIT 1

    WordPress database error: [Table 'imgoel_blogs.wp_3_options' doesn't exist]
    SELECT option_value FROM wp_3_options WHERE option_name = 'siteurl' LIMIT 1

    WordPress database error: [Table 'imgoel_blogs.wp_3_options' doesn't exist]
    SELECT option_value FROM wp_3_options WHERE option_name = 'post_count' LIMIT 1

    Warning: Cannot modify header information - headers already sent by (output started at /home/imgoel/public_html/wp-includes/wp-db.php:135) in /home/imgoel/public_html/wp-includes/pluggable.php on line 334

    The web hosting techs repeatedly assure me that the Wildcard is setup correctly. It's set to 'example.goelji.com'

    Any ideas?

  22. ZeeYPeeWee
    Member
    Posted 17 years ago #

    same as for imgoel here for http://www.surfandsmile.com

About this Topic

  • Started 17 years ago by mysticwolfpress
  • Latest reply from ZeeYPeeWee