The MU forums have moved to

MaxRedirects question (5 posts)

  1. mikeh30276
    Posted 17 years ago #

    I am slowly working out the kinks of my Wordpress MU install and I am having a problem resolving an activation error. When a user registers for a blog and clicks on the activation link in his email, he receives an error that reads:

    "Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log"

    My error log contains the following info:

    "[Tue Nov 07 10:28:13 2006] [error] [client] mod_rewrite: maximum number of internal redirects reached. Assuming configuration error. Use 'RewriteOptions MaxRedirects' to increase the limit if neccessary."

    Can someone shed some light on what this means?


  2. andrea_r
    Posted 17 years ago #

    Are you using subdomains and are they set up properly?

  3. mikeh30276
    Posted 17 years ago #

    Yes, I am using sub-domains and I have no idea if they are set up properly. I chose to use the sub-domain option during set up but that's the only reference to sub-domains that I have seen. Am I missing something? Thanks.

  4. mikeh30276
    Posted 17 years ago #

    Correction to my earlier post: I'm trying to use Sub-Directories, not Sub-domains. I apologize for that error but any advice is appreciated.

  5. andrea_r
    Posted 17 years ago #


    You didn't read the readme did you? From the install instrcutions: "If you want to host blogs of the form http://blog.domain.tld/ where domain.tld is the domain name of your machine then you must add a wildcard record to your DNS records. This usually means adding a "*" hostname record pointing at your webserver in your DNS configuration tool."

    The subdomains are set up using *virtual* hosts. This is not on the server by default. It must be done by editing the httpd.conf file in Apache. If you're on a shared server or most kinds of paid hosting, you will have to ask your host to enable it for your domain.

    No, it doesn't say this on the install screen.

About this Topic

  • Started 17 years ago by mikeh30276
  • Latest reply from andrea_r