The MU forums have moved to WordPress.org

Desparate with Install Problem. (9 posts)

  1. rtnair
    Member
    Posted 16 years ago #

    Sorry that i post this as a new thread. Even though the issue is posted more than 10 times in this forum, nobody seems to have a solution for this. Now the issue is:

    I get this page after installing wpmu (wpmu-2005-09-06):

    (Have tried more than a dozen nightly builds.)

    Fatal Error
    Database Tables Missing.
    The table wordpress::wp_site is missing. Delete the .htaccess file and run the installer again!
    Please check that your database contains the following tables:

    * wp_blogs
    * wp_users
    * wp_usermeta
    * wp_site
    * wp_sitemeta
    * wp_sitecategories

    If you suspect a problem please report it to support forums.

    My host details:
    OS - Debian Sarge
    Apache - 1.3.33
    PHP - 4.3.10-16
    AllowOverride FileInfo set,
    mod_rewrite loaded.

    Somebody please answer me if you got it working.
    I am trying with all the nightly builds for the past fortnight!

  2. TomK32
    Member
    Posted 16 years ago #

    go to your mysql admin interface (most likely phpmyadmin) and insert a new enry into wp_site with your domain and path. same for wp_blogs.
    If no one else is working on that bug yet I'll track and hopefully fix it tonite.

  3. rtnair
    Member
    Posted 16 years ago #

    thanks for the help...

    i done that. now the error is:

    Fatal Error
    Could Not Find Blog!
    Searched for blog.mydomain.comBASE in wordpress::wp_blogs table. Is that right?
    Please check that your database contains the following tables:

    * wp_blogs
    * wp_users
    * wp_usermeta
    * wp_site
    * wp_sitemeta
    * wp_sitecategories

    My wp_site shows:
    mysql> select * from wp_site;
    +----+--------------------+-----------------------------+
    | id | domain | path |
    +----+--------------------+-----------------------------+
    | 1 | blog.mydomain.com | /var/www/blog.mydomain.com |
    +----+--------------------+-----------------------------+
    1 row in set (0.00 sec)

    and wp_blogs shows:
    mysql> select * from wp_blogs;
    +---------+---------+--------------------+-----------------------------+---------------------+---------------------+-----------+
    | blog_id | site_id | domain | path | registered | last_updated | is_public |
    +---------+---------+--------------------+-----------------------------+---------------------+---------------------+-----------+
    | 1 | 0 | blog.mydomain.com | /var/www/blog.mydomain.com | 0000-00-00 00:00:00 | 0000-00-00 00:00:00 | yes |
    +---------+---------+--------------------+-----------------------------+---------------------+---------------------+-----------+
    1 row in set (0.00 sec)

    Any error with the data i entered? please help.

    rtnair.

  4. TomK32
    Member
    Posted 16 years ago #

    the path must be / if you use VHOST or /path if you use subdirs. The error message ist quite misleading :-(
    it took myself an hour to find that out.

  5. rtnair
    Member
    Posted 16 years ago #

    sorry to say that none of the solutions proposed in the thread solves my problem. i tried the nighly build on this day(2005-09-16) too, and the result is shown below:

    Fatal Error
    Database Tables Missing.
    The table wordpress::wp_site is missing. Delete the .htaccess file and run the installer again!
    Please check that your database contains the following tables:

    * wp_blogs
    * wp_users
    * wp_usermeta
    * wp_site
    * wp_sitemeta
    * wp_sitecategories

    If you suspect a problem please report it to support forums!

    can anybody help me?

    raja.

  6. paradiso
    Inactive
    Posted 16 years ago #

  7. federico
    Member
    Posted 16 years ago #

    serveralias?
    dns catchall?

  8. kdesilva
    Member
    Posted 16 years ago #

    I'm getting the same error with no luck...

  9. federico
    Member
    Posted 16 years ago #

    I try help you. Download last version wpmu. Delete database and create it again. Delete installation wpmu. Upload new version files wpmu. And before start new install chmod for .htaccess file must be 777.
    If you do not sure have vHost, then you do not mark this option.

About this Topic