The MU forums have moved to WordPress.org

Chmod 777 /html/ - still error messages (14 posts)

  1. simonsimon
    Member
    Posted 15 years ago #

    When I try to install WPMU, I get the following message:

    "/home/www/XXX/html : FAILED
    Quick Fix: chmod 777 /home/www/XXX/html
    Warning!

    One or more of the above directories must be made writeable by the webserver."

    I changed the permissions of /html/ and every subdirectory to 777, so everything should be fine. But it isn't. :-) When refreshing the page, the same error messages appears. So what else can I try?

  2. stutley
    Member
    Posted 15 years ago #

    What is the html-folder? Did you install in your root folder or in a subdirectory?

  3. drmike
    Member
    Posted 15 years ago #

    try setting www and XXX at 777 as well. I think that's overkill but that may be what the server is looking for.

  4. simonsimon
    Member
    Posted 15 years ago #

    HTML is the root folder, I uploaded all the WPMU files (except the "wordpressmu-1.0" folder itself) in this directory.
    Because I don't have "higher access" I can not set chmod 777 to www and XXX. Why should I chmod these directories? WPMU asks for /html/ not for XXX or www. I wonder why WPMU *still* wants me to chmod. As I mentioned, all files are in /html/ and all folders & files inside this directory have chmd 777.

  5. Bruz
    Member
    Posted 15 years ago #

    simonsimon, I had the same problems - so I've created a subfolder /html/wpmu/ and redirected my domain to that subfolder which became my new root-dir that way.
    The chmod on this folder worked, now running Wordpress MU without Problems!

    WP MU needs the access to it's root-folder to create e.g. the wp-config.php file, maybe it's possible to do that by yourself, but I like mine solution better ;-)

  6. simonsimon
    Member
    Posted 15 years ago #

    Thank you, Bruz! I've created a subfolder and set the permission to 777. WPMU seems to work now. ;-)

  7. simonsimon
    Member
    Posted 15 years ago #

    OK, there's one more problem: I've installed WPMU in the subfolder /blogs/, but I don't want the created blogs to be like subdomain.domain.tld/blogs - I want them to be subdomain.domain.tld without the ending /blogs/. Is that possible?

  8. Bruz
    Member
    Posted 15 years ago #

    For sure - but you'll have to point your domain domain.tld (depends on your hoster how) to /blogs/ instead of / - than access domain.tld and install Wordpress with your desired option.

  9. carnold
    Member
    Posted 15 years ago #

    Hi all! New to muwp. I have a regular WP install in my web root. I have also installed MUWP in a /blogs folder. These systems/installs are self-hosted and i have full access to them. I want users blogs to be subdomain.domain.tld without the ending /blogs/. I have a dyndns.com account and i also have DNS inside our network. I have a dnydns record with a wildcard "*".domain.tld and all that works fine. I just don't want users to have the ending /blogs. Can someone explain how to do this?
    The post from Bruz says:
    you'll have to point your domain domain.tld (depends on your hoster how) to /blogs/ instead of / - than access domain.tld and install Wordpress with your desired option.
    Exactly how does someone do this?

  10. lunabyte
    Member
    Posted 15 years ago #

    You will have to install it in the root of the site, not a subdirectory.

  11. carnold
    Member
    Posted 15 years ago #

    Thanks for your reply lunabyte. Am i mis-reading the above posts? Simonsimon says he did the exact thing i did and wants his users to goto sub-domain.domain.tld instead of /blogs. Bruz then answers, sure you can do doing this:
    point your domain domain.tld (depends on your hoster how) to /blogs/ instead of / - than access domain.tld and install Wordpress with your desired option.

  12. hunor
    Member
    Posted 13 years ago #

    Ran into the same problem installing Wordpress MU 2.6.3.

    What I found out is that the script checking if the given directory is writeable is a little bit flawed - at least for my configuration.

    The root of all evil is that the PHP function is_writable($dir) returns false, if the hash is missing from the end of $dir!

    So what to do? I solved this by hacking the file index-install.php and changing the function checkdirs() as follows:


    function checkdirs() {
    global $dirs;
    $return = true;

    $errors = array();
    foreach( (array) $dirs as $dir ) {
    // HACK STARTS HERE
    if( $dir[strlen($dir)-1] != '/' ) {
    $dir .= '/';
    }
    // END OF HACK
    if( false == is_writeable( $dir ) ) {
    $errors[] = $dir;
    }
    }

    I hope this helps.

  13. hunor
    Member
    Posted 13 years ago #

    Sorry for the formatting above... The code tag obviously doesn't like empty lines... Here the code again, hopefully more legible:


    function checkdirs() {
    global $dirs;
    $return = true;
    //
    $errors = array();
    foreach( (array) $dirs as $dir ) {
    // HACK STARTS HERE
    if( $dir[strlen($dir)-1] != '/' ) {
    $dir .= '/';
    }
    // END OF HACK
    if( false == is_writeable( $dir ) ) {
    $errors[] = $dir;
    }
    }

  14. hunor
    Member
    Posted 13 years ago #

    Sorry guys, it's late... Meant 'slash', not 'hash'... :-)

About this Topic

  • Started 15 years ago by simonsimon
  • Latest reply from hunor