The MU forums have moved to WordPress.org

I can't seem to create the MU site or login (25 posts)

  1. PetLvr
    Member
    Posted 17 years ago #

    Hi .. Quite familiar with the wordpress single version installation .. not so with multi-version. Here's what I have done.

    I would like to set this up in http://PetLvr.com/mypet/

    I have installed the MU software into this directory.

    I have contacted my ISP and they have modified everything necessary with the Apache as per the readme.txt

    I then went to the http://PetLvr.com/mypet/ to run the index.html script and entered my database, username, password and left as localhost.

    This part I was confused .. about the shortest distance in the URL. At first I tried .. PetLvr.com/mypet/ but when I installed the script and despite that I was receiving this email message
    =============
    Your new WPMU site has been created at
    http://petlvr.com/mypet/
    Login details:
    Username: admin
    Password: xxxxxxxxxxx
    Login: http://petlvr.com/mypet/wp-login.php
    ==============

    When I clicked on the wp-login URL the site was redirecting to my basic site location, appended to the url .. like
    http://PetLvr.com/mypet//usr/bin/site##/web/petlvr.com/mypet/

    I've been reading around in here .. and thought I would try again .. I deleted both the wp-config.php file and the .htaccess file and went to run the index.php again. I was getting errors like duplicate database tables etc ..

    So I even deleted the MySQL database and recreate a new one and repeated above. Except, instead of the shortest URL being PetLvr.com/mypet/ I left it as PetLvr.com

    Now - when I click on the link http://PetLvr.com/mypet/wp-login.php .. or just http://PetLvr.com/mypet/ ... it routes back to the root directory http://PetLvr.com/

    What am I doing wrong? How can I get this to work in MU mode? I think it has something to do with that shortest URL box, right? It's like two different extremes somehow.

  2. PetLvr
    Member
    Posted 17 years ago #

    Can't seem to make a difference trying various things .. and I suppose I'm impatient waiting here, and reading forum. SO......... I'm going to try to reinstall this into the root directory, and use subdomains instead of subdirectories as the option. I will return to let you know if this works. // HART

  3. bolnikh
    Member
    Posted 17 years ago #

    Hi!

    I have absolutely the same problem with 1.0 version.
    After installation I can not login as admin, or even like ordinary user.

    No error in error.log - just message
    "[Tue Nov 14 11:27:02 2006] [error] install_blog - ID: 1 URL: http://mu_wordpress.loc/ Title: test blog ".

    I have second level domain, as you can see, but it still do not work.

    I did not find anything in forum that can help me to cope with it. It seem serious bug in code, so wait for next version?

  4. andrea_r
    Moderator
    Posted 17 years ago #

    PetLvr, what's the htaccess file like? Did it get created?

    bolnikh - have you set up a localhost on your desktop? I've got mine running on http://desktop.local with no probs.

  5. PetLvr
    Member
    Posted 17 years ago #

    Hi Andrea... here's an update ..

    I've installed MU in the root directory but was unable to create anything until I chmod 777 both the source ../wp-content/ folder and the source ../ root folder. I was able to do that for the wp-content, but I kept getting blocked with a 550 permission error on the root, so I contacted my ISP and he set it to 777 for the root.

    I then was able to create the part using the shortest URL as PetLvr.com and I got the email with the login

    But - I can't access http://PetLvr.com/wp-login.php at all .. and a whole bunch of other issues cropped up because my site is a mega site filled with many domain aliases and I think something got affected (we're looking at it).

    If I didn't know better - I would think I have to set the chmod on each wp-*.* file in addition to the root folder? Is that possible?

    Here is what my .htaccess looks like


    RewriteEngine On
    RewriteBase /
    # Rewrite http://www.domain.com to domain.com
    RewriteCond %{HTTP_HOST} ^www.(.*)
    RewriteRule ^(.*) http://%1/$1 [R,L]
    #uploaded files
    RewriteRule ^(.*)?/?files/(.*) wp-content/blogs.php?file=$2 [L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*.php)$ $2 [L]
    RewriteRule . index.php [L]

  6. drmike
    Member
    Posted 17 years ago #

    It appears that PetLvr is on a host that runs PHP as a CGI. (Please note that he or she is getting dropped in /usr/bin/) PHP should be run as an Apache module.

    I would suggest finding a new host.

  7. andrea_r
    Moderator
    Posted 17 years ago #

    Ah, that'll do it. How'd you figure that out Mike? I second his suggestion.

  8. PetLvr
    Member
    Posted 17 years ago #

    I'm not sure how to take that - but, have passed that along to my ISP (Blacksun.ca)

    This obviously is creating me headaches. I said that I deleted the subdirectory mypets above and the database which I gave the same name and have re-installed everything into the root folder. I have created a new database called publicblogs .. and tried to install.

    It does. and then when I access it - I get this message:

    Can’t select database
    We were able to connect to the database server (which means your username and password is okay) but not able to select the mypets database.

    the "MYPETS" database? Why is that back? there is no mypets anywhere existing on my site - except somehow on this installation.

    And - to make matters worse, I've even tried over and over several times deleting all the files and with a new copy and new installation - deleted the wp-config.php and .htaccess files .. and I still get that "mypets database" reference.

    My wp-config.php gets created ..


    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'mypets'); // The name of the database
    define('DB_USER', 'ssssss'); // Your MySQL username
    define('DB_PASSWORD', 'xxxxxxxx'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value
    define('VHOST', 'yes');
    $base = '/';
    // double check $base
    if( $base == 'BASE' )
    die( 'Problem in wp-config.php - $base is set to BASE when it should be the path like "/" or "/blogs/"! Please fix it!' );
    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = 'mypets_'; // example: 'wp_' or 'b2' or 'mylogin_'
    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');
    define( "WP_USE_MULTIPLE_DB", false );
    /* Stop editing */
    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

    I've "x'ed" out the username and password .. but do you see mypets keeps coming back!

    I can't believe the only solution is to move to another host.

  9. andrea_r
    Moderator
    Posted 17 years ago #

    "define('DB_NAME', 'mypets');"

    Because you keep calling it mypets and didn't tell it the new db name. If all else fails, and you are putting in the new db name and it keep recreating a new config file with the old db name, then just edit the config file and try to continue with the install.

    BUT.

    Running php as cgi is a really, REALLY old technique. (And you don't have to stick to a Canadian host either.) The biggest reason we're suggesting moving is because MU is not designed to be installed on a site that does this. You're just going to give yourself headaches and keep runnng in to problems.

    The "minor" drawback as php-as-cgi are listed here:
    # Variables in the URL which are not regular ?foo=bar variables won't work without using mod_rewrite (example.com/blah.php/username/info/variable).
    # Custom php directives in .htaccess files (php_include_dir /home/user;/home/user/example_dir) won't work.
    # The $_SERVER['SCRIPT_NAME'] variable will return the php.cgi binary rather than the name of your script

    And I know MU needs at least a couple of those.

  10. PetLvr
    Member
    Posted 17 years ago #

    Andrea .. I've nuked wp-config.php everytime .. and when I first start fresh with the install at the index.php .. I state that the database is publicblogs! not mypets!

    I've also got a reseller account that I use with another 30 other blogs I have - at Ace-Host.net - but for this thing to work for me, I need it to go on my PetLvr.com domain. Right now I'm not prepared to move from this mega site and my idea or need for WPMU wouldn't work on another domain name i.m.o.

    I will install on one of my many domains on the other ISP and maybe that will just prove to me that you are correct - that it's an ISP issue not a WPMU issue .. (I will keep this thread informed)

    In the meantime - I would still like to know how come AFTER I nuke everything (delete) - the file called wp-config.php keeps getting recreated and includes variables from last night? There is no "mypets" folder, or database or anything at all anywhere on my entire server nor is it mentioned anywhere on my server - except here and in the wp-config.php file everytime I do a new installation.

  11. andrea_r
    Moderator
    Posted 17 years ago #

    Please do keep us up to date. :) Eventually it helps someone else.

    And uh YEAH, that is super-weird it recreated the config with old info when you give it new info. That's another reason I suspect the host. (Yes, I've reinstalled things a few times).

    Also, if you go to do a test install on another domain, make sure it's a full account and not off a domain pointer. Any reason why you can't move your petlvr domain over to your reseller account?

  12. PetLvr
    Member
    Posted 17 years ago #

    I figured out the wp-config.php issue - apparently - when I first created it last night, in my install version copy - I put those variables (mypets) in the wp-config-sample.php file and accidentally saved it. Normally when I create new blogs I do that, then rename it to just wp-config.php. What happened last night is that when I copied over the 2nd copy after nuking everything - there was no wp-config.php but there was the same wp-config-sample.php with the old variables affecting each time I created a new installation and transferring itself to wp-config.php somehow.

    In the meantime - I've just registered a new domain and setup a new site on my other ISP reseller account. But - forgot about the issue - I'm still waiting for my ISP to do those extra modification re: apache as per readme.txt file.. I tried to set up something - and it didn't work either - I hope that's all the problems ... and ISP over there will help me out.

    The new site will be http://PetLvr-Blogs.com ... stay tuned to same PetLvr-channel and same PetLvr-time (and other Batman references while I figure if I can get this to work or there really is a problem here!)

  13. andrea_r
    Moderator
    Posted 17 years ago #

    Yep, in MU you normally do not touch the wp-config or the wp-config-sample. In the install process, MU creates it for you with the values you supply.

  14. PetLvr
    Member
    Posted 17 years ago #

    The saga continues ... My ISP #2 (Ace-Host.net) claims 100% for sure they cannot help me with MU and do the Apache settings as needed. Meanwhile, my ISP #1 is aware of all theories and issues (PHP should be run as an Apache module vs CGI) and claim this is incorrect somehow and not an issue and their server can comply to all requirements ..

    Also, ISP#1 has determined it was placing it in the root because of some other issues I have with my account, and it's conflicting. So - right now we're trying something new and see how it goes - after the name servers kicks in to route this domain back to another alias fixed location within my megasite ..

    (translation - he went home for supper and will get back to me later tonight!) oh well - I don't mind waiting another day. //

    Thanks for all support by the way.

  15. andrea_r
    Moderator
    Posted 17 years ago #

    If it helps, it took me three months to get my site up. :)

  16. PetLvr
    Member
    Posted 17 years ago #

    Andrea .. if you don't mind my asking ..where is your MU site .. is http://www.atypicalife.net/blog/ part of it?

    (I'm still waiting for name servers to kick in re:my journey and would like to look at a few installations and setups by others - do you have any recommended ones to look at?)

  17. andrea_r
    Moderator
    Posted 17 years ago #

    Nope, that's my personal site. Mu MU site is at http://homeschooljournal.net/. Feel free to poke around & ask questions. :)

  18. PetLvr
    Member
    Posted 17 years ago #

    CONCLUSION! http://PetLvr-Blogs.com

    It's working on my Canadian Host ISP#1 .. (my name servers just kicked over from ISP#2) despite DrMike's suggestion - and if Collin's looking at this - Thanks!

    The installation went perfectly normal.

    We set up the above domain as a domain alias (EDIT: of a folder under PetLvr.com) and everything seemed to work 100% instead of all the trouble doing it the root directory. Maybe if it was a new site it would make a difference, but probably it was because it was a longtime mega site with many things happening for me already that caused some conflicting issues - My guess.

    Anyway - THANKS ANDREA R (and DrMIKE)for support and being here while I was going through it - it makes a difference for those out here needing help.

    HART

  19. PetLvr
    Member
    Posted 17 years ago #

    Sorry .. I thought this was "resolved" and I just switched back to "not resolved".

    The MU site works great as I described above. Now, I tested it with a new blog installation at http://demo.petlvr-blogs.com .. but whenever a subdomain type was created (that was my 2nd one) .. my site is referring back to the original domain http://www.PetLvr.com

    (reminding that http://PetLvr-Blogs.com is a domain alias to http://PetLvr.com/petlvrblogs/ )

    Rather than being a twiddle-dee and mess things up .. I'm just going to wait until the morning help to arrive from my server ISP support.

    But Can I ask a question? (re: Plugins and MU-Plugins)

    This is my understanding. All plugins in ./plugins/. are not activated and will be available to everybody? And, all plugins in ./mu-plugins/. are automatically activated, but only available by the site admin in the options area..

    (Q) Is this correct? I can't test it because I can't access my demo site to practice .. and can't seem to find clarity on any support threads.

    T.I.A. // HART

  20. andrea_r
    Moderator
    Posted 17 years ago #

    re: plugins - you've almost got it. :)

    Plugins in the mu-plugins folder are automatically activated. *IF* they have an options menu (and the default ones in there don't) anyone will see them if that's how the plugin is designed. Some mu-plugins are designed so only the Site Admin sees them.

    Also, before you waste too much time beating your head here - having http://PetLvr-Blogs.com as domain alias just isn't going to work. It will always point back to the main domain at some point. See above where I said it took me three months to get mine going.

    What worked for me was changing my account type at my host so the second domain had its own cpanel.

    "probably it was because it was a longtime mega site with many things happening for me already that caused some conflicting issues"

    Yeah, that would be my guess too. What else is running on it?

  21. PetLvr
    Member
    Posted 17 years ago #

    Hi Andrea ..

    I received an email this morning that the redirection was 'fixed' by tech support .. so, not sure if what was mentioned was taken into consideration or if I will just receive future problems because of this domain alias issue.

    But - it does seem to be working and ditto for the permalinks .. I have now created a DEMO blog at http://demo.PetLvr-Blogs.com successfully now and looked around.

    Thanks for insights on plugin and usage. I am going to re-mark this as "resolved" now. Based on what you mentioned though, I'm not going to push for new blog users until I get all the themes, plugins, options and other issues and I'm also comfortable they are working satisfactory for both the main site and the demo site.

    Take care.
    HART

  22. andrea_r
    Moderator
    Posted 17 years ago #

    *whew* Glad to hear. :)

  23. PetLvr
    Member
    Posted 17 years ago #

    Hi Andrea .. I am back and need more help and set this back to unresolved. Here is an update for those finding this again.

    (1) Firstly .. my server runs their PHP as an Apache module. Running PHP as CGI is not supported by them. So, apparently that was never an issue

    (2) http://PetLvr-Blogs.com is a subdomain alias to my http://PetLvr.com/petlvrblogs/

    (3) My blog works fine. When I began to create a DEMO blog like http://demo.PetLvr-Blogs.com .. it was hard to create activate the blog because everything was being redirected to http://PetLvr.com domain. If I edited the domain to the (2) domain above .. then the blog would have been activated and work.

    (4) I contacted my server and received my response in my last comment and assumed this was fixed.

    (5) New: I then started to create multiple blogs and I was receiving the same problem, it always would redirect. Now I know what was being done and this is what I have to for every new creation of a blog in this MU version.

    - I go to my siteadmin panel, under Configuration and then Websites .. and basically manually set everything as a new domain alias!
    e.g. Before my second demo works .. I would have to set:
    demo2.petlvr-blogs.com >> to
    petlvrblogs >> folder under my main PetLvr.com account.

    (6) Above andrea asked me "Any reason why you can't move your petlvr domain over to your reseller account? ". Because my reseller account ISP#2 doesn't want to do that Apache modifications (and I am worried about future bandwidth and space which is finite over there, but more unlimited over on ISP#1. I really do not want to find ISP#3 just for this. The point was to utilize what I've got.

    ~~~
    Andrea .. can you advise me exactly how you got yours to work .. If it was the same specific issue as mine (domain aliases) - perhaps I can provide my tech support with the same specific answers so it can help me?

    I am assuming that when a new blog is created on your MU installation, you do not have to set the domain alias each and every time.

    PS: If need anything or want to take a peak inside.. that would be fine.

  24. andrea_r
    Moderator
    Posted 17 years ago #

    "Andrea .. can you advise me exactly how you got yours to work .. If it was the same specific issue as mine (domain aliases) - perhaps I can provide my tech support with the same specific answers so it can help me?"

    I got another account. :( Same host, same server even.

    What all do you have running under that one account?

  25. bolnikh
    Member
    Posted 17 years ago #

    I found problem.
    My IE do not store cookie. I do not know why.
    It's OK under Opera.

About this Topic