The MU forums have moved to WordPress.org

subdomains user don't work (5 posts)

  1. spaccioman
    Member
    Posted 15 years ago #

    Hi,
    i'd installed wpmu on my vps on the subdomain http://blog.spaccioworld.com Now i have created the first user account "mix1986" but the address mix1986.blog.spaccioworld.com don't work, infact i can't confirm the account on the address http://mix1986.blog.spaccioworld.com/wp-activate.php?key=1a4d7ee1793676fc I have inserted the mx record in dns *.spaccioworld.com but the trouble is the same: i can see only the error page of my plesk. What's i can do?

  2. andrea_r
    Moderator
    Posted 15 years ago #

  3. strixy
    Member
    Posted 15 years ago #

    If you are using a windows web server I have no idea how to help you.

    If you are using Linux, do you have access to your apache config files? (In a Debian distro it's in /etc/apache2)

    You will have to install and enable (turn on) the virtual hosting mod. (vhost.mod) available through apt-get or synaptic.

    You will have to edit sites-enabled.conf - this file will route requests for subdomains to appropriate directories in the server file path.

    Be sure to change the 'DocumentRoot' value and the <Directory> value below.

    Remember that domains are read from right to left and document paths are read left to right, generally speaking.

    <VirtualHost *:80>
    ServerAdmin webmaster@spaccioworld.com
    ServerName spaccioworld.com
    ServerAlias mix1986.blog.spaccioworld.com
    DocumentRoot /var/www/path/to/spacioworld/blog/mix1986
    <Directory var/www/path/to/spacioworld/blog/mix1986>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
    </Directory>
    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn
    </VirtualHost>

    If you are considering adding a lot of blogs to your domain, you might want to look at other options otherwise you will have to do this every time you add a new blog.

    I don't actually use WPMU so I can't say if this will work for you or not. I created my own multi-blog hosting site using Wordpress, Apache, a little php, and some Bash scripts.

    FYI, a 'mx record' is for email ;)

  4. spaccioman
    Member
    Posted 15 years ago #

    Thanks strixy,
    but if i configure virtualhost in this way you think that this not work?

    <VirtualHost *:80>
    ServerAdmin webmaster@spaccioworld.com
    ServerName spaccioworld.com
    ServerAlias *.blog.spaccioworld.com
    DocumentRoot /var/www/path/to/spacioworld/blog/*
    <Directory var/www/path/to/spacioworld/blog/*>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
    </Directory>
    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn
    </VirtualHost>

    unfortunately i must configure my server for multiple blog, and i want find the way...i thought that word press mu was already ready to work in this ways... in which way have you used normal word press to do multiple blog account? Thanks

  5. strixy
    Member
    Posted 15 years ago #

    I know from past experience that it won't. It looks like there are a lot of people who want to do this and unfortunately I just don't have the time to explain it today. It's actually a lot more complicated than it looks when you start looking at DNS resolution, hosting and DYNdns services. I can maybe do a full write up about it on the weekend.

About this Topic

  • Started 15 years ago by spaccioman
  • Latest reply from strixy