The MU forums have moved to WordPress.org

page bug and fix (18 posts)

  1. davidiyi
    Member
    Posted 15 years ago #

    when i visite the url with no slash in the end, like: http://blog.iyi.cn/start

    the page link will be showen like this:
    http://blog.iyi.cn/start/start/page/2/
    but the correct url should be
    http://blog.iyi.cn/start/page/2/
    there is a more "start" in the url

    the mistake is caused by "wp-includes/link-template.php" line 367
    $home_root = trailingslashit($home_root);

    i removed this line, the problem solved.

  2. Ovidiu
    Member
    Posted 15 years ago #

    is this a valid bug, concerning wpmu 1.0 ? has anyone else encountered this?

  3. davidiyi
    Member
    Posted 15 years ago #

    i'm using mu1.0

  4. zeug
    Member
    Posted 15 years ago #

    Is there a list of patches for Mu 1.0? I'm still on rc4 as I patched both the subdomain and subdirectory installs to a more or less stable version and when 1.0 final was released I did a test install of it and it seemed to have the same and maybe some different bugs.

    Haven't had the time to go back and fix it but I'll be updating to 1.0 as soon as I get a spare few seconds. Maybe if there's nothing already we could pool all our bug fixes and put them up on WPMuDev as an aid to new installs of the release version.

  5. andrea_r
    Moderator
    Posted 15 years ago #

    Trac is here:
    http://trac.mu.wordpress.org/

    This is not a bug, you must have put an extra /start/ in your setup somewhere.

  6. zeug
    Member
    Posted 15 years ago #

    Trac's fine, and the blog.iyi.cn url is loading fine for me so I guess the problem is fixed.

    I'm just interested in how buggy the official 1.0 release from 10/10 is, especially seeing as it's the one the majority of new users are probably downloading and installing.

  7. dsader
    Member
    Posted 15 years ago #

    davidiyi, you are not alone.

    Same thing happens to mine. My install is dated November 2.

    Load without the last slash

    http://www.domain.com/blog

    then click "previous page" yields

    http://www.domain.com/blog/blog/page/2/ and a 404.

    Problem is site wide. But needs a theme with the archive links.
    No other accidental mods have been made.
    Changing permalinks options does nothing.

    I didn't notice on my own blog since I use rolling archives with k2.

    I'll try a fresh sandbox install with nothing added on.

  8. dsader
    Member
    Posted 15 years ago #

    Brand new install(stable), same ../blog/blog/page/2 bug.

  9. dsader
    Member
    Posted 15 years ago #

    andrea_r, I agree with davidiyi, it appears to be a bug and his fix works for me too.

    Anyone else?

  10. davidiyi
    Member
    Posted 15 years ago #

    i have give out the fix

    the mistake is caused by "wp-includes/link-template.php" line 367
    $home_root = trailingslashit($home_root);

    remove this line

  11. zeug
    Member
    Posted 15 years ago #

    Ahhhh ... yep. Just happened to me too! index.php and the first posts_nav_link returned the double subdirectory page as in href="http://mydomain.com/blog/blog/page/2/" with a 404 not found.

    Commented out the trailingslashit line and it back to normal. This only just happened though which makes me think it's a db entry somewhere after I deleted a blank post and some old categories.

    I'm on a 1.0rc4 subdirectory install.

  12. conpeo
    Member
    Posted 15 years ago #

    without slash in the end?
    can i use this for forcing trailing slash for dirs?
    i refer here.
    http://steve.e-streets.net/2005/12/10/wpmu-and-htaccess/

    add following code in htaccess
    # force a trailing slash for dirs
    RewriteRule !\..{2,4}$ - [C]
    RewriteCond %{REQUEST_URI} !^.*/$
    RewriteRule ^(.+)$ /$1/ [R=301,L]

  13. alexo05
    Member
    Posted 15 years ago #

    FYI

    We just upgraded to WP Mu 1.1.1 and the new file still has that problem.

    However, do not use your patched file from the old install, as link-template.php was modified and the culprit line of code is elsewhere.

    It's now at line 427.

    Commenting it out will fix the problem.

  14. lunabyte
    Member
    Posted 15 years ago #

    Funny, I don't have that issue with 1.1.1.

  15. drmike
    Member
    Posted 15 years ago #

    That's cuz you're special, Luna. ;)

    Why am I thinking the poster is doing their WPMu install as an addon domain? I remember having the same issue when I tried that many eons ago and, when teh trailing slash wasn't there, it tried to load the main domain.

  16. lunabyte
    Member
    Posted 15 years ago #

    Aww... I'm special. :D

    That could be the issue though.

    Although I'm still trying to figure out why you would have a start link without passing a page number to it.

    All it's going to do is produce a 404, since there's nothing it can do with it.

  17. dsader
    Member
    Posted 15 years ago #

    The link-template fix above worked for me, again, on a new install. Would an if . . . else wrap around the line be a more permanent solution?

  18. mediafetish
    Member
    Posted 15 years ago #

    I found this thread after posting about this bug myself - removing the line isn't the proper fix - it should be altered I think. Perhaps I'm wrong...

    http://mu.wordpress.org/forums/topic.php?id=4564&replies=2

About this Topic

  • Started 15 years ago by davidiyi
  • Latest reply from mediafetish