The MU forums have moved to WordPress.org

MU on mediatemple's gridserver? (36 posts)

  1. twothirty230
    Member
    Posted 12 years ago #

    i've searched the forum, i've read the readme, i've googled. still no dice getting MU working on mediatemple's gridserver (even though i have several normal wordpress installs working with no problem). i still get the:

    "No WPMU site defined on this host."

    problem. suggestions? has anyone else got MU working with mediatemple's (gs)?

  2. jshare
    Member
    Posted 12 years ago #

    Nice timing, I'm just about to attempt the same thing right now. I'll post back when I'm done or hit a roadblock. Don't be afraid to ask MediaTemple support either; just because they don't support the app doesn't mean that they won't have suggestions.

    Jacob

  3. nocomment
    Member
    Posted 12 years ago #

    Have installed Mu on Mediatemple gridserver, using both in subdomain and with directory. Both cases simple as pie and no apparent issues.
    Would be interested in anyone with appropriate server knowledge to suggest whether this is a good setup for permanent home for Mu, as I am just playing at the moment and I have read that Mu should have its own server. Would not want to go too far if it will fall over in future.
    Also installed Xoops and Drupal and Serendipity to see what happened. All seemed fine.

    PS Server is at MediaTemple.net (gridserver).

  4. jshare
    Member
    Posted 12 years ago #

    Ok, this seems to work:
    1. Create a database for MU via Mediatemple's WebPanel > Manage Databases applet.
    1a. Once inside, click Add New Database.
    1b. Database name: add 'wpmu' after the provided tablename prefix. Note this name, of format db<site number>_wpmu for later. Leave MySQL 4.1.11 as the database type.
    2. SSH to Mediatemple using your serveradmin account as provided when you signed up to Mediatemple.
    3. Change directories until you're in <yourdomain>/html where <yourdomain> will be the primary WPMU domain (*.yourdomain).
    4. Download WPMU: wget http://mu.wordpress.org/latest.tar.gz
    5. Extract WPMU: tar zxf latest.tar.gz. This will create a directory at <yourdomain>/html/wordpressmu-1.0/. If you'd like, rename this to something else such as 'blogs' (as suggested in the newly-extracted README.txt). For the purposes of this guide, I didn't rename that directory.
    6. It is recommended that WPMU should be installed in the root web directory, which is <yourdomain>/html/, so we need to mv the files to there from <yourdomain>/html/wordpressmu-1.0/. Here are the steps to do so:
    6a. Assuming you are still in <yourdomain>/html, get into the new directory by typing: cd wordpressmu-1.0
    6b. Now copy the newly-extracted files up to the web root by typing: cp -R * ../
    6c. Move back up to the web root: cd ..
    6d. Now delete the unnecessary wordpressmu-1.0/ directory: rm -R wordpressmu-1.0
    7. Surf on over to http://<your domain>/index.php in order to fill in the WPMU installation form. The page will warn you about mod_rewrite needing to be installed, which it is globally on the Mediatemple grid server.
    7a. Choose a type of Blog Address
    7b. Database Name: remove the default value of 'wordpress' and insert the name of your WPMU database, which you noted earlier. Otherwise, you can find it in Mediatemple's WebPanel > Manage Databases applet. Example: db93423_wpmu
    7c. User Name: remove the default value of 'username' and insert the db username you received when you signed up to Mediatemple, which also corresponds to the first part of your Database Name before the underscore. Example: db93423
    7d. Password: remove the default value of 'password' and insert the db password you received when you signed up to Mediatemple.
    7e. Database Host: remove the default value of 'localhost' and insert the Internal Hostname you received when you signed up to Mediatemple and also found under Global database settings in Mediatemple's WebPanel? > Manage Databases applet.
    7f. Server Address: Either keep the default of <yourdomain> or change it as you like.
    7g. Weblog Title: fill in as desired.
    7h. Email: it is VERY IMPORTANT that this account be accessible to you, since WPMU will use it to send you a confirmation email once you are done. That email will have the WPMU admin login & password, so you definitely want to receive it. The sender will be 'wordpress@<yourdomain>' so if necessary, alter your spam settings NOW before the mail has been sent out.
    7i. Click Submit.
    8. If all has gone well, as it did twice for me, then you should see a short confirmation page saying 'Creating Database Config File: DONE'. Also, you should receive the aforementioned confirmation email.
    9. Click on the 'WPMU site' link, it will take you to the default blog in the WPMU install.

    Quickly Validating That It Really Works

    * Clicking all the links in the default blog worked fine.
    * I was able to write a comment for the default first post of the default blog.
    * I was able to login and use the WPMU admin panel successfully, although I didn't all the features available.
    * Adding a blog via the default blog works like a charm. However, adding a blog via the site admin generates an error page detailing:
    ** 3 failing SELECT queries, in other words, 3 db errors that the newly-created 'db<sitenumber>_wpmu.wp_*_options' table doesn't exist, even though it does if you check in Mediatemple's WebPanel > MySQL Admin and then select the WPMU database from the dropdown menu on the left side of the now-appearing phpMyAdmin page. Plus, if you refresh the Site Admin page, you will see the new blog which does appear to work just like a new WP install.
    ** A warning about not being able to modify header information.

    I'm trying to see where the errors are coming from and how to get rid of them (all suggestions are taken :) ). For now though, this setup seems to work very nicely. Good enough that I can tell Mediatemple to add WPMU to their list of gridserver-compatible apps.

    Jacob

  5. andrea_r
    Moderator
    Posted 12 years ago #

    - the SQL errors are a bug that's been fixed. please see trac.
    http://trac.mu.wordpress.org/

  6. jshare
    Member
    Posted 12 years ago #

    Found it: bug #184

    Thanks Andrea

  7. twothirty230
    Member
    Posted 12 years ago #

    jshare: thank you very much! i'm going to give that a try today or tmw... very detailed, i appreciate it.

  8. nocomment
    Member
    Posted 12 years ago #

    I have noticed that mediatemple seems to have taken down the Mu link on:-

    http://www.mediatemple.net/webhosting/gs/faq/grid_compatible_applications-faq.htm

    the above page of grid compatible applications.

    Did either of you have issues with this or are they just not too keen for everyone to have a Mu installation there?

  9. jshare
    Member
    Posted 12 years ago #

    Hey nocomment, thanks for pointing that out. I haven't had any problems, I'll ask MT support what happened; I was the one who got them to add it.

  10. brbreslin23
    Member
    Posted 12 years ago #

    i thought it was fairly easy to get MU to install on the grid. Once you get the db host figured out (not localhost) its pretty straightforward.

  11. jshare
    Member
    Posted 12 years ago #

    MediaTemple got back to me. It turns out that they had a change management problem resulting in an older compatibility page being used on their site. They've since put back the recent version which links the Grid server as WPMU-compatible.

  12. srotman
    Member
    Posted 12 years ago #

    OK. I've read this thread over and over and I am still having a problem!!!

    On my previous host I used "localhost" as the domain and had the db name as: mydomainaccount_mydbname which is similar to the (mt) setup. I have NO PROBLEM getting the whole blog up and running as a result. HOWEVER email DOES NOT WORK!!!

    I cant figure it out! I used to receive that welcome email when I opened a new blog telling me my new blog address, username, password, etc. Similarly when youre at the admin panel and you click "lost password" and type your username and email, nothing comes!

    Am I forgetting to set something?

  13. lunabyte
    Member
    Posted 12 years ago #

    Did you ask the kind folks at MT?

  14. amanzi
    Member
    Posted 12 years ago #

    I had problems setting up email accounts on MT. Are you using MT to manage the email for you domain? If so, have you set up email accounts for the email address that will be receiving the emails?

  15. jshare
    Member
    Posted 12 years ago #

    Srotman,
    It's a bit unclear - are you setting up WPMU on MT from scratch or are you using an existing WPMU db from your old host?

    More generally- in following my instructions above, was there any step where you needed to do something different? Or where you said to yourself 'it's not exactly what he says, but it probably won't matter'?

  16. urban10
    Member
    Posted 11 years ago #

    For those who have successfully gotten the subdomain setup working for WPMU on MediaTemple's Grid, did you have to perform any hacks to get the redirection working properly? I know that (mt) allows wildcard virtual hosts, but they state that a directory must exist in the root html directory that is the exact name of the subdomain.

    I'm sure I could create the directories on user sign-up and then setup the necessary symlinks to the master WP installation, but is there a better/easier method?

  17. lunabyte
    Member
    Posted 11 years ago #

    If you set-up according to the readme file, you'll be fine.

    No, you don't have to have a directory existing, as you are aliasing everything to your primary domain, and MU handles the rest.

  18. urban10
    Member
    Posted 11 years ago #

    Thanks for the quick reply... that worked. I must have been doing something wrong earlier that was preventing it from working properly.

  19. Yyrkoon
    Member
    Posted 11 years ago #

    I've followed the instructions in this thread to the letter. I've tried numerous other approaches to installing MU on my (gs) account at MT. All in vain.

    All I get when filling out the first page of the installation script is "Error establishing a database connection" on a new page.

    I've tried installing plain Wordpress using same credentials and SQL setup successfully. Same goes with Moveable Type, Vanilla and MediaWiki. Nothing wrong with my credentials.

    Once I managed to get the database setup, but according to error_log the setup was imperfect. Here are some of the lines in error_log:

    WordPress database error Unknown column 'blog_public' in 'field list' for query UPDATE wp_blogs SET blog_public = '1', last_updated = NOW() WHERE blog_id = '1' made by update_blog_status, referer: http://domain.com/index.php

    WordPress database error: [Unknown column 'blog_public' in 'field list'], referer: http://domain.com/index.php

    I fixed those errors manually in phpmyadmin, but couldn't load any page afterwards. All I got was the same old clean page screaming Error establishing a database connection at me.

    So.

    Can someone enlighten me into what I'm doing wrong, or some line and file to edit in the 1.5.1 version of MU in order to get it working?

  20. Trent
    Member
    Posted 11 years ago #

    Just installing with "localhost" doesn't work with Media Temple (gs) in wp-config.php. If you check the wp-config.php of a "1 click install" of WP 2.5.1 you will get the correct syntax needed, but for one of my installs it would be like such:

    define('DB_HOST', $_ENV{DATABASE_SERVER});

    instead of:

    define('DB_HOST','localhost');

    See if that helps get you connected.

    Trent

  21. lunabyte
    Member
    Posted 11 years ago #

    Or you can set your host to something like:

    internal-db.sXXXXX.gridserver.com

    Where the sXXXXX is your server number/domain they gave you.

  22. cafespain
    Member
    Posted 11 years ago #

    Yes you need to use the internal-db url instead of localhost.
    The correct string is shown on the Database panel page of your MU account centre.

    Once that is done and you have the wildcard dns set up the rest should work out of the box.

  23. Yyrkoon
    Member
    Posted 11 years ago #

    Cheers for your quick replies, however I've made sure that it has the correct values in wp-config.php. Right now it says:
    define('DB_HOST', 'internal-db.xYYYYY.gridserver.com');

    The thing is I can't find any errors in the error_log for mysql, so I cannot pinpoint exactly where stuff fails.

    What differs from plain Wordpress in the code, any pointers on where I should look?

  24. Trent
    Member
    Posted 11 years ago #

    With WPMU I had trouble with the internal addresses as well. Did you try my suggestion?

    Trent

  25. cafespain
    Member
    Posted 11 years ago #

    My wp-config.php is as follows:

    define('DB_NAME', 'dbxxxxx_cafespain'); // The name of the database
    define('DB_USER', 'dbxxxxx_cafe'); // Your MySQL username
    define('DB_PASSWORD', 'xxxxxxxx'); // ...and password
    define('DB_HOST', 'internal-db.sxxxxx.gridserver.com'); // 99% chance you won't need to change this value
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');
    define('VHOST', 'yes');
    $base = '/';

    Those are the only changes I made to the config file.

  26. Yyrkoon
    Member
    Posted 11 years ago #

    Trent - no luck with your suggestion.

    cafespain - except for the VHOST var, mine looks pretty much identical.

    I've sent in a support ticket to (mt) now. If any of you want to help, mail me at my mail addy given in my profile here.

  27. nocomment
    Member
    Posted 11 years ago #

    I have not looked in detail at this thread, but this strikes me:

    define('DB_USER', 'dbxxxxx_cafe'); // Your MySQL username

    unless you have changed this, it would normally just be:

    dbxxxxx

    without the:

    _cafe

    I might be completely wrong, but check and see.

  28. nocomment
    Member
    Posted 11 years ago #

    By the way, the reason I looked at this is simply because, once you have uploaded your files and gone to your installed location in your browser, it normally takes a few seconds to fill in the details and you are there.

    There is really nothing to do on the gridserver. Mu just jumps out of the box and runs.

  29. cafespain
    Member
    Posted 11 years ago #

    nocomment - you are correct. I had previously set up a new database user in the MT db admin panel with rights only to the MU database.

  30. nocomment
    Member
    Posted 11 years ago #

    Woops! Sorry!

    That'll teach me not to read through properly and then reply to the wrong person and the wrong problem.

    I'll just crawl back under my stone.

    However, for my quick tip of the day:

    If this is a new install with no data, my experience is that simply uninstalling and starting again is often quicker than keep trying to fix.

    As I said, it really should do all the work for you itself.

About this Topic

  • Started 12 years ago by twothirty230
  • Latest reply from easywizards