The MU forums have moved to WordPress.org

Dashboard not updating (14 posts)

  1. Farms2
    Member
    Posted 16 years ago #

    Hiya,

    Very odd - have changed the default feeds (only edit) in my wpmu dashboards but they are not updating... any idea what it could be?

    Cheers, James

  2. Farms2
    Member
    Posted 16 years ago #

    Very bizarre - I've just noticed that this has been happening on all my upgraded WPMU installs (the dashboard feeds not refreshing) whether I've edited the feeds or not.

    Wonder if this could be related to the no 'new blog to admin' email too? Are they governed by the same function?

    Regular WP dashboards on the same server continue to work just fine...

    Any thoughts?

  3. a-bishop
    Member
    Posted 16 years ago #

    I have the same problem. Moreover, when I try to use rss.php functions, it fetches feeds only once. It seems that this problem is related to wrong caching. Can anybody help? I have cache folder (I created it manually) in wp-content and all the rights to read/write are set...

  4. Farms2
    Member
    Posted 16 years ago #

    Glad (in a way) to hear I'm not the only one.

    Could this be down to older installations which have been upgraded?

  5. a-bishop
    Member
    Posted 16 years ago #

    Farms2, what exactly could be done?

  6. a-bishop
    Member
    Posted 16 years ago #

    It seems that something is broken in rss.php, so feeds are not updated. Nightly build contains the same file as 1.0 version. I've just renamed rss-functions.php from WP 2.0.5 to rss.php and replaced the original file with it. Seems it works.

  7. Farms2
    Member
    Posted 16 years ago #

    Dude! I'll try that fix tomorrow - great thinking.

  8. andrea_r
    Moderator
    Posted 16 years ago #

    The same happened to me, and I did the same thing: used the old rss-functions file instead of rss.php. It also fixed the problem i'd been having with my Flickr rss feeds not refreshing.

  9. kipit
    Member
    Posted 16 years ago #

    The same here.

    Adding to wp-config.php :
    define('ENABLE_CACHE', true);

    do the job... for the moment...

  10. andrea_r
    Moderator
    Posted 16 years ago #

    Had that, wasn't helping.

  11. Farms2
    Member
    Posted 16 years ago #

    Just to check... could there be any potential problems with using the wp 2.0.5 rss-functions.php renamed?

  12. dsader
    Member
    Posted 16 years ago #

    I HAD the same problem. Now, when I use one of my mu feeds in the dashboard, I use http://www.blog.tld/feed/wp-rss2.php rather than the usual http://www.blog.tld/feed/. I don't have any problems with feeds updating. I also use object cache enabled. I did nothing to the the rss.php. But I'm certain the object cache was the real fix.

  13. zimen
    Member
    Posted 15 years ago #

    So at the end what is it exactly that we have to do?

    enable cache? Use 2.0.5 file and rename? change address to .../wp-rss2.php?

    can you explain please?

    thank you

    Simon

  14. vladbuk
    Member
    Posted 15 years ago #

    All work if use adreess: http://www.blog.tld/feed/rss2

About this Topic