The MU forums have moved to WordPress.org

I need some major help (8 posts)

  1. DesignDroide
    Member
    Posted 15 years ago #

    I have asked everyone I know that know PHP and they can;t figure it out...
    please help me let me know if you got this same message?
    "No WPMU site defined on this host."

    to see it on the site goto : https://designdroide.com

  2. stutley
    Member
    Posted 15 years ago #

    Please search the forum. It's been covered several times.

  3. DesignDroide
    Member
    Posted 15 years ago #

    I dont know If I have done this right... I am trying to have it be my main page, not into a subdirectory or a subdomain but under me https. i researhed dsoem and it told me to edit these two file to be like this

    wp-config
    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'XXXX'); // DB Nmae
    define('DB_USER', 'XXXX'); // User Name
    define('DB_PASSWORD', 'XXXXXX'); // Pass word
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value
    define('VHOST', 'yes');
    $base = '/';

    // double check $base
    if( $base == 'BASE' )
    die( 'Problem in wp-config.php - $base is set to BASE when it should be the path like "/" or "/blogs/"! Please fix it!' );

    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = 'wp_'; // example: 'wp_' or 'b2' or 'mylogin_'

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    define( "WP_USE_MULTIPLE_DB", true );

    /* Stop editing */

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

    htaccess.dist

    RewriteEngine On
    RewriteBase /

    # Rewrite http://www.domain.com to domain.com
    RewriteCond %{HTTP_HOST} ^www\.(.*)
    RewriteRule ^(.*) http://%1/$1 [R,L]

    #uploaded files
    RewriteRule ^(.*)?/?files/(.*) wp-content/blogs.php?file=$2 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    basically am I doing this properly or am I going completely the wrong direction with my amepts???

  4. andrea_r
    Moderator
    Posted 15 years ago #

    *sigh*

    You're installing MU, right? Do *not* edit the config files. That's just for regular WP.

    Delete the htaccess.
    Delete the wp-config files.
    Check the database to see that all tables are dropped. Keep the database.

    Read the readme.txt.
    Run the install.

    Then come back and tell me what happened.

  5. DesignDroide
    Member
    Posted 15 years ago #

    ok so in my config file do not pu t in my DataBase info. just delete it? if that is correct i have done so and now I am lacking ssome stuff... I dont know what.

  6. andrea_r
    Moderator
    Posted 15 years ago #

    The config file is generated when you run the install. That's why it needs to be empty.

    Did you run the install?

  7. DesignDroide
    Member
    Posted 15 years ago #

    it gives my some error message
    what should my database be?

    ok so I should have no htacces or Config

    I am hfurther ahead in this et up i think at designdroide.com/blogs/ then at https://designdroide.com

  8. DesignDroide
    Member
    Posted 15 years ago #

    I contacted my hosting provider and they helped me fix it ...
    It had to do with the Chmod777

About this Topic

  • Started 15 years ago by DesignDroide
  • Latest reply from DesignDroide