The MU forums have moved to WordPress.org

Tarski breaks my 'Save' button (13 posts)

  1. Farms2
    Member
    Posted 15 years ago #

    This is really odd... when users have Tarski enabled as their theme they are able to 'Publish' posts but not to 'Save ' them.

    Clicking on 'Save' (with Tarski on) navigates them back to Manage>Posts without saving the content.

    Any ideas what could be going on???? It's tres weird.

  2. dsader
    Member
    Posted 15 years ago #

    I recall it had something to do with the rich text editor. No tinymce=no problems. But that's no good.

    I got as far as commenting out the prototype.js line in Tarski's functions.php, but no further. I forget what got busted doing that so I never fixed it.

  3. Farms2
    Member
    Posted 15 years ago #

    Time to go delving into functions... wish me luck ;)

  4. ceffyl
    Member
    Posted 15 years ago #

    I'm also having the same problem. I posted on the Tarski theme forum and have not received a reply. I would be grateful if you posted any solutions you might find.

    Ceffyl

  5. Farms2
    Member
    Posted 15 years ago #

    I've managed to isolate it but not got much further.

    It's contained in /js/prototype.js so if you remove around line 34 in functions.php:

    echo '<script src="' . get_bloginfo('template_directory') . '/js/prototype.js' .'" type="text/javascript"></script>';

    The problem will go away.

    However... so will the ability for your users to select theme headers - which kinda renders Tarski useless... sigh.

    So... what we need is someone who's comfortable enough with javascript to edit prototype.js so it doesn't stuff with the text editor (it also removes my Anarchy media player icons) but still allows users to click on different headers.

    Any takers?

    Cheers, James

  6. Farms2
    Member
    Posted 15 years ago #

    BTW I plan on releasing a new wpmu 'theme pack' as soon as I can get all of these bugs ironed out - it's gonna be nice, promise :)

  7. indiasex
    Member
    Posted 15 years ago #

    Free Nude Pictures Of Indian Girls Here
    free for you are these nude pictures of indian girls
    View Link:FUCKBOY.EU

  8. dsader
    Member
    Posted 15 years ago #

    Farms2, I even found other "prototype.js" from other themes. It is identical, replaced it even, solved nothing. But. . .

    Borrow K2s prototype.js.php and put into Tarski's js folder.

    I'm guessing it is not so much a flaw in prototype.js, but how or when it is called by Tarski.

    I put the following into Tarski's header.php just before the wp_head():
    <script type="text/javascript" src="<?php bloginfo('template_directory'); ?>/js/prototype.js.php"></script>

    Oh, and deleted the prototype.php line from Tarski's functions.php.

    All saves work. All headers work.

    Tada.(Until I hear what else I've broken)

  9. Farms2
    Member
    Posted 15 years ago #

    Followed your steps but haven't been able to get it to working for me :(

    Do you reckon it could just be a matter of reworking: add_action('admin_head', 'inject_tarski_js'); early on in functions.php?

    I'm wondering if there's a way we can inject the js to only the themes area... that should fix it right?

  10. dsader
    Member
    Posted 15 years ago #

    Look at the files downloaded when you load a front page from a tarski blog. Does the prototype.js.php file show up? I looked there to confirm that I was doing anything at all.(I use Safari-->Activity)

    Try putting all the js files into the the header.php, as in K2 and destroying the "inject_tarski_js" altogether.

    I don't know why Tarski is particular with these, otherwise common, js files. Many other themes put them in the header.php. They are miniscule, really.

    I'll try to blast all of 'em into the header.php

  11. dsader
    Member
    Posted 15 years ago #

    Try changing add_action('admin_head', 'inject_tarski_js');

    to

    add_action('wp_head', 'inject_tarski_js');

  12. dsader
    Member
    Posted 15 years ago #

    Indeed, there it is.

    Go back to an un-touched tarski and change only admin_head to wp_head in the functions.php.

    I'm laughing.

    Thanks a bunch.

  13. ceffyl
    Member
    Posted 15 years ago #

    It worked! You guys are awesome! Thank you!

    (Dancing off to reload the design I'd based on Tarski...)

    ~Ceffyl
    (a happy new WPMU admin)

About this Topic