The MU forums have moved to WordPress.org

How do I delete the default pages? (13 posts)

  1. dmaher
    Member
    Posted 15 years ago #

    I find that each theme comes with some default pages. They all have a HOME page and the one I'm working with now has a link to an illustration gallery. How do I get rid of them? I have this link to an illustration gallery on my page and it's really out of place. There are no options for it under the Site Admin and it doesn't show up under Page Management.

  2. stutley
    Member
    Posted 15 years ago #

    Well, the HOME-page is usually a link to the frontpage?

    Don't know about the gallery you are talking about. But WPMU also creates a default example page when the blog is set up.

    Comment out the lines in wpmu-functions.php somewhere around line 1240. That will prevent that page from being created in the first place.

    If you want to delete existing pages, you have to do it manually through the backend of each blog or by editing the database directly.

  3. andrea_r
    Moderator
    Posted 15 years ago #

    Delete them out of the theme folder.

  4. dmaher
    Member
    Posted 15 years ago #

    That's the thing, they don't show up on the backends of the blog. Just the ones I created do, not the default ones.

  5. andrea_r
    Moderator
    Posted 15 years ago #

    Like which ones? What themes?

    mayne this will give you a better understanding of how the included files work.
    http://codex.wordpress.org/Template_Hierarchy

  6. dmaher
    Member
    Posted 15 years ago #

    I'm using the MM3 theme and trying to remove the HOME page and also the Illustration Gallery page. Not just the pages, but the links to them on every other page. When I go into manage the pages in the Site Admin, they're not there. They came with the template.

  7. andrea_r
    Moderator
    Posted 15 years ago #

    You can't edit the themes themselves from the backend of MU. I am also not familiar with that theme. If you want me to look at it, you're gonna have to provide me with a link.

    If there are hardcoded links in the theme to nonexistant pages, you'll have to go into your file manager to edit the theme to remove them that way.

  8. dmaher
    Member
    Posted 15 years ago #

    The theme looks like this.
    http://www.danmaher.com/screenshot.jpg
    It's just a screenshot but you can see the illustration link I want to get rid of.

    So by going into the file manager you mean editing the files via the file manager on the server itself right? I didn't see any file manager on the backend of MU.

  9. andrea_r
    Moderator
    Posted 15 years ago #

    Yep, on the server. The theme editor is disabled in MU.

  10. dmaher
    Member
    Posted 15 years ago #

    Okay, now if I edit these files, will it keep that category out of there if the client makes a new page? I'm releasing this page to a client who will take ownership and update it themselves. I want it all to flow without having to edit source code.

  11. andrea_r
    Moderator
    Posted 15 years ago #

    I hate to sound testy here, but all you had to do was look at it to see that it is indeed a hard-coded link.

    Yes, I went and hunted the theme down, downloaded it, looked at the sidebar.pph file and there it is. Specifically this line:

    <li class="page_item"><a href="<?php bloginfo('url'); ?>/lazy-index.php">Illustration Gallery</a></li>


    Find it, nuke it. No, it won't come back, unless the blog owner specifically creates a new page with the name "Illustration gallery". Sheesh.
    Just because it's a theme for wordpress or MU, doesn't mean you won't have to touch the source code of it to get it just how you like. This is oh-so-true of WP as well. Many people release themes that need work or editing.

  12. dmaher
    Member
    Posted 15 years ago #

    Wow, that was embarassingly easy. Took me 2 minutes, sorry about that.

  13. dmaher
    Member
    Posted 15 years ago #

    I solved my problem with the themes too....somehow. I renamed the directory with the theme in it and uploaded it to the themes folder with the rest. Then I went into the Site Admin and made that theme active. I left the selection in the Presentation menu on the original theme (not the renamed one) and then went into the Site Admin for the blogs and changed the TEMPLATE and STYLESHEET fields to the new directory name. Presto, it's working. Case closed. Now I can edit the sidebar and footer like I want.

About this Topic