The MU forums have moved to

777 set but still requesting chmod (9 posts)

  1. blogga
    Posted 17 years ago #

    I am trying to install wpmu into the root of a subdomain


    First it said folder 'wpmu' and folder 'wpmu/wp-content' needed to be 777. I changed them, now no complaint about 'wpmu/wp-content' but it continues to say 'wpmu' is not set correctly.

    It definitely appears set as 777 but install doesn't think so. Any ideas please? Thank you

  2. lunabyte
    Posted 17 years ago #

    Try temporarily doing a 777 on your root directory as well.

    Just remember after install to put the root and directory for the subdomain back to 755 when it's done and you have it initially running.

  3. andrea_r
    Posted 17 years ago #

    Also, since you mentioned in another thread you wanted your users to have URLs like wpmu.domainname.tld/username/, bring it up one level from that /wpmu/ folder. Yes, I know it says put it in a folder in the instructions, but don't. Otherwise it's going to wind up as wpmu.domainname.tld/wpmu/username/ and that's *if* you manage to get it working. Too may subfolders and subdomains and MU goes all wonky.

  4. blogga
    Posted 17 years ago #

    thanks for both replies, i will try that lunabyte

    andrea, please clarify, I have created a subdomain and ftp'd all files into the root of this subdomain


    surely mu will not/cannot create user accounts as

    wpmu.domainname.tld/wpmu/username/ (will it?!)

    i want them to be



  5. andrea_r
    Posted 17 years ago #

    if they are in the root of the subdomain, you're fine. in the original post, you talked about the wpmu folder.

  6. blogga
    Posted 17 years ago #

    lunabyte, tried it, still no good.

    i'd welcome any suggestions why wpmu install thinks folder is not 777

  7. hunor
    Posted 15 years ago #

    Ran into the same problem installing Wordpress MU 2.6.3.

    What I found out is that the script checking if the given directory is writeable is a little bit flawed - at least for my configuration.

    The root of all evil is that the PHP function is_writable($dir) returns false, if the slash ('/') is missing from the end of $dir!

    So what to do? I solved this by hacking the file index-install.php and changing the function checkdirs() as follows:

    function checkdirs() {
    global $dirs;
    $return = true;
    $errors = array();
    foreach( (array) $dirs as $dir ) {
    if( $dir[strlen($dir)-1] != '/' ) {
    $dir .= '/';
    // END OF HACK
    if( false == is_writeable( $dir ) ) {
    $errors[] = $dir;

    I hope this helps.

  8. tdjcbe
    Posted 15 years ago #

    May want to bring that up on trac:

  9. extranonsense
    Posted 15 years ago #

    Try using this chmod script

    $filename = "configure.php";
    chmod("/customers/", 0444);
    echo "chmod for $filename was changed";

    just make sure that you edit the part for the filename unix path and CHMOD permission value

About this Topic

  • Started 17 years ago by blogga
  • Latest reply from extranonsense