The MU forums have moved to WordPress.org

Cannot Login to Admin Page (5 posts)

  1. mcblogs
    Inactive
    Posted 17 years ago #

    hi,

    i just installed wpmu at dreamhost and the installation was successful but i cannot login to the admin page.

    the email that was sent to me with my admin password gave me a link to login to:
    http://mysite.com/cgi-system/wp-login.php, however that page does not exist. it returns a "not found" page.

    so i ftp'd to see if i could locate the log in page and it looks like it is actually located at. http://www.mysite.net/testing/wpmu/wp-inst/wp-login.php, which makes sense because i installed it in a directly called testing/wpmu/.

    but after locating the page. i cannot successfully login to the page with my username and password (which was sent to me in email). after trying to login i get:

    The requested URL /cgi-system/wp-login.php was not found on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    any help would be greatly appreciated!!!

  2. ozgreg
    Member
    Posted 17 years ago #

    The issue is MU thinks your install is in cgi-system. Since Dreamhost by default run their domains as CGI-PHP it is very possible this setting is causing your grief.

    Try turning off this option in your domain tab. If this still fails, you may need to reinstall MU again

  3. mcblogs
    Inactive
    Posted 17 years ago #

    Hey, thanks for the help.

    i turned off the option Run PHP as CGI in dreamhost and tried logging in again. this time, i got a ton of errors (see below). should i leave Run PHP as CGI off and reinstall? Also, Dreamhost say that it's highly recommended to Run PHP as CGI. will this effect any other fuctions of dreamhost if i leave it off? thanks!

    Warning: session_start(): open(/tmp/sess_15c3def9e03714311b636e7f1073c93d, O_RDWR) failed: Permission denied (13) in /home/.maia/mysite.net/testing/wpmu/wp-inst/wp-content/mu-plugins/wp-hashcash.php on line 29

    Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/.maia/mysite.net/testing/wpmu/wp-inst/wp-content/mu-plugins/wp-hashcash.php:29) in /home/.maia/mysite.net/testing/wpmu/wp-inst/wp-content/mu-plugins/wp-hashcash.php on line 29

    Warning: Cannot modify header information - headers already sent by (output started at /home/.maia/mysite.net/testing/wpmu/wp-inst/wp-content/mu-plugins/wp-hashcash.php:29) in /home/.maia/mysite.net/testing/wpmu/wp-inst/wp-login.php on line 9

    Warning: Cannot modify header information - headers already sent by (output started at /home/.maia/mysite.net/testing/wpmu/wp-inst/wp-content/mu-plugins/wp-hashcash.php:29) in /home/.maia/mysite.net/testing/wpmu/wp-inst/wp-includes/pluggable-functions.php on line 199

    Warning: Cannot modify header information - headers already sent by (output started at /home/.maia/mysite.net/testing/wpmu/wp-inst/wp-content/mu-plugins/wp-hashcash.php:29) in /home/.maia/mysite.net/testing/wpmu/wp-inst/wp-includes/pluggable-functions.php on line 200

    Warning: Cannot modify header information - headers already sent by (output started at /home/.maia/mysite.net/testing/wpmu/wp-inst/wp-content/mu-plugins/wp-hashcash.php:29) in /home/.maia/mysite.net/testing/wpmu/wp-inst/wp-includes/pluggable-functions.php on line 172

    Warning: Unknown(): open(/tmp/sess_15c3def9e03714311b636e7f1073c93d, O_RDWR) failed: Permission denied (13) in Unknown on line 0

    Warning: Unknown(): Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in Unknown on line 0

  4. mcblogs
    Inactive
    Posted 17 years ago #

    hi,

    just a quick update:
    i've noticed that all the links are not working after installation. meaning, if i click on any link i get a not found page. example: if i'm at http://mysite.net/testing/wpmu/wp-inst/wp-login.php, enter my username and pass and i click on login, i get a page not found error--

    "Not Found
    The requested URL /cgi-system/wp-login.php was not found on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

    same thing if i click on "lost your password?", the header of the blog i created, etc.

    i first noticed this when i could not login to the admin page after installing last night and now i'm noticing that it's not just the admin page, it's all pages.

    did i miss something major here? the only thing i've done to try and fix the problem was turn off Run PHP as CGI in dreamhost's control panel but when i did that i got many more errors. could this be a wildcard issue?

    any suggestions? thanks in advance!!! j

  5. g8minhquan
    Member
    Posted 14 years ago #

    I got the same issue, then I figured out that you need to switch to PHP5 to solve the problem.
    Good luck

About this Topic

  • Started 17 years ago by mcblogs
  • Latest reply from g8minhquan