The MU forums have moved to WordPress.org

Multiple blog confusion (5 posts)

  1. topherrosado
    Member
    Posted 17 years ago #

    I have a problem on my wpmu site that I can't quite figure out. On the home blog, I am unable to edit posts/comments from the home page or post comments. Everytime I try, the link that is generated for either the edit link or to submit the comment form points to my personal blog.

    I thought it might have been an issue with a theme so I tried different ones, but it persists. Then I disabled my personal blog, and then the links started pointing to the blog I set up for my sitewide feed! It's only after I disabled both of the additional blogs under my admin account that I started seeing proper links.

    If it's happening to me, I imagine that it'll probably happen to any of my users who decided to have multiple blogs, so what can I do to fix this issue?

    http://gayteenresources.org/

  2. topherrosado
    Member
    Posted 17 years ago #

    Hate to bump my own post, but has anyone found a solution?

  3. andrea_r
    Moderator
    Posted 17 years ago #

    What does the generated link look like? I can't figure out much of anything just by looking at the site itself (not being an admin and all)> :) Also, the problem doesn't sound familiar, so I'm not sure what it could be.

  4. topherrosado
    Member
    Posted 17 years ago #

    Okay, if I go to post a comment on the home blog (http://gayteenresources.org/ ), the form action is sent to http://gayteenresources.org/topher/wp-comments-post.php. "Topher" is my personal blog, not the home blog.

    If I try to edit a comment or post, the links go to http://gayteenresources.org/topher/wp-admin/comment.php and to the respective file for editing posts. Again, the link on the home blog is erroneously pointing to my personal blog.

    If I disable my personal blog, then the links point to the planetgtr blog (my sitewide feed blog). It's not until I disable both of the other two blogs (topher & planetgtr) that the links correctly point to the home blog. All three blogs, home, topher, and planetgtr, are under the admin account.

  5. andrea_r
    Moderator
    Posted 17 years ago #

    Must be soemthign to do with being logged in, as when I go visits, if I click the "leave a coment" link, then I get redirected to the full article and the comment area, which of course says I must be logged in to leave a comment. But it has the correct URL for me. :D

    That *is* odd behavior, because I have a few admin blogs on my own system and haven't had that issue.

About this Topic

  • Started 17 years ago by topherrosado
  • Latest reply from andrea_r