The MU forums have moved to WordPress.org

latest.tar.gz (40 posts)

  1. plaverty
    Member
    Posted 17 years ago #

    So I just installed the "latest" version of WPMU, and I got through much of the installation, but when I get to this page:

    wpmu/main/wp-admin/install.php?step=2

    I get these errors:

    Warning: main(wp-includes/class-smarty.php): failed to open stream: No such file or directory in /www/data/httpd/htdocs/Facilities/CIS/patrick/wpmu/wp-inst/wpmu-settings.php on line 31

    Fatal error: main(): Failed opening required 'wp-includes/class-smarty.php' (include_path='') in /www/data/httpd/htdocs/Facilities/CIS/patrick/wpmu/wp-inst/wpmu-settings.php on line 31

    I simply untarred and followed the instructions. Why is a file not found?

  2. plaverty
    Member
    Posted 17 years ago #

    Just to fill in more info, everything is 777, owned by the web server and in the same group as the web server. I just parsed enough for the URL out of that error, put that in the browser and then the error on the screen becomes:

    Warning: main(../Smarty.class.php): failed to open stream: No such file or directory in /www/data/httpd/htdocs/Facilities/CIS/patrick/wpmu/wp-inst/wp-includes/class-smarty.php on line 8

    Fatal error: main(): Failed opening required '../Smarty.class.php' (include_path='.:/usr/local/lib/php') in /www/data/httpd/htdocs/Facilities/CIS/patrick/wpmu/wp-inst/wp-includes/class-smarty.php on line 8

    So then I did the same, pulled out just enough to call the class-smarty.php in the browser and I just get a blank screen with empty <body></body> tags in the source. Any guesses on what's wrong here?

  3. plaverty
    Member
    Posted 17 years ago #

    Ok, last update. I fixed it by creating an .htaccess file in the top level and putting in there:

    php_value include_path .

    It installed.

  4. donncha
    Key Master
    Posted 17 years ago #

    Thanks for that, I'll adjust the include() statement accordingly!

  5. gnukerman
    Inactive
    Posted 17 years ago #

    Are the nightlies, no longer nightlies?

    The latest.tar is still dated 05-19-05

  6. donncha
    Key Master
    Posted 17 years ago #

    You must have a cached version - mine shows a file dated May 23rd!

  7. soladon
    Inactive
    Posted 17 years ago #

    Is this what you mean ?

    php_value include_path /wpmu/wp-inst/

  8. soladon
    Inactive
    Posted 17 years ago #

    or something like

    php_value include_path ".:/path/to/include/files/"

    ?

  9. Farms
    Member
    Posted 17 years ago #

    ***mod_rewrite enabled but WPMU claims it isn't...***

    Hiya,

    Am trying to get the latest version to work and have mod_rewrite enabled but WPMU just won't believe me... http://brisbaneblogs.org

    Any ideas why / ways I could fix this?

    Cheers, James

  10. kimonostereo
    Inactive
    Posted 17 years ago #

    This is happening to me as well. I thought I was going nuts. Tried to post about it here but I couldn't :-(

    Can anyone help? I need to get this app to work :-)

  11. ballen
    Member
    Posted 17 years ago #

    Welcome to my life!!! I was going down that "I MUST be crazy" road too until I saw this... I really would LOVE to get this working, but I don't even know where to start. Is there any way that anyone knows to disable the mod_rewrite check on install?

  12. donncha
    Key Master
    Posted 17 years ago #

    You can't disable the check it because if mod_rewrite was working you'd be redirected internally to wp-inst/index.php.
    Check that there's a .htaccess file in the same directory. If it's not, then check if the webserver can write to that dir.
    I've installed it, and so have numerous others so it does work, good luck!

  13. kimonostereo
    Inactive
    Posted 17 years ago #

    Hi,
    Yes the directory is writable by the webserver but it still doesn't work. Still says that mod_rewrite doesn't work.

    If you'd like to see what I'm talking about feel free to email me.

  14. Farms
    Member
    Posted 17 years ago #

    me too... there's a .htaccess file, the dir is writable and mod_rewrite is on... any ideas / directions I could explore?

  15. donncha
    Key Master
    Posted 17 years ago #

    Farms - send me your apache config file, and details of what virtual host and directory location of your install. Send to donncha @ linux.ie please! Maybe I can spot something amiss.

  16. Farms
    Member
    Posted 17 years ago #

    Yer a legend... I certainly will, have asked my hosting providers... (who are also workiong on this) to provide it. Thanks for bearing with me!

  17. brumski
    Inactive
    Posted 17 years ago #

    I'm having the same problem - mod_rewrite is definitely enabled and in use by other scripts. So no clue why it be fussin' so :)
    And if I rename the htaccess-dist to .htaccess, I get a 500 error.
    I'd love to check this mojo out - any word on this?

  18. donncha
    Key Master
    Posted 17 years ago #

    If mod_rewrite is enable but doesn't seem to be working:
    1. Is there a .htaccess in the same directory as Changelog.txt?
    If yes, then what's the file size and permissions of it?
    If it's an empty file, then copy this code into a php file in the same directory and run it from your browser.
    if (is_writable( ".htaccess")) {
    echo 'The file is writable';
    } else {
    echo 'The file is not writable';
    }

    If it prints that the file is writeable then there's something very wrong and I'm stumped!

    Are you getting any errors about fopen like this?
    *Warning*: fopen(.htaccess): failed to open stream: Permission denied in */home/www/public_html/index.php* on line *113*

    If yes, then make doubly sure that that directory is writeable by the webserver.
    Try the following php:
    if( is_writeable( "/home/www/public_html/" ) ) {
    print "dir is writeable!";
    } else {
    print "dir is not writeable!";
    }

    To be honest, if all those tests show that the directory is writeable then I'm stumped. Are you running in safe_mode? Maybe it's impossible to create new files. Put the following in a php file in the same directory:
    $fp = fopen( "t.txt", "w" );
    fwrite( $fp, "hello world!" );
    fclose( $fp );

    I don't do any error checking above, but if the t.txt file is in the directory then file creation works fine.

    * Obviously change file and directory paths above to suit your local settings!

  19. soladon
    Inactive
    Posted 17 years ago #

    Hi, I have the same problem and tried the first part of code and the file .htaccess is writable. Also I tried the last part of code and it creates the file. It's the same for me, if I use the htaccess.dist renamed to .htaccess I get error500.
    I can't wait to try it out!
    Thanks

  20. NetAndif
    Inactive
    Posted 17 years ago #

    I have blogs.dir/1/
    Permissions are set to the apache user.
    But there are no files in there. So i get the No "Blog by that name on this system".
    Sorry, i somehow can't get into this.
    In my case, htaccess is ok and dir permissions are ok, i've verified this again and again.
    Donncha, you've obviously missed something...
    Could you please install it yourself on another machine?

  21. Farms
    Member
    Posted 17 years ago #

    Thanks for that Donncha, much appreciated.

    mod_rewrite is fine :o)

    Bizzarly though (and despite most definite much CHMODing) it claimed that the directory wasn't writeable.

    Having said that I ran (another) install) and this time what I'm getting is the redirection limit exceeded - see here: http://brisbaneblogs.org

    This *could* just be something to do with time (don't ask me why but these things seem to have sorted themselves out in the past???) but if anyone knows what might be going on here please let me know.

    Somehow my hosts managed to get londonblogs.org working no problemo... basically saying 'what's the problem, just follow the steps'... so could this be something to do with my access to the servers (versus theirs... and yours Donncha?)

    Thanks again!

    James

  22. Farms
    Member
    Posted 17 years ago #

    Oh, and can I just add, having got londonblogs.org working and just having looked at the back end, ahem:

    WOOOOOHOOOOOOO ABSOLUTELY BLOODY FANTASTIC ACE GREAT YEAH KABOOM ETC!

    Oh, and could someoen tell me how to include a 'create new blog' form like here: http://incsub.org/gcheblogs/how-do-i-get-started/

    Is it just the same process as before ?

  23. Farms
    Member
    Posted 17 years ago #

    I think I've figured it out... my hosting provider has set things up so that I can't make the dir writable by php scripts!

    Do you think this is it? If so I imagine it's the same problem other people are having?

    I've asked them if they can change this for installs... pain in the proverbial but if this is the problem then it explains a lot!!!

  24. kimonostereo
    Inactive
    Posted 17 years ago #

    nope. I can write to any directory and I still have the same problem.

  25. donncha
    Key Master
    Posted 17 years ago #

    kimonostereo - please take a look throug the index.php and pay attention to do_htaccess. If you can see any bugs in it I'll fix that, otherwise you can copy what my script does when copying htaccess.dist to .htaccess

  26. Farms
    Member
    Posted 17 years ago #

    Guess what... wasn't really the solution ... ho hum!

    But but but... I think I might be half way to the answer.... in my 'process of elimination' approach :o)

    After uploading the latest nightly (24th) and prior to uploading I checked the permissions for .htaccess: 644. So, I changed them to 777 for that and also for htaccess.dist (why not, I have no idea what it does anyway ;), ran the usual install details and it worked.

    Yeh there were a whole bunch of errors but studioblogs.net is up... and that's probably just as well considering that I'm running the intro tomorrow morning!!!

    Sweet.

  27. Farms
    Member
    Posted 17 years ago #

    Ah... now while the creation process for all new blogs is pretty smooth, you can't actually see them because all new sites, i.e. http://studioblogs.net/jamestest lead to studioblogs.net

    Something to do with .htaccess?

    Hmmmm... can anyone help me in the next few hours..

  28. soladon
    Inactive
    Posted 17 years ago #

    Hey

    I now have same problem as NetAndif had.
    I always get "No Blog by that name on this system." no matter which file I call..

    If somebody know why's that could you please give some help please ?
    thanks!

  29. Farms
    Member
    Posted 17 years ago #

    Will overcome this! In the meantime though I switched to using the old stable version :o)

  30. donncha
    Key Master
    Posted 17 years ago #

    If you try the unstable version which I've just created it has a lot more debugging information in the installer.
    Please copy and paste the information that it prints when you're posting a help request here!

About this Topic

  • Started 2024 years ago by plaverty
  • Latest reply from kimonostereo