The MU forums have moved to

Install Problems (infinite 302 redir) with W2K3/Apache2.0.59/PHP4.4 or 5.2 (14 posts)

  1. zappoman
    Posted 17 years ago #

    I am having problems getting WordpressMU to work. I am a relatively savvy guy with windows and unix sysadmin experience. But after long hours the last couple night trying to get this to work I am in need of help.

    * Windows Server 2003
    * WordpressMU 1.0
    * Apache 2.0.59
    * PHP (I've tried both 4.4.4 and 5.2.0)
    * MySql 5.0.27

    * Followed the instructions for Apach, PHP, and Wordpress, I believe I didn't leave any steps out.
    * Verified that Apache is working.
    * Verified that PHP is running fine.
    * Verified that PHP is able to connect to MySql
    * Verified that PHP is able to send email

    Setup Parameters:
    * Running blogs in directory NOT as subdomains.
    * The server is not; instead it is
    * The server is running on port 8080 not on port 80
    * I get the same behavior with PHP 4.x or 5.x, running as a CGI or SAPI plugin.

    * I've gotten past the main install process, WordpressMU press asks for its standard MySQL server/user questions.
    * Wordpress does it's DB stuff and I've verified that it creates all the standard wp_* tables in the MySql schema.
    * Note: I do get the error about category_descriptions not have default values. But this doesn't slow things down, I think this is a MySQL 5.0 thing, I'll deal with that later.
    * I get the email about the blog being available/new password/please activate.

    --- Here's where things go bad. ---

    At this point if I go back to the main URL ( or if I click on the link in the email to activate my blog (same url) my browser get's stuck in an infinite loop of 302 redirects for the URL ""

    Other interesting points:
    * If I explicitly reference some resources, like for example if I put a helloworld.html in the root directory than apache will serve it up ok. For example I can access ""

    * But other explicit resources, like /index.php or /wp-signup.php get this behavior.

    I suspected this problem was related to a 302 redirect problem I saw mentioned elsewhere, but now I can't find that forum post (maybe I was dreaming it in a state of sleep deprivation).

    I know this is a lot of detail, but I'm hoping that by posting these facts it will be clear that I do know what I'm doing and will gladly help by providing detailed bug reports and reproduce case.

    Thanks in advance... my family misses me. ;)


  2. zappoman
    Posted 17 years ago #

    Ok, well, I figured I'd give it one more go with Apache 2.2.3 and I still get the same behavior.

    Of course, I had to use PHP 5.2 to get Apache 2.2.3 to work, but I get the exact same behavior of the infinite 302 redirects.

    Any ideas?

    I can't possibly imagine this would be windows specific...

    But I guess my next step would be to setup a linux box... please someone help me before I go through the effort of finding and setting up another server. (the finding the machine is the harder part of that project) :)

  3. zappoman
    Posted 17 years ago #

    Just to make sure I wasn't completely crazy... I installed wordpress 2.0.6 on this setup, and everything seems to be working fine... No 302 redirection infinite loop from hell.

    So, I think this problem must be specific to WordpresMU.

    Please help.

  4. zappoman
    Posted 17 years ago #

    I've also attempted to get this working with using subdomains, thinking that possible the problem was related to the sub-directories feature. And I get the same behavior.

    I know you guys are busy. I love this product, I really want to use if for my community.

    Please ping me or reply to this post so that I know someone has at least read it. Thanks.

  5. lunabyte
    Posted 17 years ago #

    Read it. ;)

    Hate windows, and I'm sticking to the 1.x.xx branch of Apache ATM.

    Only suggestion is to try the 1.xx.xx branch of Apache, Mysql 4.1 branch, and php 4.4.X for kicks to see if it works.

  6. andrea_r
    Posted 17 years ago #

    "* Running blogs in directory NOT as subdomains.
    * The server is not; instead it is
    * The server is running on port 8080 not on port 80"

    Any one of these could be an issue too.

  7. zappoman
    Posted 17 years ago #

    Thanks lunabyte... I appreciate the comment.

    I just found a comment on tracs that seems to suggest this may be related to using a port number.

    01/09/07 13:35:14 changed by donncha

    • status changed from reopened to closed.
    • resolution set to wontfix.

    WPMU will now die if a port number is used. Unfortunately it's an edge case, and not used very often. At least it'll die now gracefully with an error message. Patches and fixes are welcome if your company depends on this facility.

    Yep... it looks like the MU gods have spoken and this is a bug, and it won't be fixed.

    Well, anyway, let me put in my suggestion that this bug should be fixed. There are plenty of good reasons to run MU on a port other than 80.

    But at least now, I know that I can stop pulling my hair out thinking I was doing something wrong.

    And for the record, it appears to have nothing to do with Windows.

  8. donncha
    Key Master
    Posted 17 years ago #

    zappoman - I don't have the time to fix that problem so unless someone else is willing to step up to the plate and write a patch it's going to stay unfixed unfortunately.

  9. zappoman
    Posted 17 years ago #

    I hear you man... I dig WordpressMU alot, and this is probably low on the feature list.

    I've set up a second server for now. I wanted to run on a non-standard port because I am also running IIS on this box with multiple domain support.

    I know, I know, I'm obviously a glutton for punishment to even attempt to do this. ;)

    I'll take a crack at looking through the code to see if I can offer a patch. It looks like others are bumping into the same problem.

  10. zappoman
    Posted 17 years ago #

    One more thing. For the record, I got things working just fine once I moved it to a second box using the standard port 80.

    So, using a domain like "" didn't seem to be a problem. I did opt for the subdomain approach for now, so my users blogs will be at ""... etc.

  11. HeadOnFire
    Posted 17 years ago #

    I have the same problem...

    Mac OS X 10.4.8
    Apache 2.2.0
    PHP 5.1.2
    MySQL 5.0.20a

    And I'm not using non-standard ports or subdomains - WordpressMU configured at

    After installation I see the page with text "This is a WordPress Mu powered site. You can: " and login link there. Clicking this link loads And here is the problem - i enter 'admin' and password received by email, but the page redirects to

    Last entries from Apache's access_log: - - [10/Jan/2007:16:31:14 +0200] "POST /wpmu/wp-login.php HTTP/1.1" 302 - - - [10/Jan/2007:16:31:14 +0200] "GET /wpmu/wp-admin/ HTTP/1.1" 302 - - - [10/Jan/2007:16:31:15 +0200] "GET /wpmu/wp-login.php?redirect_to=%2Fwpmu%2Fwp-admin%2F HTTP/1.1" 200 1760

    What's the problem?

  12. lunabyte
    Posted 17 years ago #

    For the domain, when you installed Mu, did you add it as, or add it as

    If I browse my wp_site table, I have 1 entry as follows:

    id = 1
    domain =
    path = /mut/

    This particular test is in the "mut" (MU Test) dir, off the root. Yours should be the same, except say /wpmu/ for the path.

    Check your wp_blogs table as well, and see that the domain and path match the wp_site table for id 1 (your primary site/blog)

  13. HeadOnFire
    Posted 17 years ago #

    2 lunabyte:

    Checked. All seems to be ok.
    One more note - all works fine in Firefox. This problem appears only in Safari. I suppose this is a cookie issue, not MU code or installation and not a web server problem. I have cookies enabled in Safari but it still don't store MU's cookie. But Firefox does. Strange...

  14. lunabyte
    Posted 17 years ago #

    This is strange.

    I primarily use FF. To be honest, Safari isn't even in my dock anymore.

    Let me see...
    - Yep. Does the same for in Safari too.

    Let me try one of my live sites...
    - Nope. All is well.

    So, it has to do something with being on (or maybe an ip), and Safari's cookies. (I'm guessing cookies).

About this Topic

  • Started 17 years ago by zappoman
  • Latest reply from lunabyte