The MU forums have moved to WordPress.org

comvatars probs (3 posts)

  1. Ovidiu
    Member
    Posted 15 years ago #

    hi there,

    I have some problems with comvatars. HTey were basically working but I want to change from the default implementation to template implementation. So I went to the options page and saw that I cannot go there.

    manage => comvatars leads to this url: http://sibiu.zice.ro/wp-admin/edit.php?page=comvatars.php

    options => comvatars leads to this url: http://sibiu.zice.ro/wp-admin/admin.php?page=comvatars.php

    which is the same page, namely the comvatars registration page.

    I tried this url manually: http://sibiu.zice.ro/wp-content/wp-comvatars-manager.php

    which leads to the same page...

    then I tried this ursl: http://sibiu.zice.ro/wp-content/plugins/comvatars.php which just leads to a white page...

    anyone got any ideas? or can someone give me the correct url if it was none of the above? I want to get to the comvatars plugin page...

  2. dsader
    Member
    Posted 15 years ago #

    My wp-comvatars-manager.php is in the same directory as wp-config.php. My folder comvatars is in wp-content, and comvatars.php is in mu-plugins.
    I am a No vhost install.
    My urls are uglier than yours:

    Manager(uncomment add_management_page in comvatars.php)
    http://sub.domain.tld/username/wp-admin/edit.php?page=/home/domain/public_html/sub/wp-content/mu-plugins/comvatars.php
    or from the front
    http://sub.domain.tld/username/wp-comvatars-manager.php

    Options
    http://sub.domain.tld/username/wp-admin/options-general.php?page=/home/domain/public_html/sub/wp-content/mu-plugins/comvatars.php

    What do you mean by "template implementation"?

  3. Ovidiu
    Member
    Posted 15 years ago #

    well, comvatar does not work for me inside mu-plugins, has hardcoded links to plugins folder, gives error:

    AWarning: main(wp-content/plugins/comvatars.php): failed to open stream: No such file or directory in /var/www/web5/web/wp-comvatars-manager.php on line 5

    Fatal error: main(): Failed opening required 'wp-content/plugins/comvatars.php' (include_path='.:/usr/share/php:/usr/share/pear:.:.') in /var/www/web5/web/wp-comvatars-manager.php on line 5

    did you edit your comvatars version to get it working inside mu-plugins?

    by template implementation I mean that I do not want comvatars appearing where they want, but where I want so I am trying to use: http://bluesome.net/post/2005/08/07/44/#tagimplementation

    which I successffully did, but if you use template tags you have to turn off the default comvatar placement...

    thx for the links, one of those adapted to my url worked for me.

About this Topic